<!DOCTYPE html>
<html lang="en">
  <head>
    <!-- Google Tag Manager -->
  <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','dataLayer','GTM-5GMVQ6J');</script>
  <!-- End Google Tag Manager -->






<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=yes">
<meta name="google-site-verification" content="Yn7U5qsaj-oKD3y_qp7IbGawlVoNxW1Pzu87ZOHqabU">
<meta name="view-id" content="article">



<title>Slog PM: Dick's Fries May Taste a Lil' Different, GameStop Reopens Downtown, Alex Jones Is Fucked - The Stranger</title>


  

  

  

  

  <meta name="twitter:card" content="summary_large_image" />
  <meta name="twitter:site" content="@thestranger" />
  <meta name="twitter:image" content="https://media2.fdncms.com/stranger/imager/u/cover/77304636/gettyimages-1229672856.jpg" />
  <meta property="og:title" content="Slog PM: Dick&#39;s Fries May Taste a Lil&#39; Different, GameStop Reopens Downtown, Alex Jones Is Fucked" />
  <meta property="og:description" content="The Stranger&#39;s evening news roundup." />
  <meta name="description" content="The Stranger&#39;s evening news roundup." />
  <meta property="og:site_name" content="The Stranger" />
  <meta property="og:type" content="article" />
  <meta property="og:image" content="https://media2.fdncms.com/stranger/imager/u/cover/77304636/gettyimages-1229672856.jpg" />
  <meta property="article:publisher" content="https://www.facebook.com/https://www.facebook.com/strangerseattle" />
  
    
  
  <meta name="apple-mobile-web-app-title" content="Slog PM: Dick's Fries May Taste a Lil' Different, GameStop Reopens Downtown, Alex Jones Is Fucked - The Stranger" />
  

  <link rel="mask-icon" href="https://www.thestranger.com/assets/sites/stranger/images/site-badge.svg" color="#000000">
  <link rel="icon" type="image/x-icon" href="https://www.thestranger.com/assets/sites/stranger/images/favicon.png">

  
    <meta property="fb:app_id" content="43933993878"/>
  
  
    <meta property="fb:admins" content="741428065"/>
  
  
    <meta property="fb:pages" content="56439755991" />
  

  

  
  
  
    <link rel="canonical" href="https://www.thestranger.com/slog-pm/2022/08/03/77289174/slog-pm-dicks-fries-may-taste-a-lil-different-gamestop-reopens-downtown-alex-jones-is-fucked" />
    <meta property="og:url" content="https://www.thestranger.com/slog-pm/2022/08/03/77289174/slog-pm-dicks-fries-may-taste-a-lil-different-gamestop-reopens-downtown-alex-jones-is-fucked" />
  
  
  


<link rel="alternate" type="application/rss+xml" title="The Stranger: Whole Site" href="/seattle/Rss.xml"/>


  
    <link rel="alternate" type="application/rss+xml" title="The Stranger: Articles by Jas Keimig" href="/seattle/Rss.xml?author=32434319"/>
  


 

<!-- typekit -->
<link rel="stylesheet" href="https://use.typekit.net/hrt1inn.css">

<!-- revved -->

<link href="https://www.thestranger.com/assets/build/css/styles.f1389505.css" rel="stylesheet">


<script src="https://code.jquery.com/jquery-3.6.0.min.js" integrity="sha256-/xUj+3OJU5yExlq6GSYGSHk7tPXikynS7ogEvDej/m4=" crossorigin="anonymous"></script>

<script src="https://cdn.jsdelivr.net/npm/bootstrap@5.1.3/dist/js/bootstrap.bundle.min.js" integrity="sha384-ka7Sk0Gln4gmtz2MlQnikT1wXgYsOg+OMhuP+IlRH9sENBO0LRn5q+8nbTov4+1p" crossorigin="anonymous"></script>

<script src="https://kit.fontawesome.com/1a5dd3b0ab.js" crossorigin="anonymous"></script>

<script src="/seattle/Library/Environment/JavascriptEnvironmentScript"></script>


  <script src="https://www.thestranger.com/assets/build/js/app.80ba9c21.js"></script>














<script type="text/javascript">
     var _sf_async_config = _sf_async_config || {};
     /** CONFIGURATION START **/
     _sf_async_config.uid = 65679
     _sf_async_config.domain = "thestranger.com";
     _sf_async_config.useCanonical = true;
     /** CONFIGURATION END **/
     var _sf_startpt = (new Date()).getTime();
</script>
<script src="//static.chartbeat.com/js/chartbeat_mab.js"></script>
  </head>
  <body class="article stranger">
    <div class="wrapper">
      <div class="container-fluid header g-0">
        <nav>
          <div id="leaderboardDrawer" class="component leaderboard py-4 px-4 px-md-0 bg-gray-1" style="display:none;">
  <div class="row g-0">
    <div class="col text-center">
      <div id="div-gpt-ad-top-super"></div>
      <div id="div-gpt-ad-mobile-top"></div>
    </div>
  </div>
</div>


      

    
      
      
      
      
      
      
      
      
      






<div class="network-bar bg-white d-none d-md-block">
  <div class="container">
    <div class="row py-3">
      <div class="col">
        <div class="d-flex justify-content-center align-items-end">
          
            <a class="nav-link text-black ff-serif mx-2 text-uppercase fs-8" href="https://thestranger.com" target="self">The Stranger</a>
          
            <a class="nav-link text-black ff-serif mx-2 text-uppercase fs-8" href="https://everout.com/seattle/" target="self">EverOut</a>
          
            <a class="nav-link text-black ff-serif mx-2 text-uppercase fs-8" href="https://portlandmercury.com" target="self">Portland Mercury</a>
          
          <span class="d-inline-block mx-2 p-2"><img src="/assets/3/base/images/index-logo.png" style="max-height:18px;"></span>
          
            <a class="nav-link text-black ff-serif mx-2 text-uppercase fs-8" href="https://savage.love/" target="_self">Savage Love</a>
          
            <a class="nav-link text-black ff-serif mx-2 text-uppercase fs-8" href="https://humpfilmfest.com" target="_self">Hump</a>
          
            <a class="nav-link text-black ff-serif mx-2 text-uppercase fs-8" href="https://boldtypetickets.com" target="_self">Bold Type Tickets</a>
          
        </div>
      </div>
    </div>
  </div>
</div>


      

    
      
      
      
      
      
      
      
      
      














<div class="main-nav article">
  <div class="container">
    <div class="row g-0">
      <div class="d-flex justify-content-center">
        <div class="above-navbar-ad hide-if-no-ad">
        </div>
        
      </div>
      <div class="navbar py-2 py-md-4 px-4 px-md-0 flex-nowrap">
        <button class="navbar-toggler link-icon text-decoration-none p-0" type="button" data-bs-toggle="collapse"
          data-bs-target="#primaryNavigation"
          aria-controls="primaryNavigation" aria-expanded="false"
          aria-label="Toggle navigation">
          <div class="animated-nav-icon"><span></span><span></span><span></span></div>
        </button>
        
          <a class="navbar-brand d-inline-block m-3 text-center text-md-start" style="width:250px;" href="/">
            <img class="img-fluid" src="https://www.thestranger.com/assets/sites/stranger/images/site-logo.png?20220525222143" alt="The Stranger">
          </a>
        
        
          <div class="in-navbar-ad hide-if-no-ad d-none d-lg-block">
            <div id="div-gpt-ad-masthead"></div>
          </div>
        
        <div>
          <div id="navbarSearch">
            <div class="d-flex justify-content-end align-items-center">
              <a data-toggle="collapse" href="#navbarSearchForm" class="link-icon"><i class="fa fa-search"></i></a>
              <form action="/search" id="navbarSearchForm" class="collapse navbar-form ms-4" role="search" required>
                <input name="q" id="q" type="text" class="form-control" placeholder="Search" name="srch-term" id="srch-term">
              </form>
            </div>
            <script>
              $("#navbarSearch a.link-icon").click(function(){
                $(this).siblings('#navbarSearchForm').toggleClass("search-open");
                $(this).siblings("#navbarSearchForm").toggle();
                if($(this).siblings('#navbarSearchForm').hasClass('search-open')) {
                  $(this).siblings("#navbarSearchForm").find('.form-control').focus();
                }
                return false;
              });
            </script>
          </div>
        </div>
      </div>
    </div>
    <div id="primaryNavigation" class="collapse p-4" style="margin-top: -3.5rem;">
      <div class="row">
        <div class="col-12 px-4">
          <div class="mb-2">
            <a href="/" target="_blank">
              <img src="/assets/3/sites/stranger/images/site-logo-darkbg.png" alt="The Stranger" style="max-height: 26px;">
            </a>
          </div>
        </div>
      </div>
      <div class="row">
        <div class="col-6 px-4">
          <ul class="list-unstyled mb-0">
            
            
              <li class="nav-item my-3 my-md-2">
                <a class="fw-medium fs-5 text-decoration-none" data-silo="ttr" href="https://www.thestranger.com/slog" target="_self">
                  Slog
                </a>
              </li>
            
              <li class="nav-item my-3 my-md-2">
                <a class="fw-medium fs-5 text-decoration-none" data-silo="ttr" href="https://www.thestranger.com/savage-love" target="_self">
                  Savage Love
                </a>
              </li>
            
              <li class="nav-item my-3 my-md-2">
                <a class="fw-medium fs-5 text-decoration-none" data-silo="ttr" href="https://www.thestranger.com/slog-am-pm" target="_self">
                  Slog AM/PM
                </a>
              </li>
            
              <li class="nav-item my-3 my-md-2">
                <a class="fw-medium fs-5 text-decoration-none" data-silo="ttr" href="https://www.thestranger.com/news" target="_self">
                  News
                </a>
              </li>
            
              <li class="nav-item my-3 my-md-2">
                <a class="fw-medium fs-5 text-decoration-none" data-silo="ttr" href="https://www.thestranger.com/weed" target="_self">
                  Weed
                </a>
              </li>
            
          </ul>
        </div>
        <div class="col-6 px-4">
          <ul class="list-unstyled mb-0">
            
              <li class="nav-item my-3 my-md-2">
                <a class="fw-medium fs-5 text-decoration-none" data-silo="ttr" href="https://www.thestranger.com/music" target="_self">
                  Music
                </a>
              </li>
            
              <li class="nav-item my-3 my-md-2">
                <a class="fw-medium fs-5 text-decoration-none" data-silo="ttr" href="https://www.thestranger.com/stickers" target="_self">
                  Sticker Patrol
                </a>
              </li>
            
              <li class="nav-item my-3 my-md-2">
                <a class="fw-medium fs-5 text-decoration-none" data-silo="ttr" href="https://www.thestranger.com/arts" target="_self">
                  Arts
                </a>
              </li>
            
              <li class="nav-item my-3 my-md-2">
                <a class="fw-medium fs-5 text-decoration-none" data-silo="ttr" href="https://www.thestranger.com/food-and-drink" target="_self">
                  Food & Drink
                </a>
              </li>
            
              <li class="nav-item my-3 my-md-2">
                <a class="fw-medium fs-5 text-decoration-none" data-silo="ttr" href="https://www.thestranger.com/collections/74726477/elections-2022" target="_self">
                  Elections 2022
                </a>
              </li>
            
          </ul>
        </div>
      </div>
      <div class="row mt-2">
        <div class="col-12">
          <hr class="text-gray-2">
        </div>
      </div>
      
        <div class="row mt-2">
          <div class="col-12 px-4">
            <div class="mb-2">
              <a href="https://everout.com/seattle" target="_blank">
                <img src="/assets/sites/everout/everout-logo-small-white.png" alt="EverOut" style="max-height: 22px;">
              </a>
            </div>
          </div>
        </div>
        <div class="row">
          <div class="col-12 px-4">
            <ul class="list-unstyled mb-0">
              <li class="nav-item my-3 my-md-2">
                <a class="fw-medium fs-5 text-decoration-none" href="https://everout.com/seattle/top-events/" target="_blank>">
                  Top Events Today and This Week
                </a>
              </li>
              <li class="nav-item my-3 my-md-2 text-gray-3">
                
                  <a class="fw-medium fs-5 text-decoration-none" href="https://everout.com/seattle/music/" target="_blank>">
                    Live Music
                  </a>
                  &bull;
                
                  <a class="fw-medium fs-5 text-decoration-none" href="https://everout.com/seattle/arts/" target="_blank>">
                    Arts
                  </a>
                  &bull;
                
                  <a class="fw-medium fs-5 text-decoration-none" href="https://everout.com/seattle/food/" target="_blank>">
                    Food
                  </a>
                  &bull;
                
                  <a class="fw-medium fs-5 text-decoration-none" href="https://everout.com/seattle/" target="_blank>">
                    & More!
                  </a>
                  
                
              </li>
            </ul>
          </div>
        </div>
      
      <div class="row mt-2">
        <div class="col-12">
          <hr class="text-gray-2">
        </div>
      </div>
      <div class="row mt-2">
        <div class="col-12 text-center">
          <a href="/contribute" class="text-warning fw-bold">Support The Stranger</a>
        </div>
      </div>
      <div class="row mt-2">
        <div class="col-12">
          <hr class="text-gray-2">
        </div>
      </div>
      
        <div class="row mt-2">
          <div class="col-8 px-4">
            <ul class="list-unstyled legal-links mb-0">
              
                <li><a class="fw-medium fs-5 text-decoration-none" href="https://www.thestranger.com/masthead">Masthead</a></li>
              
                <li><a class="fw-medium fs-5 text-decoration-none" href="https://www.thestranger.com/ad-info">Ad Info & Rates</a></li>
              
                <li><a class="fw-medium fs-5 text-decoration-none" href="https://www.thestranger.com/jobs">Jobs at The Stranger</a></li>
              
                <li><a class="fw-medium fs-5 text-decoration-none" href="https://www.thestranger.com/contact-information">Contact</a></li>
              
                <li><a class="fw-medium fs-5 text-decoration-none" href="https://www.thestranger.com/privacy-policy">Privacy Policy</a></li>
              
                <li><a class="fw-medium fs-5 text-decoration-none" href="https://www.thestranger.com/terms-of-use">Terms of Use</a></li>
              
                <li><a class="fw-medium fs-5 text-decoration-none" href="https://www.thestranger.com/takedown-policy">Takedown Policy</a></li>
              
            </ul>
          </div>
          <div class="col-4 px-4 text-end">
            
              <span class="fa-stack tw-share share-tools" style="vertical-align: top;" data-href="https://twitter.com/thestranger/">
                <i class="fa-solid fa-circle fa-stack-2x text-dark"></i>
                <i class="fa-brands fa-twitter fa-stack-1x fa-inverse"></i>
              </span>
            
            
              <span class="fa-stack tw-share share-tools" style="vertical-align: top;" data-href="https://instagram.com/thestrangerseattle/">
                <i class="fa-solid fa-circle fa-stack-2x text-dark"></i>
                <i class="fa-brands fa-instagram fa-stack-1x fa-inverse"></i>
              </span>
            
            
              <span class="fa-stack tw-share share-tools" style="vertical-align: top;" data-href="https://facebook.com/https://www.facebook.com/strangerseattle/">
                <i class="fa-solid fa-circle fa-stack-2x text-dark"></i>
                <i class="fa-brands fa-facebook fa-stack-1x fa-inverse"></i>
              </span>
            
          </div>
        </div>
        <div class="row mt-3">
          <div class="col-12 text-center">
            <div id="mainNavAccountMenu" class="mt-2">
              <a href="/login" class="text-decoration-none mx-3"><i class="fa-regular fa-person-to-portal fa-xs"></i> Log In</a>
              <a href="/login/create" class="text-decoration-none mx-3"><i class="fa-regular fa-file-signature fa-xs"></i> Sign Up</a>
            </div>
          </div>
        </div>
      
      
        <div class="row mt-3">
          <div class="col-12 px-4 text-gray-3 fs-7">
            All contents &copy; Index Newspapers LLC<br>
800 Maynard Ave S, Suite 200, Seattle, WA 98134
          </div>
        </div>
      
    </div> <!-- end primaryNavigation -->
  </div> <!-- end container -->
</div> <!-- end main-nav -->



      

    
      
      
      
      
      
      
      
      
      






      <div class="trending-links">
      <div class="container">
        <div class="row g-0 mb-0 mb-md-4 py-3 border-bottom border-top align-items-center justify-content-center">
          
            <div class="trending-link-item col-12 col-md-4 text-center py-2 px-4 border-end">
              <a class="text-decoration-none ff-serif fs-5 fs-md-4 text-black" href="https://www.thestranger.com/books/2022/08/02/77175064/killer-prophets" target="_self">Killer Prophets? ⛪️</a>
            </div>
            
              <div class="d-block d-md-none text-center mx-auto text-gray-4 w-25"><hr class="my-0"></div>
            
          
            <div class="trending-link-item col-12 col-md-4 text-center py-2 px-4 border-end">
              <a class="text-decoration-none ff-serif fs-5 fs-md-4 text-black" href="https://www.thestranger.com/stranger-suggests/2022/08/03/77282940/hear-ye-hear-ye-its-renaissance-faire-time" target="_self">Hear ye, hear ye!! 🧝&#8205;♀️</a>
            </div>
            
              <div class="d-block d-md-none text-center mx-auto text-gray-4 w-25"><hr class="my-0"></div>
            
          
            <div class="trending-link-item col-12 col-md-4 text-center py-2 px-4 ">
              <a class="text-decoration-none ff-serif fs-5 fs-md-4 text-black" href="https://www.thestranger.com/stranger-suggests/2022/08/03/77288434/kexp-has-been-the-coolest-radio-station-for-half-of-a-century" target="_self">Celebrate KEXP's 50th 🎂</a>
            </div>
            
          
        </div>
      </div>
    </div>
        </nav>
        <div class="row top-span g-0">
          <div class="col-12">
            <div id="articleTop-77289174" class="component article-top text-center mb-5">
      <div class="row justify-content-center my-4 my-md-5 py-0 pb-md-5 pt-md-3 g-0">
        <div class="col-12 col-md-8">
          <div class="date-and-collection mb-4 fs-3">
            
              <a class="article-collection text-uppercase ff-condensed text-primary text-decoration-none mx-1 text-nowrap border-end pe-3" href="/collections/74529062/slog-pm">Slog PM</a>
            
            <span class="release-date ff-serif text-gray-3 ps-2">Aug  3, 2022 at  5:39 pm</span>
          </div>
        </div>
        <div class="row justify-content-center">
          <div class="col-12 col-md-8">
            <h1 class="headline mb-4 ff-header fw-bold">
              
                Slog PM: Dick's Fries May Taste a Lil' Different, GameStop Reopens Downtown, Alex Jones Is Fucked
              
            </h1>
          </div>
        </div>
        
        
          <div class="row justify-content-center">
            <div class="col-12 col-md-8">
              <div class="byline text-uppercase fs-5 fs-md-3">
                <a href="https://www.thestranger.com/authors/32434319/jas-keimig">Jas Keimig</a>
              </div>
            </div>
          </div>
        
      </div>
      
        
        <div class="cover-image">
          <img class="img-fluid hide-if-missing" src="https://media2.fdncms.com/stranger/imager/u/cover/77304636/gettyimages-1229672856.jpg" alt="">
          
            <div class="image-caption px-3 px-md-0">
              Alex Jones, pictured here in 2020, seeming to have an extremely rare reflective moment.
              
                <span class="image-credit ps-1">Elijah Nouvelage/Getty</span>
              
            </div>
          
        </div>
      
    </div> <!-- end component -->
          </div>
        </div>
      </div> <!-- header container -->
      <div class="container main">
        <div class="row top justify-content-center">
          <div class="col-12 col-md-6">
            <div id="div-gpt-ad-native-article-sponsorship-label"></div>
  <div id="articleBodyComponent-77289174" class="component article-body my-1 fs-3 ff-serif fw-light">
    
    

    

    
      
      
      
      
      
      
      
        
        
        
        
          
          <p><strong>We're still in the post-election afterglow: </strong>Even though voter turnout was less than 25%—yikes. That number is so concerning, a KOMO strategist <a href="https://komonews.com/news/local/washington-state-voter-turnout-less-than-25-percent-for-primaries">speculates</a> we should change the primary date to someday in September or during the school year to capture more attention. Some races in the county are still settling, but our <em>Stranger</em> analysts' major takeaway boiled down to: <a href="https://www.thestranger.com/elections-2022/2022/08/03/77278857/six-takeaways-from-washingtons-2022-midterm-primaries">WHAT RED WAVE??????</a> Will explained <a href="https://www.thestranger.com/elections-2022/2022/08/03/77297349/ballot-drop-update">today's ballot drop</a> earlier on Slog, so don't miss that!</p>
          
        
          
           <p><strong>Oh god, I can't look away:</strong> Like a plot straight out of a movie, Alex Jones's lawyer apparently fucked up BIG TIME. Currently, the conspiracy theorist and Infowars host is being sued by two families of Sandy Hook victims for defamation after he repeatedly claimed the massacre wasn't real. And today their lawyer revealed that Jones's attorney had accidentally sent him two years of his client's unredacted texts and emails. Those documents provide proof supporting the argument that Jones consistently lied under oath. The phone also outlined Jones's long sought-after financials, showing that on several days in 2018, Infowars made over $800,000 per day, <a href="https://www.nbcnews.com/news/us-news/alex-jones-lawyers-accidentally-leak-years-emails-infowars-financial-d-rcna41378?cid=sm_npd_nn_tw_ma">reports</a> NBC News. Now the Jan 6 Committee <a href="https://www.rollingstone.com/politics/politics-news/alex-jones-cell-phone-jan6-committee-subpoeana-1392270/">wants a slice</a>. Incredible. </p>
          
        
          
           <blockquote class="twitter-tweet"> <p dir="ltr" lang="en">“Do you know what perjury is?” <a href="https://t.co/awbBpVf4Tl">pic.twitter.com/awbBpVf4Tl</a></p>
          <div id="div-gpt-ad-native-inline-1" class="my-4"></div>
        
          
           — Acyn (@Acyn) <a href="https://twitter.com/Acyn/status/1554875445253812225?ref_src=twsrc%5Etfw">August 3, 2022</a></blockquote> <p> <script src="https://platform.twitter.com/widgets.js"></script> </p>
          
        
          
          
      <a name="more"></a>
      <p><strong>The fries are a bit off at Dick's:</strong> Apparently, that's because the local fast food chain is "at the end of their season on Washington potatoes," leading them to produce "fries that they say are not up to their normal standards," <a href="https://www.kiro7.com/news/local/potato-problems-dicks-drive-in-with-end-harvest-not-producing-fries-up-standards/RD2AGJOMWZDK5JRZE6VH7R2GVQ/">reports</a> KIRO. Good that they acknowledge the problem, I guess, but...have their fries never not been floppy and little too greasy? That's the appeal!</p>
          <div class="interstitial-ad-1 ad text-center my-4">
                  <div id="div-gpt-ad-mobile-inline-1" class="interstitial-ad  inline-ad"></div>
                </div>
        
          
           <p><strong>Indiana Rep. Jackie Walorski and two staffers—Zachery Potts and Emma Thomson—killed in a car accident: </strong>According to the cops, the Republican Congressperson's vehicle was struck by another car going the opposite direction. That driver was also killed in the crash. From Asia, House Speaker Nancy Pelosi ordered the flags at the Capitol to fly at half-staff to commemorate Walorski's memory, <a href="https://www.nbcnews.com/politics/congress/indiana-rep-jackie-walorski-killed-car-accident-rcna41410">reports</a> NBC News. </p>
          
        
          
           <p><strong>A Black man sues the Seattle Police Department for wrongful detention: </strong>Anthony Sims was making a delivery at a downtown 7-Eleven when cops suddenly surrounded him and ordered him out of his vehicle at gunpoint. The coppers detained him for several minutes before they realized they'd gotten the wrong guy. Now, Sims is suing SPD for discrimination, <a href="https://www.seattletimes.com/seattle-news/law-justice/mistaken-detention-of-black-seattle-driver-prompts-lawsuit/">reports</a> the <em>Seattle Times</em>. "The only apparent reason [the officer] would have stopped Mr. Sims was his race,” the lawsuit alleges.</p>
          
        
          
           <p><strong>Your Wednesday Moment of Wonder:</strong> NASA's James Webb Space Telescope keeps delivering hits. Yesterday, the agency dropped these stunning photos of the Cartwheel Galaxy, located 500 million light years away in the Sculptor constellation. According to a press release, the galaxy formed as a result of "a high-speed collision between a large spiral galaxy and a smaller galaxy not visible in this image." More from their <a href="https://www.nasa.gov/feature/goddard/2022/webb-captures-stellar-gymnastics-in-the-cartwheel-galaxy">website</a>:</p>
          
        
          
           <blockquote> <p id="yui_3_16_0_1_1659564748842_3143">The collision most notably affected the galaxy’s shape and structure. The Cartwheel Galaxy sports two rings — a bright inner ring and a surrounding, colorful ring. These two rings expand outwards from the center of the collision, like ripples in a pond after a stone is tossed into it. Because of these distinctive features, astronomers call this a “ring galaxy,” a structure less common than spiral galaxies like our Milky Way.</p>
          
        
          
           </blockquote> <figure class="image"><img src="https://media2.fdncms.com/stranger/imager/u/large/77299583/52258939646_6ad1dc41a1_k.jpg" alt="" width="700" height="644" /> <figcaption>Courtesy of NASA, ESA, CSA, STScI</figcaption> </figure> <p><strong>Gamers, rejoice! </strong>GameStop has reopened in downtown Seattle. If you'll remember, the carpeted arcade shut down all its locations during the pandemic nearly a year ago. But now, the joint is being brought to Seventh and Pike by Howard Brand and former GameWorks CEO Greg Stevens, <a href="https://www.seattlemet.com/news-and-city-life/2022/08/gameworks-reopens-in-downtown-seattle-august-2022">reports</a> <em>Seattle Met</em>. The next couple of weeks are a ~*~*soft opening~*~*, but the shop hopes to be open to its fullest extent by mid-September. I will always celebrate the opening of places where I can go on stoned friend dates. </p>
          <div class="interstitial-ad-2 ad text-center my-4">
                  <div id="div-gpt-ad-mobile-inline-2" class="interstitial-ad  inline-ad"></div>
                </div>
        
          
           <p><strong>No, it's not just you, things are fucking strange: </strong>Could it be because the Earth is spinning over a millisecond- -and-a-half times faster than usual? <a href="https://www.cbsnews.com/news/earth-spinning-faster-than-usual-shortest-day-ever/?r=mnao&ftag=CNM-00-10aab7e&linkId=175805923&utm_source=substack&utm_medium=email">Experts can't figure out what's going on</a>. </p>
          
        
          
           <p><strong>Joe Biden signed a new executive order to ensure abortion access for pregnant people: </strong>According to <a href="https://www.cnn.com/2022/08/03/politics/joe-biden-abortion-executive-order/index.html">CNN</a>, the measure would help people travel out of state to receive abortions, ensure health care providers are complying with federal law, and collect data to get a sense of how limited abortion access effects maternal health and other health conditions. </p>
          
        
          
           <p><strong>This little piggy went to market, this little piggy went home...</strong><a href="https://www.nytimes.com/2022/08/03/science/pigs-organs-death.html">this little dead piggy's cells</a> were revived by scientists using a solution literally called OrganEx as part of study to see if human organs can be revived to increase the transplant supply, etc. Ok, so maybe this doesn't work as a nursery rhyme, but it sounds like a promising plot to a David Cronenberg film? </p>
          
        
          
           <p><strong>The Senate votes to ratify Sweden's and Finland's NATO membership:</strong> The vote made the US the 23rd of NATO's 30 members to give Sweden and Finland the go-ahead to join the military bloc in response to Russia's invasion of Ukraine, <a href="https://www.washingtonpost.com/national-security/2022/08/03/senate-nato-sweden-finland/">reports</a> <em>WaPo.</em> If the seven remaining members are on board, it'd "boost the alliance's military assets, which include "artillery, warplanes, and naval weapons." War—it's what's for dinner!</p>
          
        
          
           <p><strong>I wanna date her: </strong>But she lives <a href="https://www.theguardian.com/environment/2022/aug/03/discovered-in-the-deep-the-snail-with-iron-armour">several miles deep in the ocean</a> next to "searing hydrothermal vents, which are bathed in toxic chemicals and can reach temperatures of more than 300C (572F)" so it'll never work out :\</p>
          <div class="interstitial-ad-3 ad text-center my-4">
                  <div id="div-gpt-ad-mobile-inline-3" class="interstitial-ad  inline-ad"></div>
                </div>
        
          
           <blockquote class="twitter-tweet"> <p dir="ltr" lang="en">I've started a new weekly series in the <a href="https://twitter.com/guardian?ref_src=twsrc%5Etfw">@guardian</a> all about the incredible species being Discovered in the Deep.<br /><br />First up the scaly-foot snail, with its amazing bionic scales and shell. Featuring <a href="https://twitter.com/sigwartae?ref_src=twsrc%5Etfw">@sigwartae</a>, one of very few people who've seen them alive.<a href="https://t.co/ilwcFlx8XK">https://t.co/ilwcFlx8XK</a></p>
          
        
          
           — Dr Helen Scales (@helenscales) <a href="https://twitter.com/helenscales/status/1554739888464986112?ref_src=twsrc%5Etfw">August 3, 2022</a></blockquote> <p> <script src="https://platform.twitter.com/widgets.js"></script> </p>
          
        
          
           <h2 id="yui_3_16_0_1_1659564748842_3144" class=" meta-field photo-desc "></h2> <p><strong>Seattle City Council approves permanent cap on food delivery fees: </strong>According to <a href="https://www.geekwire.com/2022/seattle-lawmakers-approve-permanent-15-fee-cap-on-food-delivery-companies-with-key-exception/">GeekWire</a>, the amounts that apps like Uber Eats, DoorDash, and Grubhub can charge restaurants for food delivery is capped at 15%. The cap was temporarily in place when the pandemic started as a way to mitigate impacts on small businesses. HoWeVeR, there's an exception—delivery services can charge more "if restaurants purchase additional, non-delivery services, such as marketing and consulting."</p>
          <div id="div-gpt-ad-native-contribution"></div>
        
          
           <p><strong>Volcano erupts in Iceland: </strong>After a 4.6 earthquake, molten lava began spewing from the crevices of the Fagradalsfjall volcano this morning, <a href="https://abcnews.go.com/International/icelandic-volcano-erupts-amid-swarm-earthquakes/story?id=87875172">reports</a> ABC. A fissure around 100 to 200 meters long appeared near an old field of hardened lava, adding fresh magma to the mix. No one has been reported injured, nor do authorities think the eruption will have an impact on flights coming into Reykjavik. But this is a perfect reminder to watch one of the best movies of the year, <em><a href="https://www.thestranger.com/film/2022/07/19/76598298/love-and-volcanoes">Fire of Love</a>. </em></p>
          
        
          
           <p><strong>Today in corporate greed:</strong> Warner Bros. has killed the upcoming, already-filmed <em>Batgirl </em>movie instead of releasing it in theaters or on their streaming service HBO Max in order to save money, lol, <a href="https://www.hollywoodreporter.com/movies/movie-news/batgirl-shelved-at-warner-bros-hbo-max-1235191371/">reports</a> THR. Directors Adil El Arbi and Bilall Fallah <a href="https://www.nbcnews.com/pop-culture/movies/batgirl-directors-say-are-saddened-movie-shelved-rcna41432">released a joint statement today</a> saying they were "saddened and shocked" at the decision, as it seems like Discovery is trying to <a href="https://www.indiewire.com/2022/08/hbo-max-removed-6-streaming-movies-1234747761/">blow up HBO's whole strategy</a>. Sad!</p>
          
        
          
           <p><strong>For your listening pleasure: </strong>Badsista's set at Boiler Room Primavera. <iframe title="YouTube video player" src="https://www.youtube.com/embed/KkhwjIVDHGc" width="560" height="315" frameborder="0" allowfullscreen=""></iframe></p>
          
        
        <div id="div-gpt-ad-native-inline-2" class="my-4"></div>
       

    

  </div> <!-- end component -->




      

    
      
      
      
      
      
      
      
      
      









  <div id="articleFooterComponent-77289174" class="component article-footer">
    <div class="row py-3 article-share-tools">
      <div class="col">
        <div class="share-tools-wrapper fs-6 d-flex align-items-center justify-content-start">
      
      
        <a class="btn btn-primary me-3 text-white" href="/slog-pm/2022/08/03/77289174/slog-pm-dicks-fries-may-taste-a-lil-different-gamestop-reopens-downtown-alex-jones-is-fucked/comments"><i class="fa-regular fa-comments"></i> Comments 1</a>
      
      
        <span class="fa-stack tw-share share-tools" style="vertical-align: top;" data-href="https://twitter.com/intent/tweet?url=https%3A//www.thestranger.com/slog-pm/2022/08/03/77289174/slog-pm-dicks-fries-may-taste-a-lil-different-gamestop-reopens-downtown-alex-jones-is-fucked&text=Slog+PM%3A+Dick%27s+Fries+May+Taste+a+Lil%27+Different%2C+GameStop+Reopens+Downtown%2C+Alex+Jones+Is+Fucked">
          <i class="fas fa-circle fa-stack-2x text-primary"></i>
          <i class="fab fa-twitter fa-stack-1x fa-inverse"></i>
        </span>
      
      
        <span class="fa-stack share-tools fb-share" style="vertical-align: top;" data-href="https://www.thestranger.com/slog-pm/2022/08/03/77289174/slog-pm-dicks-fries-may-taste-a-lil-different-gamestop-reopens-downtown-alex-jones-is-fucked">
          <i class="fas fa-circle fa-stack-2x text-primary"></i>
          <i class="fab fa-facebook fa-stack-1x fa-inverse"></i>
        </span>
      
      
        <a href="https://www.reddit.com/submit?url=https%3A//www.thestranger.com/slog-pm/2022/08/03/77289174/slog-pm-dicks-fries-may-taste-a-lil-different-gamestop-reopens-downtown-alex-jones-is-fucked" class="fa-stack share-tools reddit-share" style="vertical-align: top;"  target="_blank">
          <i class="fas fa-circle fa-stack-2x text-primary"></i>
          <i class="fab fa-reddit fa-stack-1x fa-inverse"></i>
        </a>
      
      
        <a href="mailto:?subject=I%20thought%20you%20might%20like%20this%20article%20from%20The%20Stranger&body=https%3A//www.thestranger.com/slog-pm/2022/08/03/77289174/slog-pm-dicks-fries-may-taste-a-lil-different-gamestop-reopens-downtown-alex-jones-is-fucked" class="fa-stack" style="vertical-align: top;">
          <i class="fas fa-circle fa-stack-2x text-primary"></i>
          <i class="fas fa-envelope fa-stack-1x fa-inverse"></i>
        </a>
      
    </div>
      </div>
    </div>
    
      <div class="row mt-3 article-tags mb-5">
        <div class="col">
          <div class="ff-serif text-uppercase">
            <span class="text-gray-3">Tags:</span>
            
              <a class="article-tag text-decoration-none text-gray-4 fw-bold px-1" href="/collections/74529062/slog-pm">Slog PM</a>
            
              <a class="article-tag text-decoration-none text-gray-4 fw-bold px-1" href="/collections/25720387/slog-am-pm">Slog AM/PM</a>
            
          </div>
        </div>
      </div>
    
    
      
        <div class="row border-top rounded-1 py-4 author-info align-items-center">
          
            <div class="cover-image col-12 col-md-3 text-center mb-3 mb-md-0">
              <a href="/authors/32434319/jas-keimig"><img class="img-fluid" src="https://media1.fdncms.com/stranger/imager/u/large/57365918/keimig_photo.png" alt="Jas Keimig"></a>
            </div>
          
          <div class="col-12 col-md-9">
            <h3 class="fw-bold mb-1"><a class="text-decoration-none text-black" href="/authors/32434319/jas-keimig">Jas Keimig</a></h3>
            
              <div class="author-bio ff-serif">
                Jas Keimig is a staff writer at <em>The Stranger</em>, where they cover visual art, film, stickers, and culture.
              </div>
            
            
              <div class="author-links mt-2">
                
                  <a href="mailto:jkeimig@thestranger.com" class="text-decoration-none text-gray-3 me-2">
                    <i class="fas fa-envelope"></i>
                  </a>
                
                
                  <a href="https://twitter.com/jaskeimig" class="text-decoration-none text-gray-3 me-2">
                    <i class="fab fa-twitter"></i>
                  </a>
                
                
                
              </div>
            
          </div>
        </div>
      
    

    
    
    
  </div> <!-- end component -->

  <!-- article-contribution-footer -->
  
  
    <div class="article-contribution-footer py-5">
      <div class="row justify-content-center">
        <div class="col-12">
          <div class="p-3 rounded border bg-warning">
            <div class="mb-3 ff-header"><em>The Stranger</em> depends on your continuing support to provide articles like this one. In return, we pledge our ongoing commitment to truthful, progressive journalism and serving our community. So if you’re able, please consider a small recurring contribution. Thank you—you are appreciated!</div>
            <div class="text-center"><a href="/contribute?utm_source=publication&utm_medium=article_footer&utm_campaign=footer_ask" class="btn btn-danger btn-large">CONTRIBUTE NOW</a></div>
          </div>
        </div>
      </div>
    </div>
  
  <!-- article-contribution-footer -->
          </div>
          <div class="col-1 d-none d-md-block"></div>
          <div class="col-12 col-md-3">
            <div class="component sidebar-ads py-1 sticky-top text-center">
  <div class="row mb-3">
    <div class="col">
      <div id="div-gpt-ad-sidebar-1"></div>
    </div>
  </div>
  <div class="row mb-3">
    <div class="col">
      <div id="div-gpt-ad-sidebar-2"></div>
    </div>
  </div>
  <div class="row mb-3">
    <div class="col">
      <div id="div-gpt-ad-sidebar-3"></div>
    </div>
  </div>
</div>
          </div>
        </div> <!-- top -->
        
          <div class="row bottom justify-content-center">
            <div class="col-12 col-md-8 px-md-5">
              <div id="moreInTopicComponent-Slog PM" class="component article-list more-in pt-md-5 my-md-5">
    <h3 class="ff-header fw-bold pb-1 border-bottom">More In Slog PM</h3>
    <div class="row row-cols-1 row-cols-md-3 pt-3">
      
        <div class="col mb-3">
          <div class="item-image mb-2">
            <a href="/slog-pm/2022/07/25/76910191/slog-pm-shootings-in-british-columbia-and-dallas-the-pope-apologizes-for-cultural-genocide-meet-the-northern-giant-hornet">
              
                <img class="img-fluid" src="https://media2.fdncms.com/stranger/imager/u/large/76915903/gettyimages-1242112707_1_.jpg">
              
            </a>
          </div>
          <h5><a class="text-decoration-none text-black headline" href="/slog-pm/2022/07/25/76910191/slog-pm-shootings-in-british-columbia-and-dallas-the-pope-apologizes-for-cultural-genocide-meet-the-northern-giant-hornet">Slog PM: Shootings in British Columbia and Dallas, the Pope Apologizes for Cultural Genocide, Meet the Northern Giant Hornet</a></h5>
        </div>
      
        <div class="col mb-3">
          <div class="item-image mb-2">
            <a href="/slog-pm/2022/08/01/77221692/slog-pm-nanci-pelosi-heads-to-taiwan-blue-angels-arrive-tomorrow-and-is-des-moines-the-new-bothell">
              
                <img class="img-fluid" src="https://media1.fdncms.com/stranger/imager/u/large/77222080/gettyimages-1296714644.jpg">
              
            </a>
          </div>
          <h5><a class="text-decoration-none text-black headline" href="/slog-pm/2022/08/01/77221692/slog-pm-nanci-pelosi-heads-to-taiwan-blue-angels-arrive-tomorrow-and-is-des-moines-the-new-bothell">Slog PM: Nanci Pelosi Heads to Taiwan, Blue Angels Arrive Tomorrow, and Is Des Moines the New Bothell?</a></h5>
        </div>
      
        <div class="col mb-3">
          <div class="item-image mb-2">
            <a href="/slog-pm/2022/06/22/75441753/slog-pm-inslee-snubs-bidens-gas-tax-holiday-afghanistan-earthquake-kills-at-least-a-thousand-florida-man-hits-gator-with-pan">
              
                <img class="img-fluid" src="https://media2.fdncms.com/stranger/imager/u/large/75448087/biden_pointing.jpg">
              
            </a>
          </div>
          <h5><a class="text-decoration-none text-black headline" href="/slog-pm/2022/06/22/75441753/slog-pm-inslee-snubs-bidens-gas-tax-holiday-afghanistan-earthquake-kills-at-least-a-thousand-florida-man-hits-gator-with-pan">Slog PM: Inslee Snubs Biden's Gas Tax Holiday, Afghanistan Earthquake Kills at Least a Thousand, Florida Man Hits Gator with Pan</a></h5>
        </div>
      
        <div class="col mb-3">
          <div class="item-image mb-2">
            <a href="/slog-pm/2022/06/03/74635883/new-owners-at-elliott-bay-books-new-ceo-at-sound-transit-and-new-revelations-about-carmen-best">
              
                <img class="img-fluid" src="https://media1.fdncms.com/stranger/imager/u/large/74643374/ebc_kelly_o.png">
              
            </a>
          </div>
          <h5><a class="text-decoration-none text-black headline" href="/slog-pm/2022/06/03/74635883/new-owners-at-elliott-bay-books-new-ceo-at-sound-transit-and-new-revelations-about-carmen-best">New Owners at Elliott Bay Books, New CEO at Sound Transit, and New Revelations about Carmen Best</a></h5>
        </div>
      
        <div class="col mb-3">
          <div class="item-image mb-2">
            <a href="/slog-pm/2022/06/28/75733354/slog-pm-bombshell-testimony-in-jan-6-hearing-ghislaine-maxwell-gets-20-years-seattle-should-be-silent-on-july-4">
              
                <img class="img-fluid" src="https://media1.fdncms.com/stranger/imager/u/large/75735590/unnamed_4_.jpeg">
              
            </a>
          </div>
          <h5><a class="text-decoration-none text-black headline" href="/slog-pm/2022/06/28/75733354/slog-pm-bombshell-testimony-in-jan-6-hearing-ghislaine-maxwell-gets-20-years-seattle-should-be-silent-on-july-4">Slog PM: Bombshell Testimony in Jan 6 Hearing, Ghislaine Maxwell Gets 20 years, Seattle Should Be Silent on July 4</a></h5>
        </div>
      
        <div class="col mb-3">
          <div class="item-image mb-2">
            <a href="/slog-pm/2022/07/01/75875540/slog-pm-biden-wants-you-to-vote-harder-travel-booms-as-some-plan-to-boycott-gas-new-gun-laws-just-dropped">
              
                <img class="img-fluid" src="https://media2.fdncms.com/stranger/imager/u/large/75876063/1646238135-gettyimages-1238863309-1.jpg">
              
            </a>
          </div>
          <h5><a class="text-decoration-none text-black headline" href="/slog-pm/2022/07/01/75875540/slog-pm-biden-wants-you-to-vote-harder-travel-booms-as-some-plan-to-boycott-gas-new-gun-laws-just-dropped">Slog PM: Biden Wants You to Vote Harder, Travel Booms as Some Plan to Boycott Gas, New Gun Laws Just Dropped</a></h5>
        </div>
      
    </div>
  </div> <!-- end component -->




      

    
      
      
      
      
      
      
      
      
      









  <div id="editorsPicksComponent" class="component article-list editors-picks my-3 my-md-5">
    <h3 class="ff-header fw-bold pb-1 border-bottom">Editors' Picks</h3>
    <div class="row row-cols-1 row-cols-md-3 pt-3">
      
        <div class="col mb-3">
          <div class="item-image mb-2">
            <a href="/stranger-comics/2022/07/05/76036433/are-you-ready-for-summer">
              
                <img class="img-fluid placeholder-if-missing" src="https://media1.fdncms.com/stranger/imager/u/large/76036418/sc_ayrfts_rgb_001.jpg">
              
            </a>
          </div>
          <h5><a class="text-decoration-none text-black headline" href="/stranger-comics/2022/07/05/76036433/are-you-ready-for-summer">Are You Ready for Summer?</a></h5>
        </div>
      
        <div class="col mb-3">
          <div class="item-image mb-2">
            <a href="/features/2011/05/04/7989613/the-long-con">
              
                <img class="img-fluid placeholder-if-missing" src="https://media2.fdncms.com/stranger/imager/u/large/76073805/img_9087.jpg">
              
            </a>
          </div>
          <h5><a class="text-decoration-none text-black headline" href="/features/2011/05/04/7989613/the-long-con">The Long Con</a></h5>
        </div>
      
        <div class="col mb-3">
          <div class="item-image mb-2">
            <a href="/news/2004/02/26/17256/daddy-was-a-bankrobber">
              
                <img class="img-fluid placeholder-if-missing" src="https://media1.fdncms.com/stranger/imager/u/large/76073615/img_9081.jpg">
              
            </a>
          </div>
          <h5><a class="text-decoration-none text-black headline" href="/news/2004/02/26/17256/daddy-was-a-bankrobber">Daddy Was A Bankrobber</a></h5>
        </div>
      
        <div class="col mb-3">
          <div class="item-image mb-2">
            <a href="/features/2008/01/17/484025/confessions-of-a-gasoline-huffer">
              
                <img class="img-fluid placeholder-if-missing" src="https://media2.fdncms.com/stranger/imager/u/large/76072372/img_9100.jpg">
              
            </a>
          </div>
          <h5><a class="text-decoration-none text-black headline" href="/features/2008/01/17/484025/confessions-of-a-gasoline-huffer">Confessions of a Gasoline Huffer</a></h5>
        </div>
      
        <div class="col mb-3">
          <div class="item-image mb-2">
            <a href="/features/2016/10/12/24610950/how-writing-for-the-stranger-made-me-blacker">
              
                <img class="img-fluid placeholder-if-missing" src="https://media2.fdncms.com/stranger/imager/u/large/24610948/c.mudede_1991_mag.jpg">
              
            </a>
          </div>
          <h5><a class="text-decoration-none text-black headline" href="/features/2016/10/12/24610950/how-writing-for-the-stranger-made-me-blacker">How Writing for <i>The Stranger</i> Made Me Blacker</a></h5>
        </div>
      
        <div class="col mb-3">
          <div class="item-image mb-2">
            <a href="/stickers/2022/07/13/76396092/seattle-sticker-patrol-columbia-city-has-eyes">
              
                <img class="img-fluid placeholder-if-missing" src="https://media1.fdncms.com/stranger/imager/u/original/76400939/img_7649.jpg">
              
            </a>
          </div>
          <h5><a class="text-decoration-none text-black headline" href="/stickers/2022/07/13/76396092/seattle-sticker-patrol-columbia-city-has-eyes">Seattle Sticker Patrol: Columbia City Has Eyes 👁️</a></h5>
        </div>
      
    </div>
  </div> <!-- end component -->
            </div>
            <div class="col-12 col-md-4">
              <div id="popularArticlesComponent" class="component popular-articles my-0 my-md-5 pt-0 pt-md-5">
    <h3 class="ff-header fw-bold pb-1 border-bottom">Popular Articles</h3>
    <div class="popular-articles">
      
        <div class="item py-3 border-bottom">
          <h5 class="headline m-0"><a class="fw-normal" href="https://www.thestranger.com/slog-pm/2022/08/01/77221692/slog-pm-nanci-pelosi-heads-to-taiwan-blue-angels-arrive-tomorrow-and-is-des-moines-the-new-bothell">Slog PM: Nanci Pelosi Heads to Taiwan, Blue Angels Arrive Tomorrow, and Is Des Moines the New Bothell?</a></h5>
        </div>
      
        <div class="item py-3 border-bottom">
          <h5 class="headline m-0"><a class="fw-normal" href="https://www.thestranger.com/slog-pm/2022/08/03/77289174/slog-pm-dicks-fries-may-taste-a-lil-different-gamestop-reopens-downtown-alex-jones-is-fucked">Slog PM: Dick's Fries May Taste a Lil' Different, GameStop Reopens Downtown, Alex Jones Is Fucked</a></h5>
        </div>
      
        <div class="item py-3 border-bottom">
          <h5 class="headline m-0"><a class="fw-normal" href="https://www.thestranger.com/slog-pm/2022/07/29/77073790/slog-pm-seattle-pacific-university-under-investigation-for-homophobic-discrimination-16-dead-in-kentucky-flood-and-starbucks-strike-worked">Slog PM: Seattle Pacific University under Investigation for Homophobic Discrimination, 16 Dead in Kentucky Flood, and Starbucks Strike Worked</a></h5>
        </div>
      
        <div class="item py-3 border-bottom">
          <h5 class="headline m-0"><a class="fw-normal" href="https://www.thestranger.com/slog-pm/2022/06/29/75784779/slog-pm-justice-breyer-to-step-down-tomorrow-alaska-cruise-hits-ice-the-nba-will-be-back-in-seattle-kinda">Slog PM: Justice Breyer to Step Down Tomorrow, Alaska Cruise Hits Ice, the NBA Will Be Back in Seattle (Kinda)</a></h5>
        </div>
      
        <div class="item py-3 border-bottom">
          <h5 class="headline m-0"><a class="fw-normal" href="https://www.thestranger.com/slog-pm/2022/07/25/76910191/slog-pm-shootings-in-british-columbia-and-dallas-the-pope-apologizes-for-cultural-genocide-meet-the-northern-giant-hornet">Slog PM: Shootings in British Columbia and Dallas, the Pope Apologizes for Cultural Genocide, Meet the Northern Giant Hornet</a></h5>
        </div>
      
        <div class="item py-3 border-bottom">
          <h5 class="headline m-0"><a class="fw-normal" href="https://www.thestranger.com/slog-pm/2022/06/28/75733354/slog-pm-bombshell-testimony-in-jan-6-hearing-ghislaine-maxwell-gets-20-years-seattle-should-be-silent-on-july-4">Slog PM: Bombshell Testimony in Jan 6 Hearing, Ghislaine Maxwell Gets 20 years, Seattle Should Be Silent on July 4</a></h5>
        </div>
      
        <div class="item py-3 ">
          <h5 class="headline m-0"><a class="fw-normal" href="https://www.thestranger.com/slog-pm/2022/07/27/76986478/slog-pm-meet-seattles-new-transit-guy-a-plane-nearly-crashed-into-west-seattle-and-sewer-rats-are-not-the-latest-monkeypox-concern-depite">Slog PM: Meet Seattle's New Transit Guy, a Plane Nearly Crashed Into West Seattle, and Sewer Rats Are Not the Latest Monkeypox Concern, Depite What You've Heard</a></h5>
        </div>
      
    </div>
  </div> <!-- end component -->
            </div>
          </div> <!-- bottom -->
        
      </div> <!-- main container -->
      <div class="container-fluid footer g-0">
        <div class="component newsletter-sign-up bg-gray-1 p-5 text-center">
    <div class="container">
      <h1 class="ff-header mb-2">Just Can't Get Enough?</h1>
      <h3 class="ff-serif mb-3">Sign up for our newsletter for news recaps, updates, and more!</h3>
      <div id="mc_embed_signup">
  <form class="row g-3 align-items-center justify-content-center" action="https://thestranger.us4.list-manage.com/subscribe/post?u=739a0d2f2ff0031156e7b3d55&amp;id=f02129603b" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
    <div class="col-12 col-md-6">
      <input class="form-control" type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>
    </div>
    <div class="col-12 col-md-1">
      <input class="btn btn-secondary" type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button">
    </div>  
    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_739a0d2f2ff0031156e7b3d55_f02129603b" tabindex="-1" value=""></div>
  </form>
</div>
    </div>
  </div>

<div class="component footer-nav bg-dark p-4">
  <div class="container">
    <div class="row row-cols-2 row-cols-md-4 text-white mx-md-5 my-5 justify-content-center">
      
    </div>
    <div class="row">
      <div class="col-12 text-center text-gray-3 mt-3">
        <div class="footer-brand">
          <a href="https://www.thestranger.com/"><img src="/assets/3/sites/stranger/images/site-logo-darkbg.png" alt="The Stranger"></a>
        </div>
        <div class="text-center mt-3 d-md-flex align-items-center justify-content-center">
          <span>is a proud member of the</span>
          <span class="d-block d-md-inline-block mx-3 mb-2 mt-1 mt-md-0 mb-md-1"><img src="/assets/3/base/images/index-logo-darkbg.png" style="max-height:18px;"></span>
          <span>media network</span>
        </div>
      </div>
    </div>
    <div class="row row-cols-3 row-cols-md-auto align-items-center justify-content-center mt-5 py-5 border-top border-bottom border-gray-3">
      <div class="col text-center mx-md-4">
        
          <a href="https://portlandmercury.com" target="_blank" class="d-inline-block px-1"><img src="/assets/3/base/images/mercury-logo-darkbg.png" style="max-height: 45px;" class="img-fluid"></a>
        
      </div>
      <div class="col text-center mx-md-4">
        <a href="https://everout.com/seattle/" target="_blank" class="d-inline-block px-1"><img src="/assets/3/base/images/everout-logo-darkbg.png" style="max-height: 70px;" class="img-fluid"></a>
      </div>
      <div class="col text-center mx-md-4">
        <a href="https://savage.love/" target="_blank" class="d-inline-block px-1"><img src="/assets/3/base/images/savagelove-logo-darkbg.png" style="max-height: 70px;" class="img-fluid"></a>
      </div>
      <div class="col text-center mx-md-4">
        <a href="https://savage.love/lovecast/" target="_blank" class="d-inline-block px-1"><img src="/assets/3/base/images/lovecast-logo-darkbg.png" style="max-height: 70px;" class="img-fluid"></a>
      </div>
      <div class="col text-center mx-md-4">
        <a href="https://humpfilmfest.com/" target="_blank" class="d-inline-block px-1"><img src="/assets/3/base/images/hump-logo-darkbg.png" style="max-height: 70px;" class="img-fluid"></a>
      </div>
    </div>

    <div class="row justify-content-center mt-5">
      <div class="col-12 col-md-8 text-center">
        
          <a class="p-0 my-1 mx-3 d-inline-block text-uppercase fw-light text-white text-decoration-none" href="https://www.thestranger.com/masthead">Masthead</a>
        
          <a class="p-0 my-1 mx-3 d-inline-block text-uppercase fw-light text-white text-decoration-none" href="https://www.thestranger.com/ad-info">Ad Info & Rates</a>
        
          <a class="p-0 my-1 mx-3 d-inline-block text-uppercase fw-light text-white text-decoration-none" href="https://www.thestranger.com/jobs">Jobs at The Stranger</a>
        
          <a class="p-0 my-1 mx-3 d-inline-block text-uppercase fw-light text-white text-decoration-none" href="https://www.thestranger.com/contact-information">Contact</a>
        
          <a class="p-0 my-1 mx-3 d-inline-block text-uppercase fw-light text-white text-decoration-none" href="https://www.thestranger.com/privacy-policy">Privacy Policy</a>
        
          <a class="p-0 my-1 mx-3 d-inline-block text-uppercase fw-light text-white text-decoration-none" href="https://www.thestranger.com/terms-of-use">Terms of Use</a>
        
          <a class="p-0 my-1 mx-3 d-inline-block text-uppercase fw-light text-white text-decoration-none" href="https://www.thestranger.com/takedown-policy">Takedown Policy</a>
        
      </div>
    </div>

    <div class="row justify-content-center mt-5">
      <div class="col-12 col-md-10 text-center">
        <h5 class="m-0"><a href="/contribute" class="text-warning fw-medium text-decoration-none">Support The Stranger</a></h5>
      </div>
    </div>

    
      <div class="row mt-5">
        <div class="col-12 text-gray-3 fs-7 text-center">
          All contents &copy; Index Newspapers LLC<br>
800 Maynard Ave S, Suite 200, Seattle, WA 98134
        </div>
      </div>
    
  </div>

  
</div>
      </div> <!-- footer container -->
    </div>
    <script>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</script>







  



  
  
    
    
  

  
  
    
  

  
  
    
    
  








<div id="fb-root"></div>

  <script>
    window.fbAsyncInit = function() {
      FB.init({
        appId      : '43933993878',
        xfbml      : true,
        version    : 'v2.6'
      });
    };
  </script>

<script>(function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
    fjs.parentNode.insertBefore(js, fjs);
  }(document, 'script', 'facebook-jssdk'));</script>


<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-332219-1', 'auto');
  ga('require', 'linkid', 'linkid.js');
  ga('set', 'anonymizeIp', true);

  var user = JSON.parse($.cookie('user'));
  var dimension1Value = "";
  var dimension2Value = "";
  var dimension3Value = "";
  var dimension4Value = "";
  var dimension5Value = "";
  var dimension6Value = "";
  var dimension7Value = "Jas Keimig";
  var dimension8Value = "";
  var dimension9Value = "";
  var dimension10Value = user ? user.type : "Guest";
  var dimension11Value = $.map($('.fish-butter'), function(val, i) {
      return $(val).data('adOid')
  }).join(",");
  ga('set', 'dimension1', dimension1Value); // calendar section
  ga('set', 'dimension2', dimension2Value); // location category
  ga('set', 'dimension3', dimension3Value); // location neighborhood
  ga('set', 'dimension4', dimension4Value); // location cuisine
  ga('set', 'dimension5', dimension5Value); // section
  ga('set', 'dimension6', dimension6Value); // category
  ga('set', 'dimension7', dimension7Value); // author
  ga('set', 'dimension8', dimension8Value); // targeting section
  ga('set', 'dimension9', dimension9Value); // location category
  ga('set', 'dimension10', dimension10Value); // user type
  ga('set', 'dimension11', dimension11Value); // native ads
  ga('send', 'pageview');
</script>



<script type='text/javascript'>
    var _sf_async_config = _sf_async_config || {};
    /** CONFIGURATION START **/
    _sf_async_config.sections = 'other';
    _sf_async_config.authors = 'Jas Keimig';
    /** CONFIGURATION END **/
    (function(){
      function loadChartbeat() {
        window._sf_endpt=(new Date()).getTime();
        var e = document.createElement('script');
        e.setAttribute('language', 'javascript');
        e.setAttribute('type', 'text/javascript');
        e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
        document.body.appendChild(e);
      }
      var oldonload = window.onload;
      window.onload = (typeof window.onload != 'function') ?
        loadChartbeat : function() { oldonload(); loadChartbeat(); };
    })();
</script>
  </body>
</html>
