 <!DOCTYPE html>
<html lang="en">
  <head>
    <!-- Google Tag Manager -->
  <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','dataLayer','GTM-5GMVQ6J');</script>
  <!-- End Google Tag Manager -->






<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=yes">
<meta name="google-site-verification" content="Yn7U5qsaj-oKD3y_qp7IbGawlVoNxW1Pzu87ZOHqabU">
<meta name="view-id" content="article">
<!-- start Omniconvert.com code -->
<link rel="dns-prefetch" href="//app.omniconvert.com" /> <script type="text/javascript">window._mktz=window._mktz||[];</script> <script src="//cdn.omniconvert.com/js/sd0d155.js"></script>
<!-- end Omniconvert.com code -->



<title>Refresh Playlist: New Music for the Week—Featuring TYuS, JoJo, FKA Twigs, and More! - Slog - The Stranger</title>


  

  

  

  

  <meta name="twitter:card" content="summary_large_image" />
  <meta name="twitter:site" content="@thestranger" />
  <meta name="twitter:image" content="https://www.thestranger.com/images/share-image.jpg" />
  <meta property="og:title" content="Refresh Playlist: New Music for the Week&mdash;Featuring TYuS, JoJo, FKA Twigs, and More!" />
  <meta property="og:description" content="Welcome to February, music-loving readers. The world is still on fire and almost everything is trash, but the music being pumped out right now is *chef&#39;s kiss* phenomenal. Here is your weekly excuse to unplug from the news, social media, and whatever&#39;s on your endless Netflix queue so you can sit back and just relax with some fresh tunes. Here are five new releases to vibe to this week. &ldquo;Suicide,&rdquo; TYuSOn January 23, R&amp;B singer..." />
  <meta name="description" content="Welcome to February, music-loving readers. The world is still on fire and almost everything is trash, but the music being pumped out right now is *chef&#39;s kiss* phenomenal. Here is your weekly excuse to unplug from the news, social media, and whatever&#39;s on your endless Netflix queue so you can sit back and just relax with some fresh tunes. Here are five new releases to vibe to this week. &ldquo;Suicide,&rdquo; TYuSOn January 23, R&amp;B singer..." />
  <meta property="og:site_name" content="The Stranger" />
  <meta property="og:type" content="article" />
  <meta property="og:image" content="https://www.thestranger.com/images/share-image.jpg" />
  <meta property="article:publisher" content="https://www.facebook.com/strangerseattle" />
  
    
  
  <meta name="apple-mobile-web-app-title" content="Refresh Playlist: New Music for the Week—Featuring TYuS, JoJo, FKA Twigs, and More! - Slog - The Stranger" />
  
    <link rel="apple-touch-icon-precomposed"  href="/images/mobile/touchicons/default/touch-icon-60.png" />
  
    <link rel="apple-touch-icon-precomposed" sizes="76x76" href="/images/mobile/touchicons/default/touch-icon-76.png" />
  
    <link rel="apple-touch-icon-precomposed" sizes="120x120" href="/images/mobile/touchicons/default/touch-icon-120.png" />
  
    <link rel="apple-touch-icon-precomposed" sizes="152x152" href="/images/mobile/touchicons/default/touch-icon-152.png" />
  

  <link rel="mask-icon" href="https://www.thestranger.com/assets/sites/stranger/images/site-badge.svg" color="#000000">
  <link rel="icon" type="image/x-icon" href="https://www.thestranger.com/assets/sites/stranger/images/favicon.png">

  
    <meta property="fb:app_id" content="43933993878"/>
  
  
    <meta property="fb:admins" content="741428065"/>
  
  
    <meta property="fb:pages" content="56439755991" />
  

  

  
  
  
    <link rel="canonical" href="https://www.thestranger.com/slog/2021/02/04/55114982/refresh-playlist-new-music-for-the-week-featuring-tyus-jojo-fka-twigs-and-more" />
    <meta property="og:url" content="https://www.thestranger.com/slog/2021/02/04/55114982/refresh-playlist-new-music-for-the-week-featuring-tyus-jojo-fka-twigs-and-more" />
  
  
   <link rel="alternate" type="application/rss+xml" title="The Stranger: Whole Site" href="/seattle/Rss.xml"/>

  <link rel="alternate" type="application/rss+xml" title="The Stranger: Slog Section" href="/seattle/Rss.xml?section=529161"/>


  
    <link rel="alternate" type="application/rss+xml" title="The Stranger: Articles by Jenni Moore" href="/seattle/Rss.xml?author=24656453"/>
 

<!-- revved -->

<link href="https://www.thestranger.com/assets/build/css/styles.d1b87d79.css" rel="stylesheet">

<link rel="stylesheet" href="https://use.fontawesome.com/baf88c5825.css">


<!-- jQuery (necessary for Bootstrap's JavaScript plugins) -->
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.0/jquery.min.js"></script>
<!-- Include all compiled plugins (below), or include individual files as needed -->
<script src="https://stackpath.bootstrapcdn.com/bootstrap/3.4.1/js/bootstrap.min.js" integrity="sha384-aJ21OjlMXNL5UyIl/XNwTMqvzeRMZH2w8c5cRVpzpU8Y5bApTppSuUkhZXN0VxHd" crossorigin="anonymous"></script>


<script src="/seattle/Library/Environment/JavascriptEnvironmentScript"></script>


  <script src="https://www.thestranger.com/assets/build/js/app.e765bde4.js"></script>


<!-- HTML5 Shim and Respond.js IE8 support of HTML5 elements and media queries -->
<!-- WARNING: Respond.js doesn't work if you view the page via file:// -->
<!--[if lt IE 9]>
  <script src="https://oss.maxcdn.com/libs/html5shiv/3.7.0/html5shiv.js"></script>
  <script src="https://oss.maxcdn.com/libs/respond.js/1.4.2/respond.min.js"></script>
<![endif]-->



  <!-- Hotjar Tracking Code for thestranger.com -->
  
  






<!--   typekit -->
<script type="text/javascript" src="//use.typekit.net/wjg1xbh.js"></script>
<script type="text/javascript">try{Typekit.load();}catch(e){}</script>







<script type='text/javascript'>
function getWidth() {
  if (self.innerHeight) {
    return self.innerWidth;
  }
  if (document.documentElement && document.documentElement.clientHeight) {
    return document.documentElement.clientWidth;
  }
  if (document.body) {
    return document.body.clientWidth;
  }
}
var documentWidth = getWidth();

var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
  var gads = document.createElement('script');
  gads.async = true;
  gads.type = 'text/javascript';
  var useSSL = 'https:' == document.location.protocol;
  gads.src = (useSSL ? 'https:' : 'http:') +
  '//www.googletagservices.com/tag/js/gpt.js';
  var node = document.getElementsByTagName('script')[0];
  node.parentNode.insertBefore(gads, node);
})();
</script>

<script type="text/javascript">
  // in gyrobase
  // $(document).ready(function() {
  //   if($('.fish-butter') && !navigator.userAgent.match(/bot|googlebot|crawler|spider|robot|crawling|PhantomJS|BingPreview/ig)){
  //     $('.fish-butter').each(function() {
  //       var xhr = new XMLHttpRequest();
  //       var data = {
  //         'oid': $(this).data('adOid'),
  //         'context': $(this).data('contextOid')
  //       }
  //       xhr.open('POST', '/_private/tracking/record-hit');
  //       xhr.setRequestHeader('Content-Type', 'application/json');
  //       xhr.setRequestHeader('X-CSRF-Token', getCookie('csrfToken'));
  //       xhr.onload = function() {
  //         var response = JSON.parse(xhr.responseText);
  //         if (xhr.status === 200) {
  //         } else {
  //         }
  //       };
  //       xhr.send(JSON.stringify(data));
  //     });
  //   }
  // });

  // in keen
  !function(name,path,ctx){
    var latest,prev=name!=='Keen'&&window.Keen?window.Keen:false;ctx[name]=ctx[name]||{ready:function(fn){var h=document.getElementsByTagName('head')[0],s=document.createElement('script'),w=window,loaded;s.onload=s.onerror=s.onreadystatechange=function(){if((s.readyState&&!(/^c|loade/.test(s.readyState)))||loaded){return}s.onload=s.onreadystatechange=null;loaded=1;latest=w.Keen;if(prev){w.Keen=prev}else{try{delete w.Keen}catch(e){w.Keen=void 0}}ctx[name]=latest;ctx[name].ready(fn)};s.async=1;s.src=path;h.parentNode.insertBefore(s,h)}}
  }('KeenAsync','https://d26b395fwzu5fz.cloudfront.net/keen-tracking-1.0.3.min.js',this);

  KeenAsync.ready(function(){
      // Configure a client instance
      var client = new KeenAsync({
        projectId: '58b718b78db53dfda8a8a0eb',
        writeKey: '326C65A94101E46B8EF1B20D83CA64E04F13DEEF29A28D5D7E39F4F5833AFB8F1E0C98E7836FB62A52269ECF45B4AF7C30417251B5A7EE01E34071751EB398A79E24280EEA32F15CC3D607C32274ABA72CD3C460A3F0EB9361D304A6F5391B91'
      });

      // Record views of sponsored posts
      if($('.fish-butter') && !navigator.userAgent.match(/bot|googlebot|crawler|spider|robot|crawling|PhantomJS|BingPreview/ig)){

        // in keen
        $('.fish-butter').each(function() {
          client.recordEvent('adViews', {
            publication: "stranger",
            ad: {
              oid: $(this).data('adOid')
            },
            placement: {
              oid: $(this).data('contextOid')
            },
            user_agent: navigator.userAgent,
            page_url: location.href,
            keen: {
              addons: [{
                name: "keen:ua_parser",
                input: {
                  ua_string: "user_agent"
                },
                output: "parsed_user_agent"
              },{
                name: "keen:url_parser",
                input: {
                  url: "page_url"
                },
                output: "parsed_page_url"
              },{
                name: "keen:date_time_parser",
                input: {
                  date_time: "keen.timestamp"
                },
                output: "timestamp_info"
              }]
            }
          });
        })

      }
    });
</script>


<script type="text/javascript">
     var _sf_async_config = _sf_async_config || {};
     /** CONFIGURATION START **/
     _sf_async_config.uid = 65679
     _sf_async_config.domain = "thestranger.com";
     _sf_async_config.useCanonical = true;
     /** CONFIGURATION END **/
     var _sf_startpt = (new Date()).getTime();
</script>
<script src="//static.chartbeat.com/js/chartbeat_mab.js"></script>
  </head>
  <body class="article  article-section-slog">
    <div class="wrapper">
      <div class="network-bar navbar hidden-xs navbar-expand-md navbar-dark bg-dark">
    <div class="container">
      <ul class="nav navbar-nav mr-auto">
        
          
            <li class="nav-item"><a class="nav-link" href="https://thestranger.com" target="self">The Stranger</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          
            <li class="nav-item"><a class="nav-link" href="https://portlandmercury.com" target="self">Portland Mercury</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          
            <li class="nav-item"><a class="nav-link" href="https://everout.com/stranger-seattle/" target="self">EverOut</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          
            <li class="nav-item"><a class="nav-link" href="https://www.savagelovecast.com" target="self">Savage Love</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          
            <li class="nav-item"><a class="nav-link" href="https://humpfilmfest.com" target="self">Hump</a></li>
          
          
        
      </ul>
    </div>
  </div>



  
  
    <div id="aboveNav" style="background:#183000;border-bottom:1px solid #999;position:relative;margin-bottom:-1px;color:#fcfcfc">
      <div class="container donate-ask">
        
        <p>Dear Stranger readers,</p>

<p>2020 is finally behind us, but our recovery is just beginning. Reader support has ensured that our dedicated and tenacious team of journalists can continue to bring you important updates as only The Stranger can. Now we're imploring you to help us survive another year. <strong style="color:yellow">Ensure that we're here to ring in our upcoming 30th anniversary by making a one-time or recurring contribution today.</strong></p>

<p>We're so grateful for your support. Thank you.</p>
        <div class="text-right"><a href="/contribute?utm_source=publication&utm_medium=header&utm_campaign=header_ask" class="btn btn-danger btn-large">CONTRIBUTE NOW</a></div>
      </div>
    </div>
  

<div id="site-header" class="navbar navbar-default hidden-xs" role="navigation">
  <div id="top-nav">
    <div class="container">
      <div class="navbar-header">
        <a class="navbar-brand" href="https://www.thestranger.com/"><img src="https://www.thestranger.com/assets/sites/stranger/images/site-logo.png?2018-09-13-121404" alt="The Stranger"></a>
      </div> <!-- /.navbar-header -->

      <div class="navbar-collapse collapse">
        <ul id="nav-site" class="nav navbar-nav">
          <li id="nav-read" class="dropdown" style="margin-left:20px;">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">Things to Read <b class="caret"></b></a>
            <ul class="dropdown-menu" style="min-width:250px;">
              
              
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/slog" target="_self">
                    
                    <i class="fa fa-star"></i>
                    Slog: Seattle's Only Blog
                  </a>
                </li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/sundance" target="_self">
                    
                    <i class="fa fa-star"></i>
                    Sundance Comes to Seattle
                  </a>
                </li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/slog-ampm" target="_self">
                    
                    <i class="fa fa-star"></i>
                    Slog AM/PM
                  </a>
                </li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/sticker-patrol" target="_self">
                    
                    <i class="fa fa-star"></i>
                    Sticker Patrol
                  </a>
                </li>
              
                

                

                

                <li class="highlighted last">
                  <a data-silo="ttr" href="https://www.thestranger.com/high-brr-nation" target="_self">
                    
                    <i class="fa fa-star"></i>
                    It's High-Brr-Nation Season
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/" target="_self">
                    
                    
                    Home
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/savage-love" target="_self">
                    
                    
                    Savage Love
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/news" target="_self">
                    
                    
                    News
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/geek" target="_self">
                    
                    
                    Geek
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/i-anonymous" target="_self">
                    
                    
                    I, Anonymous
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/arts" target="_self">
                    
                    
                    Arts
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/unstreamable" target="_self">
                    
                    
                    Unstreamable
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="http://thestranger.com/how-to-look" target="_self">
                    
                    
                    How to Look
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/weed" target="_self">
                    
                    
                    Weed
                  </a>
                </li>
              
            </ul>
          </li>

          <li id="nav-do" class="dropdown">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">Things to Do <b class="caret"></b></a>
            <ul class="dropdown-menu" style="min-width:250px;">
              
                <li class="everout-nav-item">
                  <a href="https://everout.com/stranger-seattle">
                    <img src="https://www.thestranger.com/assets/sites/everout/everout-logo.png?20190815172027" width="65%;" alt="EverOut">
                  </a>
                </li>
              
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/articles/the-strangers-valentines-gift-guide/c451/" target="_self">
                    <span class="fish-nav"></span>
                    
                    Valentine's Day Gift Guide
                  </a>
                </li>

              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttd" href="https://www.thestranger.com/things-to-do" target="_self">
                    
                    <i class="fa fa-star"></i> 
                    Things To Do Home
                  </a>
                </li>

              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/locations/?feature=covered-patio&feature=heated-patio" target="_self">
                    
                    <i class="fa fa-star"></i> 
                    Covered & Heated Patios
                  </a>
                </li>

              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/" target="_self">
                    
                    <i class="fa fa-star"></i> 
                    All Events
                  </a>
                </li>

              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/?category=livestreamed" target="_self">
                    
                    <i class="fa fa-star"></i> 
                    Livestreamed Events
                  </a>
                </li>

              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/?category=in-person" target="_self">
                    
                    <i class="fa fa-star"></i> 
                    In-Person Events
                  </a>
                </li>

              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/?category=one-day-only" target="_self">
                    
                    <i class="fa fa-star"></i> 
                    One-Day-Only Events
                  </a>
                </li>

              
                

                

                

                <li class="highlighted last">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/?category=bipoc" target="_self">
                    
                    <i class="fa fa-star"></i> 
                    BIPOC-Focused Events
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/locations/?feature=in-person-visits" target="_self">
                    
                    
                    Now-Open Shops & Attractions
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/locations/?category=restaurants&feature=takeout-covid-19&feature=delivery-covid-19&feature=curbside-pickup&feature=walk-up-ordering" target="_self">
                    
                    
                    Takeout & Delivery
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/locations/?category=weed-locations&feature=takeout-covid-19" target="_self">
                    
                    
                    Weed Locations
                  </a>
                </li>

              
            </ul>
          </li>
        </ul>

        

        <ul class="nav navbar-nav navbar-right">
          
            <style>
              
                .contribute-nav-item a {
                  color: blue!important
                }
              
              
                .contribute-nav-item a:hover {
                  color: black!important
                }
              
            </style>
            <li>
              <li class="non-dropdown contribute-nav-item">
                <a class="" data-context="desktop-nav" href="https://www.thestranger.com/contribute?utm_source=publication&utm_medium=top_nav&utm_campaign=top_nav" target="_self">Support The Stranger</a>
              </li>
            </li>
          
          <li id="topNavAccountMenu" class="dropdown nav-account">
            <a href="#" class="link-icon dropdown-toggle" data-toggle="dropdown"><i class="fa fa-user-circle-o"></i></span></a>
            <ul class="dropdown-menu nav-account-menu">
              <li><a href="https://post.thestranger.com/login">Log in</a></li>
              <li><a href="https://post.thestranger.com/login/create">Sign up</a></li>
            </ul>
          </li>
          <li id="navbar-search">
            <a href="#" class="link-icon"><i class="fa fa-search"></i></a>
            <form action="/search" id="navbar-search-form" class="navbar-form" role="search" required>
              <input name="q" id="q" type="text" class="form-control" placeholder="Search" name="srch-term" id="srch-term">
            </form>
          </li>
          
          
          <script>
            $('#filter-search-more').click(function() {
              if(!$(this).hasClass('collapsed')) {
                $('.more-text',this).html('More');
                $('i.fa',this).removeClass('fa-caret-up').addClass('fa-caret-down');
              } else {
                $('.more-text',this).html('Less');
                $('i.fa',this).removeClass('fa-caret-down').addClass('fa-caret-up');
              }
            });
            $("#navbar-search a.link-icon").click(function(){
              $(this).closest('.navbar-right').toggleClass("search-open");
              $(this).siblings("#navbar-search-form").toggle();
              if($(this).closest('.navbar-right').hasClass('search-open')) {
                $(this).siblings("#navbar-search-form").find('.form-control').focus();
              }
              return false;
            });
          </script>
        </ul>
      </div><!--/.navbar-collapse -->
    </div><!-- /.container -->
  </div><!-- /#top-nav -->
</div><!-- /#site-header -->

<div id="mobile-header" class="navbar navbar-default visible-xs hidden-lg hidden-md" role="navigation">
  <div id="mobile-nav">
    









<header class="mobile-nav" role="banner">
  <div class="navbar-header">
    <button type="button" id="mobileNavToggle" class="navbar-toggle collapsed" data-toggle="collapse" data-target=".main-navigation" style="float:right;">
      <div class="navbar-toggle-closed-label">
        
          <span class="navbar-toggle-label-text">Menu</span>
        
        <i class="fa fa-bars"></i>
      </div>
      <div class="navbar-toggle-open-label">
        
          <span class="navbar-toggle-label-text">Close</span>
        
        <i class="fa fa-times"></i>
      </div>
    </button>
    
    <a class="navbar-brand " href="https://www.thestranger.com/"><img src="https://www.thestranger.com/assets/sites/stranger/images/site-logo.png?2018-09-13-121404" alt="The Stranger"></a>
  </div>
  <nav class="navbar-collapse main-navigation collapse" role="navigation" style="height: 1px;max-height:none;">
    <div class="container">
      <div class="row">
        <div class="col-xs-12">
          <form action="https://post.thestranger.com/search" class="navbar-form navbar-right" role="search">
            <div class="form-group input-group">
              <input type="text" class="form-control" name="q" placeholder="Search">
              <span class="input-group-btn">
                <button type="submit" class="btn btn-default"><i class="fa fa-search"></i></button>
              </span>
            </div>
          </form>
        </div>
      </div>
      <div class="row">
        <div class="col-xs-6" style="padding-right:0;">
          <ul class="nav navbar-nav">
            <li class="dropdown-header" style="padding-left:0;">Things To Read</li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/slog" target="_self">
                  <i class="fa fa-star"></i> 
                  
                  Slog: Seattle's Only Blog</a></li>
                </li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/sundance" target="_self">
                  <i class="fa fa-star"></i> 
                  
                  Sundance Comes to Seattle</a></li>
                </li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/slog-ampm" target="_self">
                  <i class="fa fa-star"></i> 
                  
                  Slog AM/PM</a></li>
                </li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/sticker-patrol" target="_self">
                  <i class="fa fa-star"></i> 
                  
                  Sticker Patrol</a></li>
                </li>
              
                

                

                

                <li class="highlighted last">
                  <a data-silo="ttr" href="https://www.thestranger.com/high-brr-nation" target="_self">
                  <i class="fa fa-star"></i> 
                  
                  It's High-Brr-Nation Season</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/" target="_self">
                  
                  
                  Home</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/savage-love" target="_self">
                  
                  
                  Savage Love</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/news" target="_self">
                  
                  
                  News</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/geek" target="_self">
                  
                  
                  Geek</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/i-anonymous" target="_self">
                  
                  
                  I, Anonymous</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/arts" target="_self">
                  
                  
                  Arts</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/unstreamable" target="_self">
                  
                  
                  Unstreamable</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="http://thestranger.com/how-to-look" target="_self">
                  
                  
                  How to Look</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/weed" target="_self">
                  
                  
                  Weed</a></li>
                </li>
              
            <li><a href="/issues">Print Archives</a></li>
          </ul>
        </div>
        <div class="col-xs-6">
          <ul class="nav navbar-nav">
            <li class="dropdown-header" style="padding-left:0;">Things To Do</li>

              
                

                

                

              <li class="highlighted">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/articles/the-strangers-valentines-gift-guide/c451/" target="_self">
                
                <span class="fish-nav"></span>
                Valentine's Day Gift Guide</a></li>
              </li>

            
                

                

                

              <li class="highlighted">
                <a data-silo="ttd" href="https://www.thestranger.com/things-to-do" target="_self">
                <i class="fa fa-star"></i> 
                
                Things To Do Home</a></li>
              </li>

            
                

                

                

              <li class="highlighted">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/locations/?feature=covered-patio&feature=heated-patio" target="_self">
                <i class="fa fa-star"></i> 
                
                Covered & Heated Patios</a></li>
              </li>

            
                

                

                

              <li class="highlighted">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/" target="_self">
                <i class="fa fa-star"></i> 
                
                All Events</a></li>
              </li>

            
                

                

                

              <li class="highlighted">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/?category=livestreamed" target="_self">
                <i class="fa fa-star"></i> 
                
                Livestreamed Events</a></li>
              </li>

            
                

                

                

              <li class="highlighted">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/?category=in-person" target="_self">
                <i class="fa fa-star"></i> 
                
                In-Person Events</a></li>
              </li>

            
                

                

                

              <li class="highlighted">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/?category=one-day-only" target="_self">
                <i class="fa fa-star"></i> 
                
                One-Day-Only Events</a></li>
              </li>

            
                

                

                

              <li class="highlighted last">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/?category=bipoc" target="_self">
                <i class="fa fa-star"></i> 
                
                BIPOC-Focused Events</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/locations/?feature=in-person-visits" target="_self">
                
                
                Now-Open Shops & Attractions</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/locations/?category=restaurants&feature=takeout-covid-19&feature=delivery-covid-19&feature=curbside-pickup&feature=walk-up-ordering" target="_self">
                
                
                Takeout & Delivery</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/locations/?category=weed-locations&feature=takeout-covid-19" target="_self">
                
                
                Weed Locations</a></li>
              </li>

            
          </ul>
        </div>
      </div>
      <div class="row">
        
          <div class="col-xs-6">
            <ul class="nav navbar-nav">
              <li class="dropdown-header" style="padding-left:0;">Other Things</li>
              
                <li><a href="https://www.thestranger.com/contribute" target="_self">Support The Stranger</a></li>
              
                <li><a href="https://www.thestranger.com/ad-info" target="_self">Ad Info & Rates</a></li>
              
                <li><a href="http://www.strangertickets.com" target="_blank">Stranger Tickets</a></li>
              
            </ul>
          </div>
        
        <div id="mobileNavAccountMenu" class="col-xs-6 nav-account">
          <ul class="nav navbar-nav nav-account-menu">
            <li class="dropdown-header" style="padding-left:0;">Account</li>
            <li><a href="https://post.thestranger.com/login">Log in</a></li>
            <li><a href="https://post.thestranger.com/login/create">Sign up</a></li>
          </ul>
        </div>
      </div>
    </div> <!-- end container -->
  </nav>
  <script>
    $('#mobileNavToggle').click(function() {
      var menuAction = $(this).hasClass('collapsed') ? 'openMenu' : 'closeMenu';
      ga('send', {
        hitType: 'event',
        eventCategory: 'MobileNav',
        eventAction: ''+menuAction+''
      });
      $(this).toggleClass('collapsed');
    });
    $('.mobile-nav .nav li a').click(function() {
      var navLabel = $(this).data('silo')+'-'+$(this).text();
      ga('send', {
        hitType: 'event',
        eventCategory: 'MobileNav',
        eventAction: 'click',
        eventLabel: ''+navLabel+''
      });
    });
  </script>
</header>

  </div>
</div>
      <div class="top-super text-center component container">
  <div id="div-gpt-ad-top-super"></div>
  <div id="div-gpt-ad-mobile-top"></div>
</div>
      <div id="siteContent" class="container">
        <div class="row" class="main">
          <div class="col-sm-12 col-md-8 primary">
  
  <div id="articleComponent-55114982" class="component">

    

     <div class="blog-header slog">
  <h1><a href="https://www.thestranger.com/slog"><img id="slogLogo" src="" class="img-responsive slog-logo"></a></h1>
</div>
    
    
    <div id="article-55114982" class="article coll_music">
      <div id="article-header-55114982" class="article-header">
        
          <div class="post-tags-and-date">
            
              <div class="label topic">
                
                  <a href="https://www.thestranger.com/archive/music">Music</a>
                  
                
              </div>
            
          </div>
        
        <h1 class="headline">
          <strong>Refresh Playlist:</strong> New Music for the Week—Featuring TYuS, JoJo, FKA Twigs, and More!
          
        </h1>
        <h2 class="subheadline">
          
        </h2>
        <div class="byline">
          
            by <a href="https://www.thestranger.com/authors/24656453/jenni-moore">Jenni Moore</a>
            
              &bull;
            
          
          
            <span class="post-time">
              Feb  4, 2021 at 11:30 am
            </span>
          
        </div>
        
        
        
          
        
      </div> <!-- end .article-header -->

      <div class="article-text category-slog">
        
        

        <div class="social-tools text-right" style="margin-bottom:10px;position:relative;">
          
          <div class="fb-like"
            data-href="https://www.thestranger.com/slog/2021/02/04/55114982/refresh-playlist-new-music-for-the-week-featuring-tyus-jojo-fka-twigs-and-more"
            data-layout="button_count"
            data-action="like"
            data-show-faces="true"
            data-share="true" style="margin-right:10px;position:relative;top:-5px;"></div>
          
          <a class="twitter-share-button" href="https://twitter.com/share"
            data-url="https://www.thestranger.com/slog/2021/02/04/55114982/refresh-playlist-new-music-for-the-week-featuring-tyus-jojo-fka-twigs-and-more"
            data-text="Refresh Playlist: New Music for the Week&mdash;Featuring TYuS, JoJo, FKA Twigs, and More!">
          Tweet
          </a>
          <script>
          window.twttr=(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],t=window.twttr||{};if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);t._e=[];t.ready=function(f){t._e.push(f);};return t;}(document,"script","twitter-wjs"));
          </script>
          <a style="position:relative;top:-5px;" href="//www.reddit.com/submit?url=https%3A//www.thestranger.com/slog/2021/02/04/55114982/refresh-playlist-new-music-for-the-week-featuring-tyus-jojo-fka-twigs-and-more" target="_blank"><img src="//www.redditstatic.com/spreddit5.gif" alt="submit to reddit" border="0" /></a>
        </div>

        

        
        

        
        
        
        
        
          
          
          
          
          
          
            
            
            
            
              
              <div class="blogImageCenter img-responsive" style="width:500px"><img src="https://media2.fdncms.com/portmerc/imager/u/large/31626308/1612388029-jojo-american-mood-scaled.jpg" alt="American Mood, JoJo" title="American Mood, JoJo"><div class="image-caption-and-credit"><span class="imageCaption">"American Mood," JoJo</span></div></div>Welcome to February, music-loving readers. The world is still on fire and almost everything is trash, but the music being pumped out right now is *chef's kiss* phenomenal. Here is your weekly excuse to unplug from the news, social media, and whatever's on your endless Netflix queue so you can sit back and just relax with some fresh tunes. Here are five new releases to vibe to this week. <br /><hr><br /><h3>“Suicide,” TYuS</h3><br />On January 23, R&B singer TYuS (AKA Tyus Strickland, who now lives in Cali) dropped “Suicide,” a single that sees him getting honest about what’s plagued him along his path to success, and the emotions he’s gone through while navigating the music industry. Toward the end of the song, TYuS sings “Got lost in a cloud of smoke trying hang me from that rope/I'm just too uncontrollable/I always thought of suicide I can't lie/It's bigger than you and me it's for humanity (Is this the place for me?)”<br /><iframe src="https://open.spotify.com/embed/track/6mNHEIM9CergZ638K5f2mU" width="300" height="380" frameborder="0" allowtransparency="true" allow="encrypted-media"></iframe><br /><hr></p>
              
            
              
              
          <a name="more"></a>
          <p><h3>“American Mood,” JoJo </h3><br />The newest single from pop star JoJo is the aptly titled “American Mood,” which from its opening guitar licks almost sounds like it could be a country-folk song reminiscent of the great Tracy Chapman. But JoJo’s stunning vocals steer the single in a more soulful direction, with the 30-year-old singer crooning over truthful lyrics about the state of our imperfect nation. “Hello, hello, I'm on the edge of empathy and privilege/It comes along with who I am somehow,” she begins. Each verse is dedicated to a different American story. In the pre-chorus JoJo sings “We keep on hoping/But dreamers are the first ones thrown away/My hands are open/Optimistic for a different way.” The beautiful chorus sees her continuously stretching the word “mood” into heart-fluttering runs. “American mood/To all the kids without a silver spoon/American mood/You deserve much more, this one's for you.” She also dropped this stunning music video filmed in America’s backyard: <iframe width="560" height="315" src="https://www.youtube.com/embed/lajXaa8T4A8" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe><br /><hr><br /><h3>“At My Worst,” Pink Sweat$, Kehlani</h3><br />You may know R&B singer-songwriter Pink Sweat$ AKA David Bowden for his excellent 2018 single <a href="https://www.youtube.com/watch?v=-Y9VtoPvtuM">“Honesty.”</a> Recently the artist dropped the new single “At My Worst,” as well as an even newer remix featuring Kehlani. “I need somebody who can love me at my worst/No I’m not perfect but I hope you see my worth,” the relatable and honesty chorus goes. Also be sure to check out the new music video below: <iframe width="560" height="315" src="https://www.youtube.com/embed/8CEJoCr_9UI" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
              <div class="fish-butter article-inline-native" data-context-oid="41865578" data-ad-oid="41865577">
      <h3 class="article-inline-text">
        <a href="https://post.thestranger.com/seattle/clickclick?adoid=41865577&poid=41865578&url=https%3A//www.thestranger.com/contribute%3Futm_source%3Dpublication%26utm_medium%3Darticle_inline%26utm_campaign%3Dinline_music" target="_blank" rel="nofollow">
          Support <em>The Stranger</em>
        </a>
      </h3>
      <div>
        <a href="https://post.thestranger.com/seattle/clickclick?adoid=41865577&poid=41865578&url=https%3A//www.thestranger.com/contribute%3Futm_source%3Dpublication%26utm_medium%3Darticle_inline%26utm_campaign%3Dinline_music" target="_blank" rel="nofollow" style="font-size:1rem;font-weight:normal;">
          More than ever, we depend on your support to help fund our coverage. Support local, independent media with a  one-time or recurring contribution. Thank you!
        </a>
      </div>
    </div>
            
              
               <p><hr><br /><h3><em>COLOURS</em>, PARTYNEXTDOOR</h3><br />At the end of January, Canadian R&B singer-songwriter PARTYNEXTDOOR, AKA Jahron Anthony Brathwaite, dropped a new EP called <em>COLOURS</em>, the follow-up to his 2020 studio album Partymobile. Opening track “LET’S GET MARRIED” is appealing in its progressive chaos, setting a great tone for the 8-track project. Other highlights include “JUS KNOW” featuring Travis Scott and especially “PEACE OF MIND.” The latter is about wanting to be laid up with a lover all day, but having money-making obligations to get to. “When it feels this good, you better keep her around, yeah /When it feels this good she get the key to the house, yeah,” he sings. “I'ma treat her like a spouse/Because in exchange you give me peace of mind/Baby, you could take all my time.”<br /><iframe width="560" height="315" src="https://www.youtube.com/embed/u5BtzthT41w" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe><br /><hr></p>
              
            
              
               <p><h3>“Don’t Judge Me,” FKA Twigs</h3><br />If you’re a fan of bright, alternative, or progressive R&B in the vein of artists like Solange or Chloe & Halle, you’ll likely love this new single, “Don’t Judge Me,” from FKA Twigs, UK rapper Headie One, and producer Fred again. The song was originally from Headie One and Fred again’s 2020 album <em>GANG</em>, called “Judge Me (Interlude).” Here Twigs offers light high-pitched vocals over the song’s dance-worthy pulse. Twigs sings “Don't judge me, take care of me/Don't judge me, take care of my heart/Don't judge me, be there for me/Don't judge me, just hold me in your arms.” Isn’t that what we all need right now? Check out the trippy visual below.<iframe width="560" height="315" src="https://www.youtube.com/embed/QJacful-tII" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
              
            
              
               <div style="text-align:center;">••••••</div></p>
              
            
           

        

        
        

        

        

        
          
        

      </div> <!-- end .article-text -->

      
      
        <script id="fdncms-carousel-top-stories-video" src="https://www.hub.fdncms.com/gyrobase/Responsive/Components/Content/TopStoriesVideo?cb=72fc8652&key=bc2394029788a572f638c2af9ed8678a&req=js" async></script>
      

      
      
        
          <div id="mc_embed_signup" style="padding: 30px 10px; background:#fff;font:15px Georgia,serif;width:100%; font-weight: normal; text-align: center;">
<form action="https://thestranger.us4.list-manage.com/subscribe?u=739a0d2f2ff0031156e7b3d55&amp;id=f02129603b" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" target="_blank" novalidate="">
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL" style="font-weight: normal; padding: 5px;">To get this delivered to your inbox, subscribe to <i>The Stranger</i>'s Slog AM newsletter.</label>
<div class="input-group" style=" width=100%; max-width:400px; margin: 0 auto;">
<input type="hidden" name="group[19329][4]" value="checked">
<input class="form-control" type="email" value="" name="EMAIL" id="mce-EMAIL" placeholder="email address" required="" style="border-radius: 4px;border-bottom-right-radius: 0;border-top-right-radius: 0;">
<div style="position: absolute; left: -5000px;" aria-hidden="true">
<input type="text" name="b_739a0d2f2ff0031156e7b3d55_67f93c78f9" tabindex="-1" value=""></div>
<span class="input-group-btn"><button class="btn btn-default" style="font-weight: normal;" type="submit" value="Subscribe" name="subscribe">Subscribe</span></div></div></form></div>
        
      
    </div> <!-- end .article -->

    <!-- article-contribution-footer -->
    
    
      <div class="article-contribution-footer">
        <em>The Stranger</em> depends on your continuing support to provide articles like this one. In return, we pledge our ongoing commitment to truthful, progressive journalism and serving our community. So if you’re able, please consider a small recurring contribution. Thank you—you are appreciated!
        <div style="margin-top:1rem;"><a href="/contribute?utm_source=publication&utm_medium=article_footer&utm_campaign=footer_ask" class="btn btn-danger btn-large">CONTRIBUTE NOW</a></div>
      </div>
    
    <!-- article-contribution-footer -->

    

    <div class="row social-tools" style="margin-top:1.5em; clear:both;">
      <div class="col-xs-12 col-sm-5 text-center lg-social-btn">
        <a href="http://www.facebook.com/sharer.php?u=https%3A//www.thestranger.com/slog/2021/02/04/55114982/refresh-playlist-new-music-for-the-week-featuring-tyus-jojo-fka-twigs-and-more&amp;t=Refresh+Playlist%3A+New+Music+for+the+Week%E2%80%94Featuring+TYuS%2C+JoJo%2C+FKA+Twigs%2C+and+More%21" target="_blank" onclick="window.open(this.href, '_blank', 'toolbar=no, scrollbars=auto, resizable=yes, top=250, left=250, width=500, height=500'); return false;"><img class="img-responsive" src="/images/social/share-on-facebook.png" alt="Share on Facebook" style=""></a>
      </div>
      <div class="col-xs-12 col-sm-5 text-center lg-social-btn">
        <a href="http://twitter.com/intent/tweet?&amp;url=https%3A//www.thestranger.com/slog/2021/02/04/55114982/refresh-playlist-new-music-for-the-week-featuring-tyus-jojo-fka-twigs-and-more&amp;text=Refresh+Playlist%3A+New+Music+for+the+Week%E2%80%94Featuring+TYuS%2C+JoJo%2C+FKA+Twigs%2C+and+More%21&amp;related=strangerslog" target="_blank" onclick="window.open(this.href, '_blank', 'toolbar=no, scrollbars=auto, resizable=yes, top=250, left=250, width=500, height=500'); return false;"><img class="img-responsive" src="/images/social/share-on-twitter.png" alt="Share on Twitter" style=""></a>
      </div>
      
        <div class="col-xs-12 col-sm-2 text-center" style="padding-bottom:0.2em;">
          <h3 style="margin-top:5px;">
            
              <a href="/slog/2021/02/04/55114982/refresh-playlist-new-music-for-the-week-featuring-tyus-jojo-fka-twigs-and-more/comments" rel="nofollow"><i class="fa fa-comment-o"></i></a>
            
          </h3>
        </div>
      
    </div>

    
    

    
      

      
    

    <div class="component related-content" style="padding:1em 0; border-bottom:1px solid #ddd; margin-bottom:1em;">
        <h2 style="margin:0 0 0.5em; padding-top: 25px; border-top: 1px solid #ddd">You might also be interested in these:</h2>
        
        
        <div class="related-content-row" style="padding:0.5em 0;">
        
          <h3 class="headline">
            <a href="https://www.thestranger.com/slog/2021/02/04/55100632/seattle-department-of-design-wants-to-make-civic-pride-cool" rel="nofollow">Seattle Department of Design Wants to Make Civic Pride Cool</a>
          </h3>
          
          
            <div class="byline">
              by <a href="https://www.thestranger.com/authors/32434319/jasmyne-keimig">Jasmyne Keimig</a>
            </div>
          
        
      </div>
        
      
        
        <div class="related-content-row" style="padding:0.5em 0;">
        
          <h3 class="headline">
            <a href="https://www.thestranger.com/slog/2021/02/04/55084559/where-to-get-super-bowl-2021-takeout-in-seattle-plus-where-to-watch-the-big-game" rel="nofollow">Where to Get Super Bowl 2021 Takeout in Seattle—Plus Where to Watch the Big Game</a>
          </h3>
          
          
            <div class="byline">
              by <a href="https://www.thestranger.com/authors/22700136/everout-things-to-do">Stranger EverOut Staff</a>
            </div>
          
        
      </div>
        
      
        
        <div class="related-content-row" style="padding:0.5em 0;">
        
          <h3 class="headline">
            <a href="https://www.thestranger.com/slog/2021/02/04/55107881/slog-am-sara-nelson-runs-for-city-council-grocery-industry-suing-seattle-over-hazard-pay-uzis-forehead-shines-bright-like-a-diamond" rel="nofollow"><strong>Slog AM:</strong> Sara Nelson Runs for City Council, Grocery Industry Sues Seattle, Uzi's Forehead Shines Bright Like a Diamond</a>
          </h3>
          
          
            <div class="byline">
              by <a href="https://www.thestranger.com/authors/32434319/jasmyne-keimig">Jasmyne Keimig</a>
            </div>
          
        
      </div>
        
      
          </div>

    <br>
    <div id="div-gpt-ad-mobile-bottom" class="interstitial-ad"></div>
    <div id="div-gpt-ad-bottom" class="interstitial-ad"></div>
    

  </div> <!-- end component -->
</div>
<div class="col-sm-12 col-md-4 secondary">
  <!-- stranger content sidebar ads -->
<div class="article-sidebar sidebar-ads text-right">
  
    <div class="sidebar-ad-1">
      <div id="div-gpt-ad-sidebar-1" class="sidebar-ad"></div>
    </div>
  
    <div class="sidebar-ad-2">
      <div id="div-gpt-ad-sidebar-2" class="sidebar-ad"></div>
    </div>
  
    <div class="sidebar-ad-3">
      <div id="div-gpt-ad-sidebar-3" class="sidebar-ad"></div>
    </div>
  
    <div class="sidebar-ad-4">
      <div id="div-gpt-ad-sidebar-4" class="sidebar-ad"></div>
    </div>
  
    <div class="sidebar-ad-5">
      <div id="div-gpt-ad-sidebar-5" class="sidebar-ad"></div>
    </div>
  
    <div class="sidebar-ad-6">
      <div id="div-gpt-ad-sidebar-6" class="sidebar-ad"></div>
    </div>
  
</div>
</div>
        </div>
        <div class="row">
          <div class="col-sm-12">
            <div class="bottom-super text-center">
  <div id="div-gpt-ad-bottom-super" class="gpt-dfp"></div>
</div>
          </div>
        </div>
      </div><!-- /#siteContent -->
      <div id="site-footer">
        <div class="hidden-xs hidden-sm">
  <div id="footer-features">
    <div class="container">
      <div class="footer-row">
        
            
          
          
          <div class="col-md-2 text-center" style="width:25%;">
            <i class="fa fa-envelope"></i>
            <h4><a href="/newsletters">Newsletters</a></h4>
            <p>Sign up for the latest news and to win free tickets to events</p>
          </div>
        
          
          <div class="col-md-2 text-center" style="width:25%;">
            <i class="fa fa-ticket"></i>
            <h4><a href="http://www.strangertickets.com">Stranger Tickets</a></h4>
            <p>Buy tickets to events around Seattle</p>
          </div>
        
          
          <div class="col-md-2 text-center" style="width:25%;">
            <i class="fa fa-calendar"></i>
            <h4><a href="https://everout.com/stranger-seattle/">EverOut<br>Things To Do</a></h4>
            <p>Comprehensive calendar of Seattle events</p>
          </div>
        
          
          <div class="col-md-2 text-center" style="width:25%;">
            <i class="fa fa-mobile"></i>
            <h4><a href="/thingstodoapp">EverOut App</a></h4>
            <p>The easiest way to find Seattle's best events</p>
          </div>
        
      </div>
    </div>
  </div>
</div><!-- footer (hidden-xs hidden-sm) -->

      
        







<div class="hidden-xs hidden-sm">
  <div id="footer-features-2">
    <div class="container">
      <div class="footer-row">
        <div class="col col-md-4 text-center">
          <h4>Publication Info</h4>
            <ul class="list-unstyled">
              <li><a href="https://www.thestranger.com/masthead">Masthead</a></li>
              <li><a href="https://www.thestranger.com/ad-info">Ad Info &amp; Rates</a></li>
              
                <li><a href="https://www.thestranger.com/distribution">Distribution</a></li>
              
              <li><a href="https://www.thestranger.com/jobs">Jobs at The Stranger</a></li>
              <li><a href="https://www.thestranger.com/contact-information">Contact</a></li>
              <li><a href="https://everout.com/">EverOut</a></li>
              <li><br></li>
              <li><a href="https://www.thestranger.com/contribute?utm_source=publication&utm_medium=footer_nav&utm_campaign=footer_nav">Contribute</a></li>
            </ul>
        </div>
        <div class="col col-md-4 text-center" style="border-right: solid 1px white; border-left: solid 1px white;">
          <h4>Check it out</h4>
          
            <div class="footer-promo" id="" style="margin-left:0">
              <a href="https://www.savagelovecast.com">
                
                  <img src="https://media1.fdncms.com/stranger/imager/u/original/39759989/savagelovecast.jpg" alt="Savage Lovecast">
                
              </a>
            </div>
          
            <div class="footer-promo" id="" style="margin-left:0">
              <a href="http://www.cocktailcompass.com">
                
                  <img src="https://media2.fdncms.com/stranger/imager/u/original/39759990/cocktailcompass-188x80.png" alt="Cocktail Compass">
                
              </a>
            </div>
          
            <div class="footer-promo" id="" style="margin-left:0">
              <a href="/promotions">
                
                  <img src="https://media1.fdncms.com/stranger/imager/u/original/39759991/checkitout_button-contests.png" alt="The Stranger Promotions">
                
              </a>
            </div>
          
        </div>
        <div class="col col-md-4 text-center">
          <h4>Follow Us</h4>
          
              <ul id="footer-social-links" class="list-unstyled text-left">
            
            
            <li><a href="/syndication" target="_blank"><i class="fa fa-rss"></i> RSS</a></li>
            
          
            
            <li><a href="http://www.facebook.com/strangerseattle" target="_blank"><i class="fa fa-facebook"></i> Facebook</a></li>
            
          
            
            <li><a href="/twitter" target="_blank"><i class="fa fa-twitter"></i> Twitter</a></li>
            
          
            
            <li><a href="http://instagram.com/thestrangerseattle" target="_blank"><i class="fa fa-instagram"></i> Instagram</a></li>
            
          
              </ul>
            
        </div>
      </div>
    </div>
  </div>
</div><!-- footer (hidden-xs hidden-sm) -->

      
        

<div class="hidden-xs hidden-sm">
  <div id="footer-copyright">
    <div class="container">
      <div class="footer-row">
        <div class="col-md-6">
          <div class="footer-brand">
            
              <a href="https://www.thestranger.com/"><img src="https://www.thestranger.com/assets/sites/stranger/images/site-logo.png?2018-09-13-121404" alt="The Stranger"></a>
            
          </div>
          
          <p class="footer-copyright">
            
              All contents &copy; Index Newspapers LLC<br>
800 Maynard Ave S, Suite 200, Seattle, WA 98134
            
          </p>
        </div>
        <div class="col-md-6">
          <p class="footer-links text-right">
            <a href="https://www.thestranger.com/contact-information">Contact</a>
            <span class="lighter separater">|</span>
            <a href="https://www.thestranger.com/privacy-policy">Privacy Policy</a>
            <span class="lighter separater">|</span>
            <a href="https://www.thestranger.com/terms-of-use">Terms of Use</a>
            <span class="lighter separater">|</span>
            <a href="https://www.thestranger.com/takedown-policy">Takedown Policy</a>
          </p>
        </div>
      </div>
    </div>
  </div>
</div> <!-- footer (hidden-xs hidden-sm) -->

      
        

<div id="footer-mobile"  class="hidden-md hidden-lg">
  <div class="container">
    <div class="footer-row">
      <div class="col-sm-12 text-center">
        <div id="footer-mobile-social-links">
          
            <a href="/syndication" target="_blank"><i class="fa fa-rss"></i></a>
          
            <a href="http://www.facebook.com/strangerseattle" target="_blank"><i class="fa fa-facebook"></i></a>
          
            <a href="/twitter" target="_blank"><i class="fa fa-twitter"></i></a>
          
            <a href="http://instagram.com/thestrangerseattle" target="_blank"><i class="fa fa-instagram"></i></a>
          
        </div>
        <div class="footer-brand">
          
            <a href="https://www.thestranger.com/"><img src="https://www.thestranger.com/assets/sites/stranger/images/site-logo.png?2018-09-13-121404" alt="The Stranger"></a>
          
        </div>
        
        <p class="footer-copyright">
          
            All contents &copy; Index Newspapers LLC<br>
800 Maynard Ave S, Suite 200, Seattle, WA 98134
          
        </p>
        <p class="footer-links">
          <small>
            <a href="https://www.thestranger.com/contact-information">Contact</a> |
            <a href="https://www.thestranger.com/privacy-policy">Privacy Policy</a> |
            <a href="https://www.thestranger.com/terms-of-use">Terms of Use</a> |
            <a href="https://www.thestranger.com/takedown-policy">Takedown Policy</a>
          </small>
        </p>
      </div>
    </div>
  </div>
</div> <!-- /footer-mobile -->
      </div> <!-- /#site-footer -->
    </div> <!-- /.wrapper -->
    <!-- content background ad -->
<div id="div-gpt-ad-background"></div>

      
        


 


















<script>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</script>








<div id="fb-root"></div>

  <script>
    window.fbAsyncInit = function() {
      FB.init({
        appId      : '43933993878',
        xfbml      : true,
        version    : 'v2.6'
      });
    };
  </script>

<script>(function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
    fjs.parentNode.insertBefore(js, fjs);
  }(document, 'script', 'facebook-jssdk'));</script>


<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-332219-1', 'auto');
  ga('require', 'linkid', 'linkid.js');
  ga('set', 'anonymizeIp', true);

  var user = JSON.parse($.cookie('user'));
  var dimension1Value = "";
  var dimension2Value = "";
  var dimension3Value = "";
  var dimension4Value = "";
  var dimension5Value = "slog";
  var dimension6Value = "";
  var dimension7Value = "Jenni Moore";
  var dimension8Value = "stranger-editorial-music";
  var dimension9Value = "";
  var dimension10Value = user ? user.type : "Guest";
  var dimension11Value = $.map($('.fish-butter'), function(val, i) {
      return $(val).data('adOid')
  }).join(",");
  ga('set', 'dimension1', dimension1Value); // calendar section
  ga('set', 'dimension2', dimension2Value); // location category
  ga('set', 'dimension3', dimension3Value); // location neighborhood
  ga('set', 'dimension4', dimension4Value); // location cuisine
  ga('set', 'dimension5', dimension5Value); // section
  ga('set', 'dimension6', dimension6Value); // category
  ga('set', 'dimension7', dimension7Value); // author
  ga('set', 'dimension8', dimension8Value); // targeting section
  ga('set', 'dimension9', dimension9Value); // location category
  ga('set', 'dimension10', dimension10Value); // user type
  ga('set', 'dimension11', dimension11Value); // native ads
  ga('send', 'pageview');
</script>




<script>
  // track location categories
  var locationCategories = [];
  function trackLocationCategories(i) {
    ga('send', 'event', 'Custom Dimension Event', 'Location Page Categories', 'Location Page Categories', {nonInteraction: true, 'dimension9': locationCategories[i], 'metric1': 1});
  }
  for (var i = 0; i < locationCategories.length; i++) {
    setTimeout(trackLocationCategories(i), 3000);
  }
</script>

<script>
  $(function() {
    $("audio").bind("play", function(e){
      var source = ($(this).attr('src')) ? $(this).attr('src') : $(this).find('source').attr('src');
      ga('send', {
        hitType: 'event',
        eventCategory: 'Audio',
        eventAction: 'play',
        eventLabel: source
      });
    });
  });
</script>



<script type='text/javascript'>
    var _sf_async_config = _sf_async_config || {};
    /** CONFIGURATION START **/
    _sf_async_config.sections = 'slog';
    _sf_async_config.authors = 'Jenni Moore';
    /** CONFIGURATION END **/
    (function(){
      function loadChartbeat() {
        window._sf_endpt=(new Date()).getTime();
        var e = document.createElement('script');
        e.setAttribute('language', 'javascript');
        e.setAttribute('type', 'text/javascript');
        e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
        document.body.appendChild(e);
      }
      var oldonload = window.onload;
      window.onload = (typeof window.onload != 'function') ?
        loadChartbeat : function() { oldonload(); loadChartbeat(); };
    })();
</script>


<!-- Start Quantcast tag -->

<script type="text/javascript">
  _qcJSHost = (("https:" == document.location.protocol) ? "https://secure." : "http://edge.");
  _qoptions={
    qacct:"p-aaXEgDiyQODdU"
  };
  document.write(unescape("%3Cscript src='" + _qcJSHost + "quantserve.com/quant.js' type='text/javascript'%3E%3C/script%3E"));
</script>
<noscript>
  <img src="https://secure.quantserve.com/pixel/p-aaXEgDiyQODdU.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast">
</noscript>
<!-- End Quantcast tag -->

<!-- Start Quantcast tag -->
<script type="text/javascript">
_qcJSHost = (("https:" == document.location.protocol) ? "https://secure." : "http://edge.");
 _qoptions={
   qacct:"p-a4LDpi_DEopn-"
 };
</script>
<noscript>
  <img src="https://secure.quantserve.com/pixel/p-a4LDpi_DEopn-.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast">
</noscript>
<!-- End Quantcast tag -->
  </body>
</html>
   
 

