 <!DOCTYPE html>
<html lang="en">
  <head>
    <!-- Google Tag Manager -->
  <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','dataLayer','GTM-5GMVQ6J');</script>
  <!-- End Google Tag Manager -->






<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=yes">
<meta name="google-site-verification" content="Yn7U5qsaj-oKD3y_qp7IbGawlVoNxW1Pzu87ZOHqabU">
<meta name="view-id" content="article">
<!-- start Omniconvert.com code -->
<link rel="dns-prefetch" href="//app.omniconvert.com" /> <script type="text/javascript">window._mktz=window._mktz||[];</script> <script src="//cdn.omniconvert.com/js/sd0d155.js"></script>
<!-- end Omniconvert.com code -->



<title>Slog AM: A Week Is Not Complete Without a Mass Shooting, Inslee Wants to Fight COVID with Nice Weather, Cops Caught Giving Cold Cash to Kyle Rittenhouse - Slog - The Stranger</title>


  

  

  

  

  <meta name="twitter:card" content="summary_large_image" />
  <meta name="twitter:site" content="@thestranger" />
  <meta name="twitter:image" content="https://media2.fdncms.com/stranger/imager/u/large/56589538/1618587750-gettyimages-887843396.jpg" />
  <meta property="og:title" content="Slog AM: A Week Is Not Complete Without a Mass Shooting, Inslee Wants to Fight COVID with Nice Weather, Cops Caught Giving Cold Cash to Kyle Rittenhouse" />
  <meta property="og:description" content="This time: a FedEx facility in Indianapolis. This time: 8 dead people and as many wounded. The nightmare, which is believed to have lasted for about two minutes, came to an end only when the killer, armed with an automatic rifle, joined the dead. CNN reports that &quot;the incident marks at least the 45th mass shooting in the United States since the Atlanta-area spa shootings on March 16.&quot; That&#39;s right. Forty-five mass shootings in just..." />
  <meta name="description" content="This time: a FedEx facility in Indianapolis. This time: 8 dead people and as many wounded. The nightmare, which is believed to have lasted for about two minutes, came to an end only when the killer, armed with an automatic rifle, joined the dead. CNN reports that &quot;the incident marks at least the 45th mass shooting in the United States since the Atlanta-area spa shootings on March 16.&quot; That&#39;s right. Forty-five mass shootings in just..." />
  <meta property="og:site_name" content="The Stranger" />
  <meta property="og:type" content="article" />
  <meta property="og:image" content="https://media2.fdncms.com/stranger/imager/u/large/56589538/1618587750-gettyimages-887843396.jpg" />
  <meta property="article:publisher" content="https://www.facebook.com/strangerseattle" />
  
    
  
  <meta name="apple-mobile-web-app-title" content="Slog AM: A Week Is Not Complete Without a Mass Shooting, Inslee Wants to Fight COVID with Nice Weather, Cops Caught Giving Cold Cash to Kyle Rittenhouse - Slog - The Stranger" />
  
    <link rel="apple-touch-icon-precomposed"  href="/images/mobile/touchicons/default/touch-icon-60.png" />
  
    <link rel="apple-touch-icon-precomposed" sizes="76x76" href="/images/mobile/touchicons/default/touch-icon-76.png" />
  
    <link rel="apple-touch-icon-precomposed" sizes="120x120" href="/images/mobile/touchicons/default/touch-icon-120.png" />
  
    <link rel="apple-touch-icon-precomposed" sizes="152x152" href="/images/mobile/touchicons/default/touch-icon-152.png" />
  

  <link rel="mask-icon" href="https://www.thestranger.com/assets/sites/stranger/images/site-badge.svg" color="#000000">
  <link rel="icon" type="image/x-icon" href="https://www.thestranger.com/assets/sites/stranger/images/favicon.png">

  
    <meta property="fb:app_id" content="43933993878"/>
  
  
    <meta property="fb:admins" content="741428065"/>
  
  
    <meta property="fb:pages" content="56439755991" />
  

  

  
  
  
    <link rel="canonical" href="https://www.thestranger.com/slog/2021/04/16/56577267/slog-am-a-week-is-not-complete-without-a-mass-shooting-inslee-wants-to-fight-covid-with-nice-weather-cops-caught-giving-cold-cash-to-kyle-r" />
    <meta property="og:url" content="https://www.thestranger.com/slog/2021/04/16/56577267/slog-am-a-week-is-not-complete-without-a-mass-shooting-inslee-wants-to-fight-covid-with-nice-weather-cops-caught-giving-cold-cash-to-kyle-r" />
  
  
   <link rel="alternate" type="application/rss+xml" title="The Stranger: Whole Site" href="/seattle/Rss.xml"/>

  <link rel="alternate" type="application/rss+xml" title="The Stranger: Slog Section" href="/seattle/Rss.xml?section=529161"/>


  
    <link rel="alternate" type="application/rss+xml" title="The Stranger: Articles by Charles Mudede" href="/seattle/Rss.xml?author=237"/>
 

<!-- revved -->

<link href="https://www.thestranger.com/assets/build/css/styles.a4d2e2e5.css" rel="stylesheet">

<link rel="stylesheet" href="https://use.fontawesome.com/baf88c5825.css">


<!-- jQuery (necessary for Bootstrap's JavaScript plugins) -->
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.0/jquery.min.js"></script>
<!-- Include all compiled plugins (below), or include individual files as needed -->
<script src="https://stackpath.bootstrapcdn.com/bootstrap/3.4.1/js/bootstrap.min.js" integrity="sha384-aJ21OjlMXNL5UyIl/XNwTMqvzeRMZH2w8c5cRVpzpU8Y5bApTppSuUkhZXN0VxHd" crossorigin="anonymous"></script>


<script src="/seattle/Library/Environment/JavascriptEnvironmentScript"></script>


  <script src="https://www.thestranger.com/assets/build/js/app.e765bde4.js"></script>


<!-- HTML5 Shim and Respond.js IE8 support of HTML5 elements and media queries -->
<!-- WARNING: Respond.js doesn't work if you view the page via file:// -->
<!--[if lt IE 9]>
  <script src="https://oss.maxcdn.com/libs/html5shiv/3.7.0/html5shiv.js"></script>
  <script src="https://oss.maxcdn.com/libs/respond.js/1.4.2/respond.min.js"></script>
<![endif]-->



  <!-- Hotjar Tracking Code for thestranger.com -->
  
  






<!--   typekit -->
<script type="text/javascript" src="//use.typekit.net/wjg1xbh.js"></script>
<script type="text/javascript">try{Typekit.load();}catch(e){}</script>







<script type='text/javascript'>
function getWidth() {
  if (self.innerHeight) {
    return self.innerWidth;
  }
  if (document.documentElement && document.documentElement.clientHeight) {
    return document.documentElement.clientWidth;
  }
  if (document.body) {
    return document.body.clientWidth;
  }
}
var documentWidth = getWidth();

var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
  var gads = document.createElement('script');
  gads.async = true;
  gads.type = 'text/javascript';
  var useSSL = 'https:' == document.location.protocol;
  gads.src = (useSSL ? 'https:' : 'http:') +
  '//www.googletagservices.com/tag/js/gpt.js';
  var node = document.getElementsByTagName('script')[0];
  node.parentNode.insertBefore(gads, node);
})();
</script>

<script type="text/javascript">
  // in gyrobase
  // $(document).ready(function() {
  //   if($('.fish-butter') && !navigator.userAgent.match(/bot|googlebot|crawler|spider|robot|crawling|PhantomJS|BingPreview/ig)){
  //     $('.fish-butter').each(function() {
  //       var xhr = new XMLHttpRequest();
  //       var data = {
  //         'oid': $(this).data('adOid'),
  //         'context': $(this).data('contextOid')
  //       }
  //       xhr.open('POST', '/_private/tracking/record-hit');
  //       xhr.setRequestHeader('Content-Type', 'application/json');
  //       xhr.setRequestHeader('X-CSRF-Token', getCookie('csrfToken'));
  //       xhr.onload = function() {
  //         var response = JSON.parse(xhr.responseText);
  //         if (xhr.status === 200) {
  //         } else {
  //         }
  //       };
  //       xhr.send(JSON.stringify(data));
  //     });
  //   }
  // });

  // in keen
  !function(name,path,ctx){
    var latest,prev=name!=='Keen'&&window.Keen?window.Keen:false;ctx[name]=ctx[name]||{ready:function(fn){var h=document.getElementsByTagName('head')[0],s=document.createElement('script'),w=window,loaded;s.onload=s.onerror=s.onreadystatechange=function(){if((s.readyState&&!(/^c|loade/.test(s.readyState)))||loaded){return}s.onload=s.onreadystatechange=null;loaded=1;latest=w.Keen;if(prev){w.Keen=prev}else{try{delete w.Keen}catch(e){w.Keen=void 0}}ctx[name]=latest;ctx[name].ready(fn)};s.async=1;s.src=path;h.parentNode.insertBefore(s,h)}}
  }('KeenAsync','https://d26b395fwzu5fz.cloudfront.net/keen-tracking-1.0.3.min.js',this);

  KeenAsync.ready(function(){
      // Configure a client instance
      var client = new KeenAsync({
        projectId: '58b718b78db53dfda8a8a0eb',
        writeKey: '326C65A94101E46B8EF1B20D83CA64E04F13DEEF29A28D5D7E39F4F5833AFB8F1E0C98E7836FB62A52269ECF45B4AF7C30417251B5A7EE01E34071751EB398A79E24280EEA32F15CC3D607C32274ABA72CD3C460A3F0EB9361D304A6F5391B91'
      });

      // Record views of sponsored posts
      if($('.fish-butter') && !navigator.userAgent.match(/bot|googlebot|crawler|spider|robot|crawling|PhantomJS|BingPreview/ig)){

        // in keen
        $('.fish-butter').each(function() {
          client.recordEvent('adViews', {
            publication: "stranger",
            ad: {
              oid: $(this).data('adOid')
            },
            placement: {
              oid: $(this).data('contextOid')
            },
            user_agent: navigator.userAgent,
            page_url: location.href,
            keen: {
              addons: [{
                name: "keen:ua_parser",
                input: {
                  ua_string: "user_agent"
                },
                output: "parsed_user_agent"
              },{
                name: "keen:url_parser",
                input: {
                  url: "page_url"
                },
                output: "parsed_page_url"
              },{
                name: "keen:date_time_parser",
                input: {
                  date_time: "keen.timestamp"
                },
                output: "timestamp_info"
              }]
            }
          });
        })

      }
    });
</script>


<script type="text/javascript">
     var _sf_async_config = _sf_async_config || {};
     /** CONFIGURATION START **/
     _sf_async_config.uid = 65679
     _sf_async_config.domain = "thestranger.com";
     _sf_async_config.useCanonical = true;
     /** CONFIGURATION END **/
     var _sf_startpt = (new Date()).getTime();
</script>
<script src="//static.chartbeat.com/js/chartbeat_mab.js"></script>
  </head>
  <body class="article  article-section-slog">
    <div class="wrapper">
      <div class="network-bar navbar hidden-xs navbar-expand-md navbar-dark bg-dark">
    <div class="container">
      <ul class="nav navbar-nav mr-auto">
        
          
            <li class="nav-item"><a class="nav-link" href="https://thestranger.com" target="self">The Stranger</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          
            <li class="nav-item"><a class="nav-link" href="https://portlandmercury.com" target="self">Portland Mercury</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          
            <li class="nav-item"><a class="nav-link" href="https://everout.com/stranger-seattle/" target="self">EverOut</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          
            <li class="nav-item"><a class="nav-link" href="https://www.savagelovecast.com" target="self">Savage Love</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          
            <li class="nav-item"><a class="nav-link" href="https://humpfilmfest.com" target="self">Hump</a></li>
          
          
        
      </ul>
    </div>
  </div>



  
  
    <div id="aboveNav" style="background:#5588CC;border-bottom:1px solid #999;position:relative;margin-bottom:-1px;color:#FCFCFC">
      <div class="container donate-ask">
        
        <p>One year later, we're still here. Thank you, Seattle, for your resilience and readership throughout the COVID-19 pandemic.</p>

<p>Contributions from our readers are a crucial lifeline for <em>The Stranger</em> as we write our new future. We're calling up legislators, breaking down what's going on at Seattle City Hall, and covering the region's enduring arts scenes thanks to assistance from readers like you. If <em>The Stranger</em> is an essential part of your life, <a href="https://www.thestranger.com/contribute?utm_source=publication&utm_medium=header&utm_campaign=header_ask" target="_blank" style="color: yellow"><strong>please make a one-time or recurring contribution today</strong></a> to ensure we're here to serve you tomorrow.</p>

<p>We're so grateful for your support.</p>
        <div class="text-right"><a href="/contribute?utm_source=publication&utm_medium=header&utm_campaign=header_ask" class="btn btn-danger btn-large">CONTRIBUTE NOW</a></div>
      </div>
    </div>
  

<div id="site-header" class="navbar navbar-default hidden-xs" role="navigation">
  <div id="top-nav">
    <div class="container">
      <div class="navbar-header">
        <a class="navbar-brand" href="https://www.thestranger.com/"><img src="https://www.thestranger.com/assets/sites/stranger/images/site-logo.png?2018-09-13-121404" alt="The Stranger"></a>
      </div> <!-- /.navbar-header -->

      <div class="navbar-collapse collapse">
        <ul id="nav-site" class="nav navbar-nav">
          <li id="nav-read" class="dropdown" style="margin-left:20px;">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">Things to Read <b class="caret"></b></a>
            <ul class="dropdown-menu" style="min-width:250px;">
              
              
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/sponsored/stranger-420-21" target="_self">
                    <span class="fish-nav"></span>
                    <i class="fa fa-star"></i>
                    Celebrate 420!
                  </a>
                </li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/slog" target="_self">
                    
                    <i class="fa fa-star"></i>
                    Slog: Seattle's Only Blog
                  </a>
                </li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/slog-ampm" target="_self">
                    
                    <i class="fa fa-star"></i>
                    Slog AM/PM
                  </a>
                </li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/sticker-patrol" target="_self">
                    
                    <i class="fa fa-star"></i>
                    Sticker Patrol
                  </a>
                </li>
              
                

                

                

                <li class="highlighted last">
                  <a data-silo="ttr" href="https://www.thestranger.com/washington-state-legislature" target="_self">
                    
                    <i class="fa fa-star"></i>
                    What's Going Down in Olympia
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/" target="_self">
                    
                    
                    Home
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/savage-love" target="_self">
                    
                    
                    Savage Love
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/news" target="_self">
                    
                    
                    News
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/geek" target="_self">
                    
                    
                    Geek
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/i-anonymous" target="_self">
                    
                    
                    I, Anonymous
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/arts" target="_self">
                    
                    
                    Arts
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/unstreamable" target="_self">
                    
                    
                    Unstreamable
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/weed" target="_self">
                    
                    
                    Weed
                  </a>
                </li>
              
            </ul>
          </li>

          <li id="nav-do" class="dropdown">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">Things to Do <b class="caret"></b></a>
            <ul class="dropdown-menu" style="min-width:250px;">
              
                <li class="everout-nav-item">
                  <a href="https://everout.com/stranger-seattle">
                    <img src="https://www.thestranger.com/assets/sites/everout/everout-logo.png?20190815172027" width="65%;" alt="EverOut">
                  </a>
                </li>
              
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/" target="_self">
                    
                    <i class="fa fa-star"></i> 
                    Home
                  </a>
                </li>

              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/?category=in-person" target="_self">
                    
                    <i class="fa fa-star"></i> 
                    In-Person Events
                  </a>
                </li>

              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/locations/?feature=covered-patio&feature=heated-patio" target="_self">
                    
                    <i class="fa fa-star"></i> 
                    Covered & Heated Patios
                  </a>
                </li>

              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/" target="_self">
                    
                    <i class="fa fa-star"></i> 
                    All Events
                  </a>
                </li>

              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/?category=one-day-only" target="_self">
                    
                    <i class="fa fa-star"></i> 
                    One-Day-Only Events
                  </a>
                </li>

              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttd" href="https://everout.com/streamlocal/" target="_self">
                    
                    <i class="fa fa-star"></i> 
                    StreamLocal
                  </a>
                </li>

              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/?category=livestreamed" target="_self">
                    
                    <i class="fa fa-star"></i> 
                    Livestreamed Events
                  </a>
                </li>

              
                

                

                

                <li class="highlighted last">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/?category=bipoc" target="_self">
                    
                    <i class="fa fa-star"></i> 
                    BIPOC-Focused Events
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/locations/?feature=in-person-visits" target="_self">
                    
                    
                    Now-Open Shops & Attractions
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/locations/?category=restaurants&feature=takeout-covid-19&feature=delivery-covid-19&feature=curbside-pickup&feature=walk-up-ordering" target="_self">
                    
                    
                    Takeout & Delivery
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/locations/?category=weed-locations&feature=takeout-covid-19" target="_self">
                    
                    
                    Weed Locations
                  </a>
                </li>

              
            </ul>
          </li>
        </ul>

        

        <ul class="nav navbar-nav navbar-right">
          
            <style>
              
                .contribute-nav-item a {
                  color: blue!important
                }
              
              
                .contribute-nav-item a:hover {
                  color: black!important
                }
              
            </style>
            <li>
              <li class="non-dropdown contribute-nav-item">
                <a class="" data-context="desktop-nav" href="https://www.thestranger.com/contribute?utm_source=publication&utm_medium=top_nav&utm_campaign=top_nav" target="_self">Support The Stranger</a>
              </li>
            </li>
          
          <li id="topNavAccountMenu" class="dropdown nav-account">
            <a href="#" class="link-icon dropdown-toggle" data-toggle="dropdown"><i class="fa fa-user-circle-o"></i></span></a>
            <ul class="dropdown-menu nav-account-menu">
              <li><a href="https://post.thestranger.com/login">Log in</a></li>
              <li><a href="https://post.thestranger.com/login/create">Sign up</a></li>
            </ul>
          </li>
          <li id="navbar-search">
            <a href="#" class="link-icon"><i class="fa fa-search"></i></a>
            <form action="/search" id="navbar-search-form" class="navbar-form" role="search" required>
              <input name="q" id="q" type="text" class="form-control" placeholder="Search" name="srch-term" id="srch-term">
            </form>
          </li>
          
          
          <script>
            $('#filter-search-more').click(function() {
              if(!$(this).hasClass('collapsed')) {
                $('.more-text',this).html('More');
                $('i.fa',this).removeClass('fa-caret-up').addClass('fa-caret-down');
              } else {
                $('.more-text',this).html('Less');
                $('i.fa',this).removeClass('fa-caret-down').addClass('fa-caret-up');
              }
            });
            $("#navbar-search a.link-icon").click(function(){
              $(this).closest('.navbar-right').toggleClass("search-open");
              $(this).siblings("#navbar-search-form").toggle();
              if($(this).closest('.navbar-right').hasClass('search-open')) {
                $(this).siblings("#navbar-search-form").find('.form-control').focus();
              }
              return false;
            });
          </script>
        </ul>
      </div><!--/.navbar-collapse -->
    </div><!-- /.container -->
  </div><!-- /#top-nav -->
</div><!-- /#site-header -->

<div id="mobile-header" class="navbar navbar-default visible-xs hidden-lg hidden-md" role="navigation">
  <div id="mobile-nav">
    









<header class="mobile-nav" role="banner">
  <div class="navbar-header">
    <button type="button" id="mobileNavToggle" class="navbar-toggle collapsed" data-toggle="collapse" data-target=".main-navigation" style="float:right;">
      <div class="navbar-toggle-closed-label">
        
          <span class="navbar-toggle-label-text">Menu</span>
        
        <i class="fa fa-bars"></i>
      </div>
      <div class="navbar-toggle-open-label">
        
          <span class="navbar-toggle-label-text">Close</span>
        
        <i class="fa fa-times"></i>
      </div>
    </button>
    
    <a class="navbar-brand " href="https://www.thestranger.com/"><img src="https://www.thestranger.com/assets/sites/stranger/images/site-logo.png?2018-09-13-121404" alt="The Stranger"></a>
  </div>
  <nav class="navbar-collapse main-navigation collapse" role="navigation" style="height: 1px;max-height:none;">
    <div class="container">
      <div class="row">
        <div class="col-xs-12">
          <form action="https://post.thestranger.com/search" class="navbar-form navbar-right" role="search">
            <div class="form-group input-group">
              <input type="text" class="form-control" name="q" placeholder="Search">
              <span class="input-group-btn">
                <button type="submit" class="btn btn-default"><i class="fa fa-search"></i></button>
              </span>
            </div>
          </form>
        </div>
      </div>
      <div class="row">
        <div class="col-xs-6" style="padding-right:0;">
          <ul class="nav navbar-nav">
            <li class="dropdown-header" style="padding-left:0;">Things To Read</li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/sponsored/stranger-420-21" target="_self">
                  <i class="fa fa-star"></i> 
                  <span class="fish-nav"></span>
                  Celebrate 420!</a></li>
                </li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/slog" target="_self">
                  <i class="fa fa-star"></i> 
                  
                  Slog: Seattle's Only Blog</a></li>
                </li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/slog-ampm" target="_self">
                  <i class="fa fa-star"></i> 
                  
                  Slog AM/PM</a></li>
                </li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/sticker-patrol" target="_self">
                  <i class="fa fa-star"></i> 
                  
                  Sticker Patrol</a></li>
                </li>
              
                

                

                

                <li class="highlighted last">
                  <a data-silo="ttr" href="https://www.thestranger.com/washington-state-legislature" target="_self">
                  <i class="fa fa-star"></i> 
                  
                  What's Going Down in Olympia</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/" target="_self">
                  
                  
                  Home</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/savage-love" target="_self">
                  
                  
                  Savage Love</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/news" target="_self">
                  
                  
                  News</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/geek" target="_self">
                  
                  
                  Geek</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/i-anonymous" target="_self">
                  
                  
                  I, Anonymous</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/arts" target="_self">
                  
                  
                  Arts</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/unstreamable" target="_self">
                  
                  
                  Unstreamable</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/weed" target="_self">
                  
                  
                  Weed</a></li>
                </li>
              
            <li><a href="/issues">Print Archives</a></li>
          </ul>
        </div>
        <div class="col-xs-6">
          <ul class="nav navbar-nav">
            <li class="dropdown-header" style="padding-left:0;">Things To Do</li>

              
                

                

                

              <li class="highlighted">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/" target="_self">
                <i class="fa fa-star"></i> 
                
                Home</a></li>
              </li>

            
                

                

                

              <li class="highlighted">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/?category=in-person" target="_self">
                <i class="fa fa-star"></i> 
                
                In-Person Events</a></li>
              </li>

            
                

                

                

              <li class="highlighted">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/locations/?feature=covered-patio&feature=heated-patio" target="_self">
                <i class="fa fa-star"></i> 
                
                Covered & Heated Patios</a></li>
              </li>

            
                

                

                

              <li class="highlighted">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/" target="_self">
                <i class="fa fa-star"></i> 
                
                All Events</a></li>
              </li>

            
                

                

                

              <li class="highlighted">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/?category=one-day-only" target="_self">
                <i class="fa fa-star"></i> 
                
                One-Day-Only Events</a></li>
              </li>

            
                

                

                

              <li class="highlighted">
                <a data-silo="ttd" href="https://everout.com/streamlocal/" target="_self">
                <i class="fa fa-star"></i> 
                
                StreamLocal</a></li>
              </li>

            
                

                

                

              <li class="highlighted">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/?category=livestreamed" target="_self">
                <i class="fa fa-star"></i> 
                
                Livestreamed Events</a></li>
              </li>

            
                

                

                

              <li class="highlighted last">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/?category=bipoc" target="_self">
                <i class="fa fa-star"></i> 
                
                BIPOC-Focused Events</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/locations/?feature=in-person-visits" target="_self">
                
                
                Now-Open Shops & Attractions</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/locations/?category=restaurants&feature=takeout-covid-19&feature=delivery-covid-19&feature=curbside-pickup&feature=walk-up-ordering" target="_self">
                
                
                Takeout & Delivery</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/locations/?category=weed-locations&feature=takeout-covid-19" target="_self">
                
                
                Weed Locations</a></li>
              </li>

            
          </ul>
        </div>
      </div>
      <div class="row">
        
          <div class="col-xs-6">
            <ul class="nav navbar-nav">
              <li class="dropdown-header" style="padding-left:0;">Other Things</li>
              
                <li><a href="https://www.thestranger.com/contribute" target="_self">Support The Stranger</a></li>
              
                <li><a href="https://www.thestranger.com/ad-info" target="_self">Ad Info & Rates</a></li>
              
                <li><a href="http://www.strangertickets.com" target="_blank">Stranger Tickets</a></li>
              
            </ul>
          </div>
        
        <div id="mobileNavAccountMenu" class="col-xs-6 nav-account">
          <ul class="nav navbar-nav nav-account-menu">
            <li class="dropdown-header" style="padding-left:0;">Account</li>
            <li><a href="https://post.thestranger.com/login">Log in</a></li>
            <li><a href="https://post.thestranger.com/login/create">Sign up</a></li>
          </ul>
        </div>
      </div>
    </div> <!-- end container -->
  </nav>
  <script>
    $('#mobileNavToggle').click(function() {
      var menuAction = $(this).hasClass('collapsed') ? 'openMenu' : 'closeMenu';
      ga('send', {
        hitType: 'event',
        eventCategory: 'MobileNav',
        eventAction: ''+menuAction+''
      });
      $(this).toggleClass('collapsed');
    });
    $('.mobile-nav .nav li a').click(function() {
      var navLabel = $(this).data('silo')+'-'+$(this).text();
      ga('send', {
        hitType: 'event',
        eventCategory: 'MobileNav',
        eventAction: 'click',
        eventLabel: ''+navLabel+''
      });
    });
  </script>
</header>

  </div>
</div>
      <div class="top-super text-center component container">
  <div id="div-gpt-ad-top-super"></div>
  <div id="div-gpt-ad-mobile-top"></div>
</div>
      <div id="siteContent" class="container">
        <div class="row" class="main">
          <div class="col-sm-12 col-md-8 primary">
  
  <div id="articleComponent-56577267" class="component">

    

     <div class="blog-header slog">
  <h1><a href="https://www.thestranger.com/slog"><img id="slogLogo" src="" class="img-responsive slog-logo"></a></h1>
</div>
    
    
    <div id="article-56577267" class="article coll_news">
      <div id="article-header-56577267" class="article-header">
        
          <div class="post-tags-and-date">
            
              <div class="label topic">
                
                  <a href="https://www.thestranger.com/archive/news">News</a>
                  
                
              </div>
            
          </div>
        
        <h1 class="headline">
          <strong>Slog AM:</strong> A Week Is Not Complete Without a Mass Shooting, Inslee Wants to Fight COVID with Nice Weather, Cops Caught Giving Cold Cash to Kyle Rittenhouse
          
        </h1>
        <h2 class="subheadline">
          
        </h2>
        <div class="byline">
          
            by <a href="https://www.thestranger.com/authors/237/charles-mudede">Charles Mudede</a>
            
              &bull;
            
          
          
            <span class="post-time">
              Apr 16, 2021 at  8:51 am
            </span>
          
        </div>
        
        
        
          
        
      </div> <!-- end .article-header -->

      <div class="article-text category-slog">
        
        

        <div class="social-tools text-right" style="margin-bottom:10px;position:relative;">
          
          <div class="fb-like"
            data-href="https://www.thestranger.com/slog/2021/04/16/56577267/slog-am-a-week-is-not-complete-without-a-mass-shooting-inslee-wants-to-fight-covid-with-nice-weather-cops-caught-giving-cold-cash-to-kyle-r"
            data-layout="button_count"
            data-action="like"
            data-show-faces="true"
            data-share="true" style="margin-right:10px;position:relative;top:-5px;"></div>
          
          <a class="twitter-share-button" href="https://twitter.com/share"
            data-url="https://www.thestranger.com/slog/2021/04/16/56577267/slog-am-a-week-is-not-complete-without-a-mass-shooting-inslee-wants-to-fight-covid-with-nice-weather-cops-caught-giving-cold-cash-to-kyle-r"
            data-text="Slog AM: A Week Is Not Complete Without a Mass Shooting, Inslee Wants to Fight COVID with Nice Weather, Cops Caught Giving Cold Cash to Kyle Rittenhouse">
          Tweet
          </a>
          <script>
          window.twttr=(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],t=window.twttr||{};if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);t._e=[];t.ready=function(f){t._e.push(f);};return t;}(document,"script","twitter-wjs"));
          </script>
          <a style="position:relative;top:-5px;" href="//www.reddit.com/submit?url=https%3A//www.thestranger.com/slog/2021/04/16/56577267/slog-am-a-week-is-not-complete-without-a-mass-shooting-inslee-wants-to-fight-covid-with-nice-weather-cops-caught-giving-cold-cash-to-kyle-r" target="_blank"><img src="//www.redditstatic.com/spreddit5.gif" alt="submit to reddit" border="0" /></a>
        </div>

        

        
        

        
        
        
        
        
          
          
          
          
          
          
            
            
            
            
              
              <div class="blogImageCenter img-responsive" style="width:600px"><img src="https://media2.fdncms.com/stranger/imager/u/large/56589538/1618587750-gettyimages-887843396.jpg" alt="This is how we be in our own Phase 3." title="This is how we be in our own Phase 3."><div class="image-caption-and-credit"><span class="imageCaption">This is how we be in our own Phase 3.</span> <span class="imageCredit">blightylad-infocus/<a href="http://gettyimages.com">gettyimages.com</a></span></div></div><br /> <br /><strong>This time: a FedEx facility in Indianapolis.</strong> This time: 8 dead people and as many wounded. The nightmare, which is believed to have lasted for about two minutes, came to an end only when the killer, armed with an <a href="https://www.cnn.com/us/live-news/indianapolis-fedex-shooting-04-16-21-intl-hnk/h_52e4d46f498d19249e0c8c288981ca21">automatic rifle</a>, joined the dead. CNN reports that "the incident marks at least the 45th mass shooting in the United States since the Atlanta-area spa shootings on March 16." That's right. Forty-five mass shootings in just two months. And please, no "going postal" jokes today. We are tired of mass shootings. We are tired of cops shooting black people. "It's like a jungle sometimes it makes me wonder how I keep from going under." <br /><blockquote class="twitter-tweet"><p lang="en" dir="ltr">Police responding to a 'mass casualty situation' at FedEx facility in Indianapolis <a href="https://t.co/IFCbUYDfN8">https://t.co/IFCbUYDfN8</a><br />— CNN Breaking News (@cnnbrk) <a href="https://twitter.com/cnnbrk/status/1382917725861912576?ref_src=twsrc%5Etfw">April 16, 2021</a></blockquote> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
              <div class="row fish-butter article-inline-native-wrapper" data-context-oid="56092109" data-ad-oid="56092103">

      <div class="fish-tag row article-inline-native-tag">
          Sponsored
      </div>

      <div class="row">
        <div class="col article-inline-native-inner-wrapper">
          

          
            <div class="col-xs-3 article-inline-native-image">
              <a href="https://post.thestranger.com/seattle/clickclick?adoid=56092103&poid=56092109&url=https%3A//lagunitas.com/taproom/seattle" class="image-link" rel="nofollow">
                <img src="https://media2.fdncms.com/stranger/imager/u/original/56092076/original-taproomseattle_marchstrangerads_sponsored_125x95_v3_jr_copy.jpg" class="img-fluid">
              </a>
            </div>
          

          
          <div class="col-xs-9">
            <div class="row article-inline-native-headline">
              <a href="https://post.thestranger.com/seattle/clickclick?adoid=56092103&poid=56092109&url=https%3A//lagunitas.com/taproom/seattle" rel="nofollow">
                LagunitasSeattle is here for ya with beer for ya!
              </a>
              
            </div>

            
              <div class="row article-inline-native-body">
                Ballard-brewed beers and tasty bites for all palates under our heated tent. C'mon down!
              </div>
            
          </div>
          
        </div>
      </div>
    </div>
                
                
                
                  
                  
                    <div class="interstitial-ad-1 ad pull-right">
                      <div id="div-gpt-ad-mobile-inline-1" class="interstitial-ad  inline-ad"></div>
                    </div>
            
              
              
          <a name="more"></a>
          <p><strong>The sweep of homeless people in Capitol Hill's Miller Park is happening this morning.</strong>  <br /><blockquote class="twitter-tweet"><p lang="en" dir="ltr"><a href="https://twitter.com/jseattle?ref_src=twsrc%5Etfw">@jseattle</a> Sweep happening at Miller Park as campers moving out <a href="https://t.co/3B9NhMCBJS">pic.twitter.com/3B9NhMCBJS</a><br />— Alex Garland (@AGarlandPhoto) <a href="https://twitter.com/AGarlandPhoto/status/1383084877952684035?ref_src=twsrc%5Etfw">April 16, 2021</a></blockquote> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script><br />As you watch the footage of the sweep, recall what Jo, the street kid in Charles Dicken's second-best novel, <em>Bleak House</em>, said to the constable when ordered to move:<br /><blockquote>"I'm always a-moving on, sar," cries the boy, wiping away his grimy tears with his arm. "I've always been a-moving and a-moving on, ever since I was born. Where can I possibly move to, sir...?"</p>
              <div class="interstitial-ad-2 ad pull-right">
                      <div id="div-gpt-ad-mobile-inline-2" class="interstitial-ad  inline-ad"></div>
                    </div>
            
              
              </blockquote> <p><strong>The driver who hit and killed a cyclist in Seward Park on Sunday, April 11</strong>, <a href="https://www.king5.com/article/news/crime/seattle-cyclist-fatal-hit-and-run-police/281-3535cdc8-e926-4c07-b750-7629e36814d6">is still unknown</a>. How is this even possible? How can you hit-and-run with a whole car in our day and age, and in a major city? The window of the suspect's car is said to have been shattered. The police think they have some of the information on the car's licence plat: "BKU 053." The wife and daughter of the victim, Mike Colmant, want the driver in the dark brought to the light of justice. </p>
              <div class="interstitial-ad-3 ad pull-right">
                      <div id="div-gpt-ad-mobile-inline-3" class="interstitial-ad  inline-ad"></div>
                    </div>
            
              
               <p><strong>I must bring this up again.</strong> But why are cars still allowed in Pike Place Market? What this madness shows is the super-strength of the hold that car culture has on even our urban imagination.   <br /><blockquote class="twitter-tweet"><p lang="en" dir="ltr">This is seriously one of the more bizarre things in Seattle. <a href="https://t.co/mWryUTjiqS">https://t.co/mWryUTjiqS</a><br />— Jeremiah Oshan (@JeremiahOshan) <a href="https://twitter.com/JeremiahOshan/status/1382831525595541506?ref_src=twsrc%5Etfw">April 15, 2021</a></blockquote> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
              <div class="interstitial-ad-4 ad pull-right">
                      <div id="div-gpt-ad-mobile-inline-4" class="interstitial-ad  inline-ad"></div>
                    </div>
            
              
               <p><strong>Because we are clearly heading into the fourth wave of the pandemic,</strong> Governor Inslee, who prematurely reopened the economy in March, is now turning to "nice weather" for help. Go outside, bask in the sun, enjoy the spring-warm air, that sort of thing. The name Inslee has given this new approach in the year-old fight against the pandemic is "<a href="https://komonews.com/news/local/amid-concern-of-4th-wave-inslee-tells-washingtonians-to-take-it-outside">Take It Outside</a>."  </p>
              <div class="interstitial-ad-5 ad pull-right">
                      <div id="div-gpt-ad-mobile-inline-5" class="interstitial-ad  inline-ad"></div>
                    </div>
            
              
               <p><strong>Today, three counties are officially back to Phase 2:</strong> <a href="https://www.kiro7.com/news/local/3-counties-go-back-phase-2-states-reopening-plan/7YKIXADF2RGRXD44E56FZJISLQ/">The counties are</a> Pierce, Cowlitz and Whitman. They "failed to meet the Phase 3 metrics for reopening."  </p>
              <div class="interstitial-ad-6 ad pull-right">
                      <div id="div-gpt-ad-mobile-inline-6" class="interstitial-ad  inline-ad"></div>
                    </div>
            
              
               <p><strong>Red states are generally behind blue states in vaccination rates.</strong> This, of course, is no surprise. There is close to nothing in the US that's not informed by this <a href="https://www.nytimes.com/interactive/2020/us/covid-19-vaccine-doses.html?campaign_id=9&emc=edit_nn_20210416&instance_id=29310&nl=the-morning®i_id=52359157&segment_id=55696&te=1&user_id=61840d9087fa8aa57e0d1aeef00824fc">particular political division</a>. </p>
              
            
              
               <p><strong>American Jesus apparently</strong> loves cops accused of shooting black people and Kyle Rittenhouse, the young man accused of killing two BLM protesters on August 25 of last year. We now know all about this white supremacist Jesus because the information on a Christian crowdfunding site<a href="https://www.theguardian.com/us-news/2021/apr/16/us-police-officers-public-officials-crowdfunding-website-data-breach?CMP=Share_iOSApp_Other">was compromised</a> and named names. <em><a href="https://www.theguardian.com/us-news/2021/apr/16/us-police-officers-public-officials-crowdfunding-website-data-breach?CMP=Share_iOSApp_Other">The Guardian</a></em> found that many of the donors on this site are, of course, police officers.  </p>
              
            
              
               <p><strong>Speaking of this police.</strong><br /><blockquote class="twitter-tweet"><p lang="en" dir="ltr">The US spends more on policing than all but two countries spend on their militaries (and one of those countries is the US)<a href="https://t.co/vuHq5Bt0tU">https://t.co/vuHq5Bt0tU</a> <a href="https://t.co/zfLp7ttHgN">pic.twitter.com/zfLp7ttHgN</a><br />— Stephen Semler (@stephensemler) <a href="https://twitter.com/stephensemler/status/1382106811013197825?ref_src=twsrc%5Etfw">April 13, 2021</a></blockquote> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
              
            
              
               <p><strong>What can go up again this weekend?</strong> <a href="https://www.seattletimes.com/seattle-news/bird-feeders-can-go-up-again-but-remain-vigilant-washington-state-officials-say/">Bird feeders</a>. Bird lovers were told to take the damn things down and also to drain bird baths in January because of an "outbreak in pine siskins." Washington Department of Fish and Wildlife (WDFW) made this recommendation because feeders and baths bring birds together, and this avian togetherness helped "spread the disease through droppings and saliva." Three-and-a-half months later, WDFW has seen a sharp fall in the number of sick and dead birds. Avain social distancing seems to have worked. You can now put feeders back in trees and fill those baths with water.  </p>
              <div class="fish-butter article-inline-native" data-context-oid="41865158" data-ad-oid="41865157">
      <h3 class="article-inline-text">
        <a href="https://post.thestranger.com/seattle/clickclick?adoid=41865157&poid=41865158&url=https%3A//www.thestranger.com/contribute%3Futm_source%3Dpublication%26utm_medium%3Darticle_inline%26utm_campaign%3Dinline_news" target="_blank" rel="nofollow">
          Support <em>The Stranger</em>
        </a>
      </h3>
      <div>
        <a href="https://post.thestranger.com/seattle/clickclick?adoid=41865157&poid=41865158&url=https%3A//www.thestranger.com/contribute%3Futm_source%3Dpublication%26utm_medium%3Darticle_inline%26utm_campaign%3Dinline_news" target="_blank" rel="nofollow" style="font-size:1rem;font-weight:normal;">
          More than ever, we depend on your support to help fund our coverage. Support local, independent media with a  one-time or recurring contribution. Thank you!
        </a>
      </div>
    </div>
            
              
               <p><strong>And now for the greatest poem in English about birds.</strong> The poem is by <a href="https://www.bartleby.com/113/3041.html">Emily Dickinson</a>.<br /><blockquote>SPLIT the lark and you’ll find the music,	<br />  Bulb after bulb, in silver rolled,	<br />Scantily dealt to the summer morning,	<br />  Saved for your ear when lutes be old.	<br />  <br />Loose the flood, you shall find it patent,	        <br />  Gush after gush, reserved for you;	<br />Scarlet experiment! sceptic Thomas,	<br />  Now, do you doubt that your bird was true?</blockquote>	 </p>
              
            
              
               <p><strong>77-year-old Seattle man falls from tree and dies.</strong> This happened on Thursday, shortly after noon. He was on a ladder trimming the tree. The sun was out and in the leaves. The lethal fall <a href="https://komonews.com/news/local/77-year-old-man-dies-after-falling-from-tree">was 15 feet</a>.</p>
              
            
              
               <p><strong>This is how we will end the last AM of the week:</strong><br /><blockquote class="twitter-tweet"><p lang="en" dir="ltr">A group of caterpillars, moving in a formation known as a rolling swarm. This rolling swarm of caterpillars moves faster than any single caterpillar. 🐛 <a href="https://t.co/sn3J3CDYmE">pic.twitter.com/sn3J3CDYmE</a><br />— Theo Shantonas (@TheoShantonas) <a href="https://twitter.com/TheoShantonas/status/1380536139954655237?ref_src=twsrc%5Etfw">April 9, 2021</a></blockquote> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
              
            
           

        

        
        

        

        

        
          
        

      </div> <!-- end .article-text -->

      
      
      
        
          <div id="mc_embed_signup" style="padding: 30px 10px; background:#fff;font:15px Georgia,serif;width:100%; font-weight: normal; text-align: center;">
<form action="https://thestranger.us4.list-manage.com/subscribe?u=739a0d2f2ff0031156e7b3d55&amp;id=f02129603b" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" target="_blank" novalidate="">
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL" style="font-weight: normal; padding: 5px;">To get this delivered to your inbox, subscribe to <i>The Stranger</i>'s Slog AM newsletter.</label>
<div class="input-group" style=" width=100%; max-width:400px; margin: 0 auto;">
<input type="hidden" name="group[19329][4]" value="checked">
<input class="form-control" type="email" value="" name="EMAIL" id="mce-EMAIL" placeholder="email address" required="" style="border-radius: 4px;border-bottom-right-radius: 0;border-top-right-radius: 0;">
<div style="position: absolute; left: -5000px;" aria-hidden="true">
<input type="text" name="b_739a0d2f2ff0031156e7b3d55_67f93c78f9" tabindex="-1" value=""></div>
<span class="input-group-btn"><button class="btn btn-default" style="font-weight: normal;" type="submit" value="Subscribe" name="subscribe">Subscribe</span></div></div></form></div>
        
      

      
      
        <script id="fdncms-carousel-top-stories-video" src="https://www.hub.fdncms.com/gyrobase/Responsive/Components/Content/TopStoriesVideo?cb=72fc8652&key=bc2394029788a572f638c2af9ed8678a&req=js" async></script>
      

    </div> <!-- end .article -->

    <!-- article-contribution-footer -->
    
    
      <div class="article-contribution-footer">
        <em>The Stranger</em> depends on your continuing support to provide articles like this one. In return, we pledge our ongoing commitment to truthful, progressive journalism and serving our community. So if you’re able, please consider a small recurring contribution. Thank you—you are appreciated!
        <div style="margin-top:1rem;"><a href="/contribute?utm_source=publication&utm_medium=article_footer&utm_campaign=footer_ask" class="btn btn-danger btn-large">CONTRIBUTE NOW</a></div>
      </div>
    
    <!-- article-contribution-footer -->

    

    <div class="row social-tools" style="margin-top:1.5em; clear:both;">
      <div class="col-xs-12 col-sm-5 text-center lg-social-btn">
        <a href="http://www.facebook.com/sharer.php?u=https%3A//www.thestranger.com/slog/2021/04/16/56577267/slog-am-a-week-is-not-complete-without-a-mass-shooting-inslee-wants-to-fight-covid-with-nice-weather-cops-caught-giving-cold-cash-to-kyle-r&amp;t=Slog+AM%3A+A+Week+Is+Not+Complete+Without+a+Mass+Shooting%2C+Inslee+Wants+to+Fight+COVID+with+Nice+Weather%2C+Cops+Caught+Giving+Cold+Cash+to+Kyle+Rittenhouse" target="_blank" onclick="window.open(this.href, '_blank', 'toolbar=no, scrollbars=auto, resizable=yes, top=250, left=250, width=500, height=500'); return false;"><img class="img-responsive" src="/images/social/share-on-facebook.png" alt="Share on Facebook" style=""></a>
      </div>
      <div class="col-xs-12 col-sm-5 text-center lg-social-btn">
        <a href="http://twitter.com/intent/tweet?&amp;url=https%3A//www.thestranger.com/slog/2021/04/16/56577267/slog-am-a-week-is-not-complete-without-a-mass-shooting-inslee-wants-to-fight-covid-with-nice-weather-cops-caught-giving-cold-cash-to-kyle-r&amp;text=Slog+AM%3A+A+Week+Is+Not+Complete+Without+a+Mass+Shooting%2C+Inslee+Wants+to+Fight+COVID+with+Nice+Weather%2C+Cops+Caught+Giving+Cold+Cash+to+Kyle+Rittenhouse&amp;related=strangerslog" target="_blank" onclick="window.open(this.href, '_blank', 'toolbar=no, scrollbars=auto, resizable=yes, top=250, left=250, width=500, height=500'); return false;"><img class="img-responsive" src="/images/social/share-on-twitter.png" alt="Share on Twitter" style=""></a>
      </div>
      
        <div class="col-xs-12 col-sm-2 text-center" style="padding-bottom:0.2em;">
          <h3 style="margin-top:5px;">
            
              <a href="/slog/2021/04/16/56577267/slog-am-a-week-is-not-complete-without-a-mass-shooting-inslee-wants-to-fight-covid-with-nice-weather-cops-caught-giving-cold-cash-to-kyle-r/comments" rel="nofollow"><i class="fa fa-comment"></i> <span class="comment-count">1</span></a>
            
          </h3>
        </div>
      
    </div>

    
    
      <div class="article-bio-wrapper">
        
          
          
            <div class="article-author-bio">

              <div class="row clearfix visible-xs">
      <div class="col-xs-12">
        
          <div class="author-bio-image pull-right">
            <img src="https://media2.fdncms.com/stranger/imager/u/large/37801983/charles_web.jpeg" class="img-responsive">
          </div>
        
        <h4 class="author-bio-name"><b>Charles Mudede</b></h4>
        
          <p>Charles Tonderai Mudede, The Stranger’s senior staff writer, is a Zimbabwean-born cultural critic, urbanist, filmmaker, college lecturer, and writer.  Mudede collaborated with the director Robinson Devor on three films, two of which, Police Beat and Zoo, premiered at Sundance, and one of which, Zoo, screened at Cannes. He has also written for the New York Times, Cinema Scope, Tank Magazine, e-flux, LA Weekly, and C Theory.</p>
        
        <div class="author-social-links pull-left">
          
            <a href="https://www.twitter.com/mudede" class="author-link btn btn-default"><i class="fa fa-twitter" title="Twitter"></i> Follow</a>
          
          
            <a href="mailto:charles@thestranger.com" class="author-link btn btn-default"><i class="fa fa-envelope" title="Email"></i> Email</a>
          
          
            <a href="https://www.thestranger.com/authors/237/charles-mudede" class="author-link btn btn-default">More articles</a>
          
          
        </div>
      </div>
    </div>

    
    <div class="row clearfix hidden-xs">
      
        <div class="col-sm-3">
          <div class="author-bio-image">
            <img src="https://media2.fdncms.com/stranger/imager/u/large/37801983/charles_web.jpeg" class="img-responsive">
          </div>
        </div>
      
      
      <div class="col-sm-9">
        <h2 class="author-bio-name">Charles Mudede</h2>
        
          <p>Charles Tonderai Mudede, The Stranger’s senior staff writer, is a Zimbabwean-born cultural critic, urbanist, filmmaker, college lecturer, and writer.  Mudede collaborated with the director Robinson Devor on three films, two of which, Police Beat and Zoo, premiered at Sundance, and one of which, Zoo, screened at Cannes. He has also written for the New York Times, Cinema Scope, Tank Magazine, e-flux, LA Weekly, and C Theory.</p>
        
        <div class="author-social-links">
          
            <a href="https://www.twitter.com/mudede" class="author-link btn btn-default"><i class="fa fa-twitter" title="Twitter"></i> Follow</a>
          
          
            <a href="mailto:charles@thestranger.com" class="author-link btn btn-default"><i class="fa fa-envelope" title="Email"></i> Email</a>
          
          
            <a href="https://www.thestranger.com/authors/237/charles-mudede" class="author-link btn btn-default">More articles</a>
          
          
        </div>
      </div>
    </div>
            </div>
          
        
      </div>
    

    
      

      
    

    <div class="component related-content" style="padding:1em 0; border-bottom:1px solid #ddd; margin-bottom:1em;">
        <h2 style="margin:0 0 0.5em; padding-top: 25px; border-top: 1px solid #ddd">You might also be interested in these:</h2>
        
        
        <div class="related-content-row" style="padding:0.5em 0;">
        
          <h3 class="headline">
            <a href="https://www.thestranger.com/slog/2021/04/15/56575645/slog-pm-pence-gets-a-pacemaker-video-shows-chicago-cop-shooting-13-year-old-with-hands-up-wa-senate-votes-to-resume-drug-war" rel="nofollow"><strong>Slog PM:</strong> Pence Gets a Pacemaker, Video Shows Chicago Cop Shooting 13-Year-Old with Hands Up, WA Senate Votes to Resume Drug War</a>
          </h3>
          
          
            <div class="byline">
              by <a href="https://www.thestranger.com/authors/19407358/rich-smith">Rich Smith</a>
            </div>
          
        
      </div>
        
      
        
        <div class="related-content-row" style="padding:0.5em 0;">
        
          <h3 class="headline">
            <a href="https://www.thestranger.com/slog/2021/04/13/56512634/take-the-strangers-2021-reader-survey" rel="nofollow">Take <em>The Stranger</em>'s 2021 Reader Survey!</a>
          </h3>
          
            <h4 class="subheadline">
              You've changed. We've changed. Let's talk about it.
            </h4>
          
          
            <div class="byline">
              by <a href="https://www.thestranger.com/authors/707628/the-stranger">The Stranger</a>
            </div>
          
        
      </div>
        
      
        
        <div class="related-content-row" style="padding:0.5em 0;">
        
          <h3 class="headline">
            <a href="https://www.thestranger.com/slog/2021/04/15/56574329/whats-god-got-to-do-with-michio-kakus-new-book-the-god-equation" rel="nofollow">What's God Got to Do With Michio Kaku's New Book, <em>The God Equation</em>?</a>
          </h3>
          
          
            <div class="byline">
              by <a href="https://www.thestranger.com/authors/237/charles-mudede">Charles Mudede</a>
            </div>
          
        
      </div>
        
      
          </div>

    <br>
    <div id="div-gpt-ad-mobile-bottom" class="interstitial-ad"></div>
    <div id="div-gpt-ad-bottom" class="interstitial-ad"></div>
    

  </div> <!-- end component -->
</div>
<div class="col-sm-12 col-md-4 secondary">
  <!-- stranger content sidebar ads -->
<div class="article-sidebar sidebar-ads text-right">
  
    <div class="sidebar-ad-1">
      <div id="div-gpt-ad-sidebar-1" class="sidebar-ad"></div>
    </div>
  
    <div class="sidebar-ad-2">
      <div id="div-gpt-ad-sidebar-2" class="sidebar-ad"></div>
    </div>
  
    <div class="sidebar-ad-3">
      <div id="div-gpt-ad-sidebar-3" class="sidebar-ad"></div>
    </div>
  
    <div class="sidebar-ad-4">
      <div id="div-gpt-ad-sidebar-4" class="sidebar-ad"></div>
    </div>
  
    <div class="sidebar-ad-5">
      <div id="div-gpt-ad-sidebar-5" class="sidebar-ad"></div>
    </div>
  
    <div class="sidebar-ad-6">
      <div id="div-gpt-ad-sidebar-6" class="sidebar-ad"></div>
    </div>
  
</div>
</div>
        </div>
        <div class="row">
          <div class="col-sm-12">
            <div class="bottom-super text-center">
  <div id="div-gpt-ad-bottom-super" class="gpt-dfp"></div>
</div>
          </div>
        </div>
      </div><!-- /#siteContent -->
      <div id="site-footer">
        <div class="hidden-xs hidden-sm">
  <div id="footer-features">
    <div class="container">
      <div class="footer-row">
        
            
          
          
          <div class="col-md-2 text-center" style="width:25%;">
            <i class="fa fa-envelope"></i>
            <h4><a href="/newsletters">Newsletters</a></h4>
            <p>Sign up for the latest news and to win free tickets to events</p>
          </div>
        
          
          <div class="col-md-2 text-center" style="width:25%;">
            <i class="fa fa-ticket"></i>
            <h4><a href="http://www.strangertickets.com">Stranger Tickets</a></h4>
            <p>Buy tickets to events around Seattle</p>
          </div>
        
          
          <div class="col-md-2 text-center" style="width:25%;">
            <i class="fa fa-calendar"></i>
            <h4><a href="https://everout.com/stranger-seattle/">EverOut<br>Things To Do</a></h4>
            <p>Comprehensive calendar of Seattle events</p>
          </div>
        
          
          <div class="col-md-2 text-center" style="width:25%;">
            <i class="fa fa-mobile"></i>
            <h4><a href="/thingstodoapp">EverOut App</a></h4>
            <p>The easiest way to find Seattle's best events</p>
          </div>
        
      </div>
    </div>
  </div>
</div><!-- footer (hidden-xs hidden-sm) -->

      
        







<div class="hidden-xs hidden-sm">
  <div id="footer-features-2">
    <div class="container">
      <div class="footer-row">
        <div class="col col-md-4 text-center">
          <h4>Publication Info</h4>
            <ul class="list-unstyled">
              <li><a href="https://www.thestranger.com/masthead">Masthead</a></li>
              <li><a href="https://www.thestranger.com/ad-info">Ad Info &amp; Rates</a></li>
              
              <li><a href="https://www.thestranger.com/jobs">Jobs at The Stranger</a></li>
              <li><a href="https://www.thestranger.com/contact-information">Contact</a></li>
              <li><a href="https://everout.com/">EverOut</a></li>
              <li><br></li>
              <li><a href="https://www.thestranger.com/contribute?utm_source=publication&utm_medium=footer_nav&utm_campaign=footer_nav">Contribute</a></li>
            </ul>
        </div>
        <div class="col col-md-4 text-center" style="border-right: solid 1px white; border-left: solid 1px white;">
          <h4>Check it out</h4>
          
            <div class="footer-promo" id="" style="margin-left:0">
              <a href="https://www.savagelovecast.com">
                
                  <img src="https://media1.fdncms.com/stranger/imager/u/original/39759989/savagelovecast.jpg" alt="Savage Lovecast">
                
              </a>
            </div>
          
            <div class="footer-promo" id="" style="margin-left:0">
              <a href="http://www.cocktailcompass.com">
                
                  <img src="https://media2.fdncms.com/stranger/imager/u/original/39759990/cocktailcompass-188x80.png" alt="Cocktail Compass">
                
              </a>
            </div>
          
            <div class="footer-promo" id="" style="margin-left:0">
              <a href="/promotions">
                
                  <img src="https://media1.fdncms.com/stranger/imager/u/original/39759991/checkitout_button-contests.png" alt="The Stranger Promotions">
                
              </a>
            </div>
          
        </div>
        <div class="col col-md-4 text-center">
          <h4>Follow Us</h4>
          
              <ul id="footer-social-links" class="list-unstyled text-left">
            
            
            <li><a href="/syndication" target="_blank"><i class="fa fa-rss"></i> RSS</a></li>
            
          
            
            <li><a href="http://www.facebook.com/strangerseattle" target="_blank"><i class="fa fa-facebook"></i> Facebook</a></li>
            
          
            
            <li><a href="/twitter" target="_blank"><i class="fa fa-twitter"></i> Twitter</a></li>
            
          
            
            <li><a href="http://instagram.com/thestrangerseattle" target="_blank"><i class="fa fa-instagram"></i> Instagram</a></li>
            
          
              </ul>
            
        </div>
      </div>
    </div>
  </div>
</div><!-- footer (hidden-xs hidden-sm) -->

      
        

<div class="hidden-xs hidden-sm">
  <div id="footer-copyright">
    <div class="container">
      <div class="footer-row">
        <div class="col-md-6">
          <div class="footer-brand">
            
              <a href="https://www.thestranger.com/"><img src="https://www.thestranger.com/assets/sites/stranger/images/site-logo.png?2018-09-13-121404" alt="The Stranger"></a>
            
          </div>
          
          <p class="footer-copyright">
            
              All contents &copy; Index Newspapers LLC<br>
800 Maynard Ave S, Suite 200, Seattle, WA 98134
            
          </p>
        </div>
        <div class="col-md-6">
          <p class="footer-links text-right">
            <a href="https://www.thestranger.com/contact-information">Contact</a>
            <span class="lighter separater">|</span>
            <a href="https://www.thestranger.com/privacy-policy">Privacy Policy</a>
            <span class="lighter separater">|</span>
            <a href="https://www.thestranger.com/terms-of-use">Terms of Use</a>
            <span class="lighter separater">|</span>
            <a href="https://www.thestranger.com/takedown-policy">Takedown Policy</a>
          </p>
        </div>
      </div>
    </div>
  </div>
</div> <!-- footer (hidden-xs hidden-sm) -->

      
        

<div id="footer-mobile"  class="hidden-md hidden-lg">
  <div class="container">
    <div class="footer-row">
      <div class="col-sm-12 text-center">
        <div id="footer-mobile-social-links">
          
            <a href="/syndication" target="_blank"><i class="fa fa-rss"></i></a>
          
            <a href="http://www.facebook.com/strangerseattle" target="_blank"><i class="fa fa-facebook"></i></a>
          
            <a href="/twitter" target="_blank"><i class="fa fa-twitter"></i></a>
          
            <a href="http://instagram.com/thestrangerseattle" target="_blank"><i class="fa fa-instagram"></i></a>
          
        </div>
        <div class="footer-brand">
          
            <a href="https://www.thestranger.com/"><img src="https://www.thestranger.com/assets/sites/stranger/images/site-logo.png?2018-09-13-121404" alt="The Stranger"></a>
          
        </div>
        
        <p class="footer-copyright">
          
            All contents &copy; Index Newspapers LLC<br>
800 Maynard Ave S, Suite 200, Seattle, WA 98134
          
        </p>
        <p class="footer-links">
          <small>
            <a href="https://www.thestranger.com/contact-information">Contact</a> |
            <a href="https://www.thestranger.com/privacy-policy">Privacy Policy</a> |
            <a href="https://www.thestranger.com/terms-of-use">Terms of Use</a> |
            <a href="https://www.thestranger.com/takedown-policy">Takedown Policy</a>
          </small>
        </p>
      </div>
    </div>
  </div>
</div> <!-- /footer-mobile -->
      </div> <!-- /#site-footer -->
    </div> <!-- /.wrapper -->
    <!-- content background ad -->
<div id="div-gpt-ad-background"></div>

      
        


 


















<script>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</script>








<div id="fb-root"></div>

  <script>
    window.fbAsyncInit = function() {
      FB.init({
        appId      : '43933993878',
        xfbml      : true,
        version    : 'v2.6'
      });
    };
  </script>

<script>(function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
    fjs.parentNode.insertBefore(js, fjs);
  }(document, 'script', 'facebook-jssdk'));</script>


<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-332219-1', 'auto');
  ga('require', 'linkid', 'linkid.js');
  ga('set', 'anonymizeIp', true);

  var user = JSON.parse($.cookie('user'));
  var dimension1Value = "";
  var dimension2Value = "";
  var dimension3Value = "";
  var dimension4Value = "";
  var dimension5Value = "slog";
  var dimension6Value = "";
  var dimension7Value = "Charles Mudede";
  var dimension8Value = "stranger-editorial-news";
  var dimension9Value = "";
  var dimension10Value = user ? user.type : "Guest";
  var dimension11Value = $.map($('.fish-butter'), function(val, i) {
      return $(val).data('adOid')
  }).join(",");
  ga('set', 'dimension1', dimension1Value); // calendar section
  ga('set', 'dimension2', dimension2Value); // location category
  ga('set', 'dimension3', dimension3Value); // location neighborhood
  ga('set', 'dimension4', dimension4Value); // location cuisine
  ga('set', 'dimension5', dimension5Value); // section
  ga('set', 'dimension6', dimension6Value); // category
  ga('set', 'dimension7', dimension7Value); // author
  ga('set', 'dimension8', dimension8Value); // targeting section
  ga('set', 'dimension9', dimension9Value); // location category
  ga('set', 'dimension10', dimension10Value); // user type
  ga('set', 'dimension11', dimension11Value); // native ads
  ga('send', 'pageview');
</script>




<script>
  // track location categories
  var locationCategories = [];
  function trackLocationCategories(i) {
    ga('send', 'event', 'Custom Dimension Event', 'Location Page Categories', 'Location Page Categories', {nonInteraction: true, 'dimension9': locationCategories[i], 'metric1': 1});
  }
  for (var i = 0; i < locationCategories.length; i++) {
    setTimeout(trackLocationCategories(i), 3000);
  }
</script>

<script>
  $(function() {
    $("audio").bind("play", function(e){
      var source = ($(this).attr('src')) ? $(this).attr('src') : $(this).find('source').attr('src');
      ga('send', {
        hitType: 'event',
        eventCategory: 'Audio',
        eventAction: 'play',
        eventLabel: source
      });
    });
  });
</script>



<script type='text/javascript'>
    var _sf_async_config = _sf_async_config || {};
    /** CONFIGURATION START **/
    _sf_async_config.sections = 'slog';
    _sf_async_config.authors = 'Charles Mudede';
    /** CONFIGURATION END **/
    (function(){
      function loadChartbeat() {
        window._sf_endpt=(new Date()).getTime();
        var e = document.createElement('script');
        e.setAttribute('language', 'javascript');
        e.setAttribute('type', 'text/javascript');
        e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
        document.body.appendChild(e);
      }
      var oldonload = window.onload;
      window.onload = (typeof window.onload != 'function') ?
        loadChartbeat : function() { oldonload(); loadChartbeat(); };
    })();
</script>


<!-- Start Quantcast tag -->

<script type="text/javascript">
  _qcJSHost = (("https:" == document.location.protocol) ? "https://secure." : "http://edge.");
  _qoptions={
    qacct:"p-aaXEgDiyQODdU"
  };
  document.write(unescape("%3Cscript src='" + _qcJSHost + "quantserve.com/quant.js' type='text/javascript'%3E%3C/script%3E"));
</script>
<noscript>
  <img src="https://secure.quantserve.com/pixel/p-aaXEgDiyQODdU.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast">
</noscript>
<!-- End Quantcast tag -->

<!-- Start Quantcast tag -->
<script type="text/javascript">
_qcJSHost = (("https:" == document.location.protocol) ? "https://secure." : "http://edge.");
 _qoptions={
   qacct:"p-a4LDpi_DEopn-"
 };
</script>
<noscript>
  <img src="https://secure.quantserve.com/pixel/p-a4LDpi_DEopn-.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast">
</noscript>
<!-- End Quantcast tag -->
  </body>
</html>
   
 

