 <!DOCTYPE html>
<html lang="en">
  <head>
    <!-- Google Tag Manager -->
  <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','dataLayer','GTM-5GMVQ6J');</script>
  <!-- End Google Tag Manager -->






<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=yes">
<meta name="google-site-verification" content="Yn7U5qsaj-oKD3y_qp7IbGawlVoNxW1Pzu87ZOHqabU">
<meta name="view-id" content="article">
<!-- start Omniconvert.com code -->
<link rel="dns-prefetch" href="//app.omniconvert.com" /> <script type="text/javascript">window._mktz=window._mktz||[];</script> <script src="//cdn.omniconvert.com/js/sd0d155.js"></script>
<!-- end Omniconvert.com code -->



<title>Slog PM: Monkeypox Suspected in King County, Bruce Harrell Still Waiting for His Thank You, and Farewell to the Last Public Payphone - Slog - The Stranger</title>


  

  

  

  

  <meta name="twitter:card" content="summary_large_image" />
  <meta name="twitter:site" content="@thestranger" />
  <meta name="twitter:image" content="https://media1.fdncms.com/stranger/imager/u/original/73941913/1653349959-gettyimages-1398839771.jpg" />
  <meta property="og:title" content="Slog PM: Monkeypox Suspected in King County, Bruce Harrell Still Waiting for His Thank You, and Farewell to the Last Public Payphone" />
  <meta property="og:description" content="Monkeypox is (probably) here. Public Health Seattle &amp; King County is investigating a likely case of monkeypox. The patient is an unidentified man who recently traveled abroad, and health officials aren&rsquo;t aware of any other cases. If you&rsquo;re experiencing symptoms &mdash; basically feeling like you have the flu, accompanied by a new rash, bumps, or sores &mdash; you&rsquo;re asked to contact a health care provider as soon as possible. A really bad Supreme Court ruling...." />
  <meta name="description" content="Monkeypox is (probably) here. Public Health Seattle &amp; King County is investigating a likely case of monkeypox. The patient is an unidentified man who recently traveled abroad, and health officials aren&rsquo;t aware of any other cases. If you&rsquo;re experiencing symptoms &mdash; basically feeling like you have the flu, accompanied by a new rash, bumps, or sores &mdash; you&rsquo;re asked to contact a health care provider as soon as possible. A really bad Supreme Court ruling...." />
  <meta property="og:site_name" content="The Stranger" />
  <meta property="og:type" content="article" />
  <meta property="og:image" content="https://media1.fdncms.com/stranger/imager/u/original/73941913/1653349959-gettyimages-1398839771.jpg" />
  <meta property="article:publisher" content="https://www.facebook.com/strangerseattle" />
  
    
  
  <meta name="apple-mobile-web-app-title" content="Slog PM: Monkeypox Suspected in King County, Bruce Harrell Still Waiting for His Thank You, and Farewell to the Last Public Payphone - Slog - The Stranger" />
  
    <link rel="apple-touch-icon-precomposed"  href="/images/mobile/touchicons/default/touch-icon-60.png" />
  
    <link rel="apple-touch-icon-precomposed" sizes="76x76" href="/images/mobile/touchicons/default/touch-icon-76.png" />
  
    <link rel="apple-touch-icon-precomposed" sizes="120x120" href="/images/mobile/touchicons/default/touch-icon-120.png" />
  
    <link rel="apple-touch-icon-precomposed" sizes="152x152" href="/images/mobile/touchicons/default/touch-icon-152.png" />
  

  <link rel="mask-icon" href="https://www.thestranger.com/assets/sites/stranger/images/site-badge.svg" color="#000000">
  <link rel="icon" type="image/x-icon" href="https://www.thestranger.com/assets/sites/stranger/images/favicon.png">

  
    <meta property="fb:app_id" content="43933993878"/>
  
  
    <meta property="fb:admins" content="741428065"/>
  
  
    <meta property="fb:pages" content="56439755991" />
  

  

  
  
  
    <link rel="canonical" href="https://www.thestranger.com/slog/2022/05/23/73941800/slog-pm-monkeypox-suspected-in-king-county-bruce-harrell-still-waiting-for-his-thank-you-and-farewell-to-the-last-public-payphone" />
    <meta property="og:url" content="https://www.thestranger.com/slog/2022/05/23/73941800/slog-pm-monkeypox-suspected-in-king-county-bruce-harrell-still-waiting-for-his-thank-you-and-farewell-to-the-last-public-payphone" />
  
  
   <link rel="alternate" type="application/rss+xml" title="The Stranger: Whole Site" href="/seattle/Rss.xml"/>

  <link rel="alternate" type="application/rss+xml" title="The Stranger: Slog Section" href="/seattle/Rss.xml?section=529161"/>


  
    <link rel="alternate" type="application/rss+xml" title="The Stranger: Articles by Matt Baume" href="/seattle/Rss.xml?author=21647307"/>
 

<!-- revved -->

<link href="https://www.thestranger.com/assets/build/css/styles.7245f734.css" rel="stylesheet">

<link rel="stylesheet" href="https://use.fontawesome.com/baf88c5825.css">


<!-- jQuery (necessary for Bootstrap's JavaScript plugins) -->
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.0/jquery.min.js"></script>
<!-- Include all compiled plugins (below), or include individual files as needed -->
<script src="https://stackpath.bootstrapcdn.com/bootstrap/3.4.1/js/bootstrap.min.js" integrity="sha384-aJ21OjlMXNL5UyIl/XNwTMqvzeRMZH2w8c5cRVpzpU8Y5bApTppSuUkhZXN0VxHd" crossorigin="anonymous"></script>


<script src="/seattle/Library/Environment/JavascriptEnvironmentScript"></script>


  <script src="https://www.thestranger.com/assets/build/js/app.e765bde4.js"></script>


<!-- HTML5 Shim and Respond.js IE8 support of HTML5 elements and media queries -->
<!-- WARNING: Respond.js doesn't work if you view the page via file:// -->
<!--[if lt IE 9]>
  <script src="https://oss.maxcdn.com/libs/html5shiv/3.7.0/html5shiv.js"></script>
  <script src="https://oss.maxcdn.com/libs/respond.js/1.4.2/respond.min.js"></script>
<![endif]-->



  <!-- Hotjar Tracking Code for thestranger.com -->
  
  






<!--   typekit -->
<script type="text/javascript" src="//use.typekit.net/wjg1xbh.js"></script>
<script type="text/javascript">try{Typekit.load();}catch(e){}</script>







<script type='text/javascript'>
function getWidth() {
  if (self.innerHeight) {
    return self.innerWidth;
  }
  if (document.documentElement && document.documentElement.clientHeight) {
    return document.documentElement.clientWidth;
  }
  if (document.body) {
    return document.body.clientWidth;
  }
}
var documentWidth = getWidth();

var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
  var gads = document.createElement('script');
  gads.async = true;
  gads.type = 'text/javascript';
  var useSSL = 'https:' == document.location.protocol;
  gads.src = (useSSL ? 'https:' : 'http:') +
  '//www.googletagservices.com/tag/js/gpt.js';
  var node = document.getElementsByTagName('script')[0];
  node.parentNode.insertBefore(gads, node);
})();
</script>

<script type="text/javascript">
  // in gyrobase
  $(document).ready(function() {
    if($('.fish-butter') && !navigator.userAgent.match(/bot|googlebot|crawler|spider|robot|crawling|PhantomJS|BingPreview/ig)){
      $('.fish-butter').each(function() {
        var xhr = new XMLHttpRequest();
        var data = {
          'oid': $(this).data('adOid'),
          'context': $(this).data('contextOid')
        }
        xhr.open('POST', '/_private/tracking/record-hit');
        xhr.setRequestHeader('Content-Type', 'application/json');
        xhr.setRequestHeader('X-CSRF-Token', getCookie('csrfToken'));
        xhr.onload = function() {
          var response = JSON.parse(xhr.responseText);
          if (xhr.status === 200) {
          } else {
          }
        };
        xhr.send(JSON.stringify(data));
      });
    }
  });
</script>


<script type="text/javascript">
     var _sf_async_config = _sf_async_config || {};
     /** CONFIGURATION START **/
     _sf_async_config.uid = 65679
     _sf_async_config.domain = "thestranger.com";
     _sf_async_config.useCanonical = true;
     /** CONFIGURATION END **/
     var _sf_startpt = (new Date()).getTime();
</script>
<script src="//static.chartbeat.com/js/chartbeat_mab.js"></script>
  </head>
  <body class="article  article-section-slog">
    <div class="wrapper">
      <div class="network-bar navbar hidden-xs navbar-expand-md navbar-dark bg-dark">
    <div class="container">
      <ul class="nav navbar-nav mr-auto">
        
          
            <li class="nav-item"><a class="nav-link" href="https://thestranger.com" target="self">The Stranger</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          
            <li class="nav-item"><a class="nav-link" href="https://portlandmercury.com" target="self">Portland Mercury</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          
            <li class="nav-item"><a class="nav-link" href="https://everout.com/stranger-seattle/" target="self">EverOut</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          
            <li class="nav-item"><a class="nav-link" href="https://savage.love/" target="self">Savage Love</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          
            <li class="nav-item"><a class="nav-link" href="https://humpfilmfest.com" target="self">Hump</a></li>
          
          
        
      </ul>
    </div>
  </div>


<div id="site-header" class="navbar navbar-default hidden-xs" role="navigation">
  <div id="top-nav">
    <div class="container">
      <div class="navbar-header">
        <a class="navbar-brand" href="https://www.thestranger.com/"><img src="https://www.thestranger.com/assets/sites/stranger/images/site-logo.png?2018-09-13-121404" alt="The Stranger"></a>
      </div> <!-- /.navbar-header -->

      <div class="navbar-collapse collapse">
        <ul id="nav-site" class="nav navbar-nav">
          <li id="nav-read" class="dropdown" style="margin-left:20px;">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">Things to Read <b class="caret"></b></a>
            <ul class="dropdown-menu" style="min-width:250px;">
              
              
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/slog" target="_self">
                    
                    <i class="fa fa-star"></i>
                    Slog: Seattle's Only Blog
                  </a>
                </li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/slog-ampm" target="_self">
                    
                    <i class="fa fa-star"></i>
                    Slog AM/PM
                  </a>
                </li>
              
                

                

                

                <li class="highlighted last">
                  <a data-silo="ttr" href="https://www.thestranger.com/sticker-patrol" target="_self">
                    
                    <i class="fa fa-star"></i>
                    Sticker Patrol
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/" target="_self">
                    
                    
                    Home
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/savage-love" target="_self">
                    
                    
                    Savage Love
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/news" target="_self">
                    
                    
                    News
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/arts" target="_self">
                    
                    
                    Arts
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/geek" target="_self">
                    
                    
                    Comics<span class="lighter">&</span>Games
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/unstreamable" target="_self">
                    
                    
                    Unstreamable
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/food-and-drink" target="_self">
                    
                    
                    Food<span class="lighter">&</span>Drink
                  </a>
                </li>
              
            </ul>
          </li>

          <li id="nav-do" class="dropdown">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">Things to Do <b class="caret"></b></a>
            <ul class="dropdown-menu" style="min-width:250px;">
              
                <li class="everout-nav-item">
                  <a href="https://everout.com/seattle">
                    <img src="https://www.thestranger.com/assets/sites/everout/everout-logo.png?20190815172027" width="65%;" alt="EverOut">
                  </a>
                </li>
              
              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/seattle" target="_self">
                    
                    
                    Home
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/seattle/neighborhoods/" target="_self">
                    
                    
                    Neighborhoods at a Glance
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/seattle/articles/" target="_self">
                    
                    
                    Picks & Guides
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/seattle/events/?category=in-person" target="_self">
                    
                    
                    In-Person Events
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/seattle/events/" target="_self">
                    
                    
                    All Events
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/seattle/events/?category=music&type=in-person" target="_self">
                    
                    
                    Live Music
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/seattle/events/?category=food-drink" target="_self">
                    
                    
                    Food & Drink
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/seattle/events/?category=readings-talks" target="_self">
                    
                    
                    Readings & Talks
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/seattle/visual-art/" target="_self">
                    
                    
                    Visual Art
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/seattle/events/?category=performance" target="_self">
                    
                    
                    Performance
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/seattle/film/" target="_self">
                    
                    
                    Film
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/seattle/events/submit/" target="_self">
                    
                    
                    Submit an Event
                  </a>
                </li>

              
            </ul>
          </li>
        </ul>

        

        <ul class="nav navbar-nav navbar-right">
          
            <style>
              
                .contribute-nav-item a {
                  color: blue!important
                }
              
              
                .contribute-nav-item a:hover {
                  color: black!important
                }
              
            </style>
            <li>
              <li class="non-dropdown contribute-nav-item">
                <a class="" data-context="desktop-nav" href="https://www.thestranger.com/contribute?utm_source=publication&utm_medium=top_nav&utm_campaign=top_nav" target="_self">Support The Stranger</a>
              </li>
            </li>
          
          <li id="topNavAccountMenu" class="dropdown nav-account">
            <a href="#" class="link-icon dropdown-toggle" data-toggle="dropdown"><i class="fa fa-user-circle-o"></i></span></a>
            <ul class="dropdown-menu nav-account-menu">
              <li><a href="https://post.thestranger.com/login">Log in</a></li>
              <li><a href="https://post.thestranger.com/login/create">Sign up</a></li>
            </ul>
          </li>
          <li id="navbar-search">
            <a href="#" class="link-icon"><i class="fa fa-search"></i></a>
            <form action="/search" id="navbar-search-form" class="navbar-form" role="search" required>
              <input name="q" id="q" type="text" class="form-control" placeholder="Search" name="srch-term" id="srch-term">
            </form>
          </li>
          
          
          <script>
            $('#filter-search-more').click(function() {
              if(!$(this).hasClass('collapsed')) {
                $('.more-text',this).html('More');
                $('i.fa',this).removeClass('fa-caret-up').addClass('fa-caret-down');
              } else {
                $('.more-text',this).html('Less');
                $('i.fa',this).removeClass('fa-caret-down').addClass('fa-caret-up');
              }
            });
            $("#navbar-search a.link-icon").click(function(){
              $(this).closest('.navbar-right').toggleClass("search-open");
              $(this).siblings("#navbar-search-form").toggle();
              if($(this).closest('.navbar-right').hasClass('search-open')) {
                $(this).siblings("#navbar-search-form").find('.form-control').focus();
              }
              return false;
            });
          </script>
        </ul>
      </div><!--/.navbar-collapse -->
    </div><!-- /.container -->
  </div><!-- /#top-nav -->
</div><!-- /#site-header -->

<div id="mobile-header" class="navbar navbar-default visible-xs hidden-lg hidden-md" role="navigation">
  <div id="mobile-nav">
    









<header class="mobile-nav" role="banner">
  <div class="navbar-header">
    <button type="button" id="mobileNavToggle" class="navbar-toggle collapsed" data-toggle="collapse" data-target=".main-navigation" style="float:right;">
      <div class="navbar-toggle-closed-label">
        
          <span class="navbar-toggle-label-text">Menu</span>
        
        <i class="fa fa-bars"></i>
      </div>
      <div class="navbar-toggle-open-label">
        
          <span class="navbar-toggle-label-text">Close</span>
        
        <i class="fa fa-times"></i>
      </div>
    </button>
    
    <a class="navbar-brand " href="https://www.thestranger.com/"><img src="https://www.thestranger.com/assets/sites/stranger/images/site-logo.png?2018-09-13-121404" alt="The Stranger"></a>
  </div>
  <nav class="navbar-collapse main-navigation collapse" role="navigation" style="height: 1px;max-height:none;">
    <div class="container">
      <div class="row">
        <div class="col-xs-12">
          <form action="https://post.thestranger.com/search" class="navbar-form navbar-right" role="search">
            <div class="form-group input-group">
              <input type="text" class="form-control" name="q" placeholder="Search">
              <span class="input-group-btn">
                <button type="submit" class="btn btn-default"><i class="fa fa-search"></i></button>
              </span>
            </div>
          </form>
        </div>
      </div>
      <div class="row">
        <div class="col-xs-6" style="padding-right:0;">
          <ul class="nav navbar-nav">
            <li class="dropdown-header" style="padding-left:0;">Things To Read</li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/slog" target="_self">
                  <i class="fa fa-star"></i> 
                  
                  Slog: Seattle's Only Blog</a></li>
                </li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/slog-ampm" target="_self">
                  <i class="fa fa-star"></i> 
                  
                  Slog AM/PM</a></li>
                </li>
              
                

                

                

                <li class="highlighted last">
                  <a data-silo="ttr" href="https://www.thestranger.com/sticker-patrol" target="_self">
                  <i class="fa fa-star"></i> 
                  
                  Sticker Patrol</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/" target="_self">
                  
                  
                  Home</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/savage-love" target="_self">
                  
                  
                  Savage Love</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/news" target="_self">
                  
                  
                  News</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/arts" target="_self">
                  
                  
                  Arts</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/geek" target="_self">
                  
                  
                  Comics<span class="lighter">&</span>Games</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/unstreamable" target="_self">
                  
                  
                  Unstreamable</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/food-and-drink" target="_self">
                  
                  
                  Food<span class="lighter">&</span>Drink</a></li>
                </li>
              
            <li><a href="/issues">Print Archives</a></li>
          </ul>
        </div>
        <div class="col-xs-6">
          <ul class="nav navbar-nav">
            <li class="dropdown-header" style="padding-left:0;">Things To Do</li>

              
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/seattle" target="_self">
                
                
                Home</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/seattle/neighborhoods/" target="_self">
                
                
                Neighborhoods at a Glance</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/seattle/articles/" target="_self">
                
                
                Picks & Guides</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/seattle/events/?category=in-person" target="_self">
                
                
                In-Person Events</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/seattle/events/" target="_self">
                
                
                All Events</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/seattle/events/?category=music&type=in-person" target="_self">
                
                
                Live Music</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/seattle/events/?category=food-drink" target="_self">
                
                
                Food & Drink</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/seattle/events/?category=readings-talks" target="_self">
                
                
                Readings & Talks</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/seattle/visual-art/" target="_self">
                
                
                Visual Art</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/seattle/events/?category=performance" target="_self">
                
                
                Performance</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/seattle/film/" target="_self">
                
                
                Film</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/seattle/events/submit/" target="_self">
                
                
                Submit an Event</a></li>
              </li>

            
          </ul>
        </div>
      </div>
      <div class="row">
        
          <div class="col-xs-6">
            <ul class="nav navbar-nav">
              <li class="dropdown-header" style="padding-left:0;">Other Things</li>
              
                <li><a href="https://www.thestranger.com/contribute" target="_self">Support The Stranger</a></li>
              
                <li><a href="https://www.thestranger.com/ad-info" target="_self">Ad Info & Rates</a></li>
              
                <li><a href="http://www.strangertickets.com" target="_blank">Stranger Tickets</a></li>
              
            </ul>
          </div>
        
        <div id="mobileNavAccountMenu" class="col-xs-6 nav-account">
          <ul class="nav navbar-nav nav-account-menu">
            <li class="dropdown-header" style="padding-left:0;">Account</li>
            <li><a href="https://post.thestranger.com/login">Log in</a></li>
            <li><a href="https://post.thestranger.com/login/create">Sign up</a></li>
          </ul>
        </div>
      </div>
    </div> <!-- end container -->
  </nav>
  <script>
    $('#mobileNavToggle').click(function() {
      var menuAction = $(this).hasClass('collapsed') ? 'openMenu' : 'closeMenu';
      ga('send', {
        hitType: 'event',
        eventCategory: 'MobileNav',
        eventAction: ''+menuAction+''
      });
      $(this).toggleClass('collapsed');
    });
    $('.mobile-nav .nav li a').click(function() {
      var navLabel = $(this).data('silo')+'-'+$(this).text();
      ga('send', {
        hitType: 'event',
        eventCategory: 'MobileNav',
        eventAction: 'click',
        eventLabel: ''+navLabel+''
      });
    });
  </script>
</header>

  </div>
</div>
      <div class="top-super text-center component container">
  <div id="div-gpt-ad-top-super"></div>
  <div id="div-gpt-ad-mobile-top"></div>
</div>
      <div id="siteContent" class="container">
        <div class="row" class="main">
          <div class="col-sm-12 col-md-8 primary">
  
  <div id="articleComponent-73941800" class="component">

    

     <div class="blog-header slog">
  <h1><a href="https://www.thestranger.com/slog"><img id="slogLogo" src="" class="img-responsive slog-logo"></a></h1>
</div>
    
    
    <div id="article-73941800" class="article coll_slog-am-pm">
      <div id="article-header-73941800" class="article-header">
        
          <div class="post-tags-and-date">
            
              <div class="label topic">
                
                  <a href="https://www.thestranger.com/archive/slog-am-pm">Slog AM/PM</a>
                  
                
              </div>
            
          </div>
        
        <h1 class="headline">
          <strong>Slog PM:</strong> Monkeypox Suspected in King County, Bruce Harrell Still Waiting for His Thank You, and Farewell to the Last Public Payphone
          
        </h1>
        <h2 class="subheadline">
          
        </h2>
        <div class="byline">
          
            by <a href="https://www.thestranger.com/authors/21647307/matt-baume">Matt Baume</a>
            
              &bull;
            
          
          
            <span class="post-time">
              May 23, 2022 at  5:30 pm
            </span>
          
        </div>
        
        
        
          
        
      </div> <!-- end .article-header -->

      <div class="article-text category-slog">
        
        

        <div class="social-tools text-right" style="margin-bottom:10px;position:relative;">
          
          <div class="fb-like"
            data-href="https://www.thestranger.com/slog/2022/05/23/73941800/slog-pm-monkeypox-suspected-in-king-county-bruce-harrell-still-waiting-for-his-thank-you-and-farewell-to-the-last-public-payphone"
            data-layout="button_count"
            data-action="like"
            data-show-faces="true"
            data-share="true" style="margin-right:10px;position:relative;top:-5px;"></div>
          
          <a class="twitter-share-button" href="https://twitter.com/share"
            data-url="https://www.thestranger.com/slog/2022/05/23/73941800/slog-pm-monkeypox-suspected-in-king-county-bruce-harrell-still-waiting-for-his-thank-you-and-farewell-to-the-last-public-payphone"
            data-text="Slog PM: Monkeypox Suspected in King County, Bruce Harrell Still Waiting for His Thank You, and Farewell to the Last Public Payphone">
          Tweet
          </a>
          <script>
          window.twttr=(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],t=window.twttr||{};if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);t._e=[];t.ready=function(f){t._e.push(f);};return t;}(document,"script","twitter-wjs"));
          </script>
          <a style="position:relative;top:-5px;" href="//www.reddit.com/submit?url=https%3A//www.thestranger.com/slog/2022/05/23/73941800/slog-pm-monkeypox-suspected-in-king-county-bruce-harrell-still-waiting-for-his-thank-you-and-farewell-to-the-last-public-payphone" target="_blank"><img src="//www.redditstatic.com/spreddit5.gif" alt="submit to reddit" border="0" /></a>
        </div>

        

        
        

        
        
        
        
        
          
          
          
          
          
          
            
            
            
            
              
              <div class="blogImageCenter img-responsive" style="width:594px"><img src="https://media1.fdncms.com/stranger/imager/u/original/73941913/1653349959-gettyimages-1398839771.jpg" alt="Liberty and justice for all, just behind these barricades" title="Liberty and justice for all, just behind these barricades"><div class="image-caption-and-credit"><span class="imageCaption">Liberty and justice for all, just behind these barricades</span> <span class="imageCredit">Chip Somodevilla / Getty Images Staff</span></div></div> <p><strong>Monkeypox is (probably) here.</strong> Public Health Seattle & King County is <a href="https://www.seattletimes.com/seattle-news/health/king-county-investigating-first-presumptive-case-of-monkeypox-in-wa/">investigating a likely case</a> of monkeypox. The patient is an unidentified man who recently traveled abroad, and health officials aren’t aware of any other cases. If you’re experiencing symptoms — basically feeling like you have the flu, accompanied by a new rash, bumps, or sores — you’re asked to contact a health care provider as soon as possible.</p>
              
            
              
              <p><strong>A really bad Supreme Court ruling.</strong> No, not the reproductive health one. Today, SCOTUS issued a ruling that basically makes it easier to keep people locked up even if their attorneys were incompetent. <a href="https://twitter.com/mjs_DC/status/1528738323585458177">It’s bad</a>! But not surprising. What America <a href="https://www.theatlantic.com/business/archive/2015/09/prison-labor-in-america/406177/">calls</a> a “justice system” is <a href="https://www.npr.org/transcripts/884989263">really</a> just a means of <a href="https://www.freedomunited.org/prison-labor-and-modern-slavery/">legitimizing slave labor</a>.</p>
              <div class="row fish-butter article-inline-native-wrapper pull-left" data-context-oid="70779700" data-ad-oid="70779699">

      <div class="fish-tag row article-inline-native-tag">
          Sponsored
      </div>

      <div class="row">
        <div class="col article-inline-native-inner-wrapper">
          

          
            <div class="col-xs-3 article-inline-native-image">
              <a href="https://post.thestranger.com/seattle/clickclick?adoid=70779699&poid=70779700&url=https%3A//wl.seetickets.us/wafform.aspx%3Fafflky%3DCapitolHillBlockParty%26_act%3Dsubpromoterev3%26_pky%3D441963%26sp%3DL7JXSZ" class="image-link" rel="nofollow">
                <img src="https://media1.fdncms.com/stranger/imager/u/original/70779661/original-chbp_thestranger_125x90.gif" class="img-fluid">
              </a>
            </div>
          

          
          <div class="col-xs-9">
            <div class="row article-inline-native-headline">
              <a href="https://post.thestranger.com/seattle/clickclick?adoid=70779699&poid=70779700&url=https%3A//wl.seetickets.us/wafform.aspx%3Fafflky%3DCapitolHillBlockParty%26_act%3Dsubpromoterev3%26_pky%3D441963%26sp%3DL7JXSZ" rel="nofollow">
                Capitol Hill Block Party returns this summer on July 22nd thru 24th!
              </a>
              
            </div>

            
              <div class="row article-inline-native-body">
                Featuring Charli XCX, Diplo, and more! Full line-up and tickets at <a href="https://wl.seetickets.us/wafform.aspx?afflky=CapitolHillBlockParty&_act=subpromoterev3&_pky=441963&sp=L7JXSZ">capitolhillblockparty.com</a>
              </div>
            
          </div>
          
        </div>
      </div>
    </div>
            
              
              <p><strong>Want to meet some trees?</strong> You don’t need a car to get to some great trails! Go take a bus to a fine hike:</p>
              <div class="interstitial-ad-1 ad pull-right">
                      <div id="div-gpt-ad-mobile-inline-1" class="interstitial-ad  inline-ad"></div>
                    </div>
            
              
              <a name="more"></a>
          <p><blockquote class="twitter-tweet"><p lang="en" dir="ltr">Re-upping this short-n-sloppy <a href="https://twitter.com/hashtag/TransitTrekker?src=hash&ref_src=twsrc%5Etfw">#TransitTrekker</a> thread about trails you need not wait for TrailheadDirect to access via transit. 🧵 <a href="https://t.co/yOKU50bfq2">https://t.co/yOKU50bfq2</a><br />— Kimberly "You call that a DEIS?" K i n c h e n (@SheRidesABike) <a href="https://twitter.com/SheRidesABike/status/1528392364003164165?ref_src=twsrc%5Etfw">May 22, 2022</a></blockquote> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
              
            
              
              <p><strong>Bruce Harrell is getting impatient waiting for you to thank him.</strong> That comes from <a href="https://www.axios.com/local/seattle/2022/05/23/hot-seat-seattle-mayor-bruce-harrell-homelessness">an Axios interview</a> with Seattle’s sweeper-in-chief, who is apparently “tired” of everyone criticizing him. “When will the city recognize — because many people do — we are doing outstanding work?” Harrell says, pointing out that they’ve “referred” dozens of unhoused people to shelter. Of course, not every referral is to shelter that the person can actually use.</p>
              
            
              
              <p><strong>About that car-fight at Pike Place Market.</strong> Prosecutors have released footage of the Pike Place Market driver who rammed his car into two people back in April. I’m not going to link to it — for one thing because it’s upsetting, and for another because it’s watermarked by a conservative radio host whose Twitter feed feels like one long failed audition for Fox News, but it’s out there if you want to go looking.</p>
              <div class="interstitial-ad-2 ad pull-right">
                      <div id="div-gpt-ad-mobile-inline-2" class="interstitial-ad  inline-ad"></div>
                    </div>
            
              
              <p><strong>Apparently there’s an app for the AIDS Memorial Pathway? </strong>You can, allegedly, download an app that creates an augmented-reality overlay on the AIDS Memorial Pathway on Capitol Hill. The virtual art project <a href="http://www.akcho.org/awards/">just won an award</a>, which will be presented (online, appropriately) tomorrow. I’m not sure what the criteria for this award is, because I went searching for an iOS version of the app and couldn’t find it, and nothing happened when I clicked the link to download it via the <a href="https://theamp.org/">AMP’s website</a>. Anyway, congrats on the award!</p>
              
            
              
              <p><blockquote class="twitter-tweet"><p lang="en" dir="ltr">The AMP has been awarded the 2022 AKCHO Technology Award for its augmented reality app and public installation project.<br><br>Join the online awards ceremony Tuesday, May 24th at 5:30 PM by registering at <a href="https://t.co/JHWPM51RcI">https://t.co/JHWPM51RcI</a><a href="https://twitter.com/Novaby3D?ref_src=twsrc%5Etfw">@novaby3D</a> <a href="https://t.co/LI3CBao9cr">pic.twitter.com/LI3CBao9cr</a><br />— Gay City: Seattle's LGBTQ Center (@GayCitySeattle) <a href="https://twitter.com/GayCitySeattle/status/1528823229162434565?ref_src=twsrc%5Etfw">May 23, 2022</a></blockquote> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
              
            
              
              <p><strong>In case you’re planning something for Memorial Day: </strong>Just a reminder that various city facilities will be closed next Monday, from swimming pools to the Japanese garden to community centers. <a href="https://parkways.seattle.gov/2022/05/03/memorial-day-closures-for-seattle-parks-and-recreation-2/">Get the full list of closures here</a>.</p>
              <div class="interstitial-ad-3 ad pull-right">
                      <div id="div-gpt-ad-mobile-inline-3" class="interstitial-ad  inline-ad"></div>
                    </div>
            
              
              <p><strong>Don’t worry, a recession isn’t inevitable.</strong> These are not exactly the most encouraging words to hear from the president of what’s left of the United States, but <a href="https://www.cnn.com/2022/05/23/politics/biden-says-recession-not-inevitable/index.html">Joe Biden says</a> that recession isn’t necessarily inevitable. Okay, thanks for bolstering our confidence, Joe!</p>
              
            
              
              <p><strong>Peace Peloton is this Friday.</strong> The eight-mile ride goes from Occidental Square Park to White Center — a little prelude to their <a href="https://www.peacepeloton.com/">70-mile ride</a> in July from Snoqualmie to Pier 62.</p>
              
            
              
              <p><blockquote class="twitter-tweet"><p lang="en" dir="ltr">Join us for the <a href="https://twitter.com/peacepeloton?ref_src=twsrc%5Etfw">@peacepeloton</a> Fresh Air Ride on Friday, May 27th! We'll gather at Occidental Park from 5-6pm and ride to Beer Star in White Center to celebrate conservation and car-free commuting. <a href="https://t.co/FjtXrXNQT6">pic.twitter.com/FjtXrXNQT6</a><br />— Commute Seattle (@CommuteSeattle) <a href="https://twitter.com/CommuteSeattle/status/1526680790033059840?ref_src=twsrc%5Etfw">May 17, 2022</a></blockquote> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
              <div class="interstitial-ad-4 ad pull-right">
                      <div id="div-gpt-ad-mobile-inline-4" class="interstitial-ad  inline-ad"></div>
                    </div>
            
              
              <p><strong>State Farm is helping to deliver inclusive books to young readers.</strong> It’s no surprise that conservatives hate reading — probably because it makes their lips so tired — so of course they’re up in arms about <a href="https://gendercool.org/">a program to send LGBTQ+ inclusive literature to classrooms</a>.</p>
              
            
              
              <p><strong>I’m not smart enough to understand how smart these kids are.</strong> Congratulations to these <a href="https://www.geekwire.com/2022/meet-the-seattle-area-teen-geeks-that-just-won-awards-at-an-international-science-fair/">23 brilliant Washington youths</a> who recently competed in an International Science and Engineering Fair, winning nearly two dozen awards for topics like “A Machine Learning Approach to Identifying Blood-Based Biomarkers for Differential Diagnosis of Alzheimer’s Disease” and “Exploiting Plasmid-Mediated Resistance: Discovery of Small-Molecule Inhibitors for the Artificial Activation of the Kid-Kis Toxin-Antitoxin System in Plasmid R1.” They are literally teenagers who are about to save the world, and what have I done with my life? Complaining about funny smells for a local online 'zine? God.</p>
              
            
              
              <p><strong>How centuries of racism continues to punish Haiti.</strong> There was an absolutely <a href="https://www.nytimes.com/2022/05/20/world/americas/haiti-history-colonized-france.html">must-read piece</a> in the <em>NY Times </em>this weekend about how French colonialism brutalized Haiti — and how it continues to do so through the echoes of history, including the forcing of Haitians to pay “reparations to enslavers.”</p>
              <div class="interstitial-ad-5 ad pull-right">
                      <div id="div-gpt-ad-mobile-inline-5" class="interstitial-ad  inline-ad"></div>
                    </div>
            
              
              <p><strong>The Washington Legislature keeps doing what it does best (nothing). </strong>For the last two years, state leaders failed to pass reforms to the comprehensive planning process — a wonky undertaking that basically guides how towns plan their growth. That’s discouraging, since the proposed reforms would have required towns to take action on climate change. <a href="https://www.heraldnet.com/news/a-climate-bill-that-died-in-legislature-lives-on-in-plans-for-future/">The good news</a> is that a handful of jurisdictions are planning to enact those reforms as though they’d actually passed; among those areas is King County and Bothell. Other towns are paying lip service with pretty words but not following the proposed reforms, including Lynnwood and Everett.</p>
              
            
              
              <p><strong>Let’s queer some data.</strong> Gay City is currently seeking a <a href="https://www.gaycity.org/Jobs/">Data Coordinator</a> to manage records, monitor HIV/STI services, and shepherd client data through databases. Perhaps that person is you! They’re also hiring in positions involving finance, communications, and research.</p>
              
            
              
              <p><strong>Farewell to the last public payphone in New York.</strong> It was airlifted out today — no word on where it’s headed, but I can see it fitting right in at a retirement home in Florida. Meanwhile, does Seattle have any public payphones left? There are a handful maintained by local businesses (<a href="https://mrandmrssmithgotowashington.com/2015/03/12/a-taste-of-the-lockspot-cafe/">Lockspot’s phone booth</a> still works, right?), and <a href="https://www.seattletimes.com/pacific-nw-magazine/working-phone-booths-dot-south-whidbey-island-where-residents-still-can-make-local-calls-for-free/">several dozen on Whidbey Island</a>, but I’m not aware of any old-fashioned out-on-the-street phones left. <a href="http://twitter.com/mattbaume">Let me know</a> if you know of any.</p>
              <div class="interstitial-ad-6 ad pull-right">
                      <div id="div-gpt-ad-mobile-inline-6" class="interstitial-ad  inline-ad"></div>
                    </div>
            
              
              <p><blockquote class="twitter-tweet"><p lang="en" dir="ltr">END OF AN ERA. Say goodbye to New York City's LAST public pay-phone booth, at 50th and 7th. <br>Kinda sad, I'm a little verklempt. <a href="https://t.co/mEV30ASFZ9">pic.twitter.com/mEV30ASFZ9</a><br />— Duty To Warn 🔉 (@duty2warn) <a href="https://twitter.com/duty2warn/status/1528763874089922560?ref_src=twsrc%5Etfw">May 23, 2022</a></blockquote> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
              
            
              
              <p><strong>Two opportunities this week to bother the Design Review Board:</strong> On Tuesday and Thursday the Design Review Board <a href="https://www.seattle.gov/dpd/aboutus/news/events/DesignReview/upcomingreviews/">will meet</a> to consider four much-needed housing projects, making up nearly 800 new units of housing: 2234 2nd Ave (59 new homes); 801 Blanchard St (418 new homes replacing two parking lots, existing Shake Shack and Butcher’s Table buildings <a href="https://www.seattle.gov/dpd/AppDocs/GroupMeetings/DRProposal3037081AgendaID12357.pdf">to remain</a>); 402 S Lucile St (152 new homes); and 119 12th Ave (127 new homes). Design Review likes to <a href="https://twitter.com/pushtheneedle/status/1528796252564905984/photo/1">uselessly delay the construction of new housing</a> so a bunch of volunteers can argue for months about brick color and drive up the cost of construction by millions of dollars, so the least you can do is submit a comment that you think the proposed designs are just fine and that they don’t need any further debate.</p>
              
            
              
              <p><strong>Madison Cawthorn is under investigation, lol.</strong> The House Ethics Committee <a href="https://www.npr.org/2022/05/23/1100827985/madison-cawthorn-house-ethics-investigation-crypto">will look into</a> whether he violated rules by promoting a cryptocurrency. I doubt very much that he gives a shit what the House Ethics Committee has to say.</p>
              <div class="fish-butter contribution-inline" data-context-oid="64624518" data-ad-oid="64624517">
      <div class="contribution-inline-headline">
        <h3>
          <a href="https://post.thestranger.com/seattle/clickclick?adoid=64624517&poid=64624518&url=https%3A//www.thestranger.com/contribute%3Futm_source%3Dpublication%26utm_medium%3Darticle_inline%26utm_campaign%3Dinline_ampm" target="_blank" rel="nofollow">
            Love Slog AM/PM?
          </a>
        </h3>
      </div>
      <div class="contribution-inline-body">
        <a href="https://post.thestranger.com/seattle/clickclick?adoid=64624517&poid=64624518&url=https%3A//www.thestranger.com/contribute%3Futm_source%3Dpublication%26utm_medium%3Darticle_inline%26utm_campaign%3Dinline_ampm" target="_blank" rel="nofollow" style="all:inherit">
          More than ever, <em>The Stranger</em> is relying on your contributions to help fund our coverage. With a one-time or recurring contribution, you can support local, independent media and help keep columns like Slog AM/PM around.
        </a>
      </div>
      <div class="contribution-inline-button">
        <a href="https://post.thestranger.com/seattle/clickclick?adoid=64624517&poid=64624518&url=https%3A//www.thestranger.com/contribute%3Futm_source%3Dpublication%26utm_medium%3Darticle_inline%26utm_campaign%3Dinline_ampm" target="_blank" rel="nofollow" class="btn btn-primary">Contribute</a>
      </div>
    </div>
            
              
              <p><strong>SDOT’s keeping the buses nice and slow.</strong> A couple years ago, SDOT put the kibosh on bus lanes on the 48 route due to a handful of complaints from residents. They said they’d revisit bus lanes in a few years when redoing 23rd Ave. Well, they’re finally redoing 23rd, and guess what? <a href="https://www.theurbanist.org/2022/05/23/route-48-bus-lanes-largely-missing/">No bus lanes in sight.</a></p>
              
            
              
              <p><strong>Remember the time Popeye and Bluto dated?</strong> Me and whomst:</p>
              
            
              
              <p><blockquote class="twitter-tweet"><p lang="en" dir="ltr">I'm so happy for them <a href="https://t.co/rIMSYYPg4w">pic.twitter.com/rIMSYYPg4w</a><br />— Matt Baume (@MattBaume) <a href="https://twitter.com/MattBaume/status/1528446598044217344?ref_src=twsrc%5Etfw">May 22, 2022</a></blockquote> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
              
            
           

        

        
        

        

        

        
          
        

      </div> <!-- end .article-text -->

      
      
      
        
          <div id="mc_embed_signup" style="padding: 30px 10px; background:#fff;font:15px Georgia,serif;width:100%; font-weight: normal; text-align: center;">
<form action="https://thestranger.us4.list-manage.com/subscribe?u=739a0d2f2ff0031156e7b3d55&amp;id=f02129603b" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" target="_blank" novalidate="">
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL" style="font-weight: normal; padding: 5px;">To get this delivered to your inbox, subscribe to <i>The Stranger</i>'s Slog AM newsletter.</label>
<div class="input-group" style=" width=100%; max-width:400px; margin: 0 auto;">
<input type="hidden" name="group[19329][4]" value="checked">
<input class="form-control" type="email" value="" name="EMAIL" id="mce-EMAIL" placeholder="email address" required="" style="border-radius: 4px;border-bottom-right-radius: 0;border-top-right-radius: 0;">
<div style="position: absolute; left: -5000px;" aria-hidden="true">
<input type="text" name="b_739a0d2f2ff0031156e7b3d55_67f93c78f9" tabindex="-1" value=""></div>
<span class="input-group-btn"><button class="btn btn-default" style="font-weight: normal;" type="submit" value="Subscribe" name="subscribe">Subscribe</span></div></div></form></div>
        
      

      
      
        <script id="fdncms-carousel-top-stories-video" src="https://www.hub.fdncms.com/gyrobase/Responsive/Components/Content/TopStoriesVideo?cb=72fc8652&key=bc2394029788a572f638c2af9ed8678a&req=js" async></script>
      

    </div> <!-- end .article -->

    <!-- article-contribution-footer -->
    
    
      <div class="article-contribution-footer">
        <em>The Stranger</em> depends on your continuing support to provide articles like this one. In return, we pledge our ongoing commitment to truthful, progressive journalism and serving our community. So if you’re able, please consider a small recurring contribution. Thank you—you are appreciated!
        <div style="margin-top:1rem;"><a href="/contribute?utm_source=publication&utm_medium=article_footer&utm_campaign=footer_ask" class="btn btn-danger btn-large">CONTRIBUTE NOW</a></div>
      </div>
    
    <!-- article-contribution-footer -->

    

    <div class="row social-tools" style="margin-top:1.5em; clear:both;">
      <div class="col-xs-12 col-sm-5 text-center lg-social-btn">
        <a href="http://www.facebook.com/sharer.php?u=https%3A//www.thestranger.com/slog/2022/05/23/73941800/slog-pm-monkeypox-suspected-in-king-county-bruce-harrell-still-waiting-for-his-thank-you-and-farewell-to-the-last-public-payphone&amp;t=Slog+PM%3A+Monkeypox+Suspected+in+King+County%2C+Bruce+Harrell+Still+Waiting+for+His+Thank+You%2C+and+Farewell+to+the+Last+Public+Payphone" target="_blank" onclick="window.open(this.href, '_blank', 'toolbar=no, scrollbars=auto, resizable=yes, top=250, left=250, width=500, height=500'); return false;"><img class="img-responsive" src="/images/social/share-on-facebook.png" alt="Share on Facebook" style=""></a>
      </div>
      <div class="col-xs-12 col-sm-5 text-center lg-social-btn">
        <a href="http://twitter.com/intent/tweet?&amp;url=https%3A//www.thestranger.com/slog/2022/05/23/73941800/slog-pm-monkeypox-suspected-in-king-county-bruce-harrell-still-waiting-for-his-thank-you-and-farewell-to-the-last-public-payphone&amp;text=Slog+PM%3A+Monkeypox+Suspected+in+King+County%2C+Bruce+Harrell+Still+Waiting+for+His+Thank+You%2C+and+Farewell+to+the+Last+Public+Payphone&amp;related=strangerslog" target="_blank" onclick="window.open(this.href, '_blank', 'toolbar=no, scrollbars=auto, resizable=yes, top=250, left=250, width=500, height=500'); return false;"><img class="img-responsive" src="/images/social/share-on-twitter.png" alt="Share on Twitter" style=""></a>
      </div>
      
        <div class="col-xs-12 col-sm-2 text-center" style="padding-bottom:0.2em;">
          <h3 style="margin-top:5px;">
            
              <a href="/slog/2022/05/23/73941800/slog-pm-monkeypox-suspected-in-king-county-bruce-harrell-still-waiting-for-his-thank-you-and-farewell-to-the-last-public-payphone/comments" rel="nofollow"><i class="fa fa-comment"></i> <span class="comment-count">4</span></a>
            
          </h3>
        </div>
      
    </div>

    

    
    
      <div class="article-bio-wrapper">
        
          
          
            <div class="article-author-bio">

              <div class="row clearfix visible-xs">
      <div class="col-xs-12">
        
          <div class="author-bio-image pull-right">
            <img src="https://media2.fdncms.com/stranger/imager/u/small/46347753/mattblue.png" class="img-responsive" loading="lazy">
          </div>
        
        <h4 class="author-bio-name"><b>Matt Baume</b></h4>
        
          <p>Matt Baume covers geek culture, queer news, and city infrastructure, and will leap at the flimsiest of excuses to write about furries. A writer, podcaster, and videomaker, he resides on Capitol Hill with far too many plants.</p>
        
        <div class="author-social-links pull-left">
          
            <a href="https://www.twitter.com/mattbaume" class="author-link btn btn-default"><i class="fa fa-twitter" title="Twitter"></i> Follow</a>
          
          
            <a href="mailto:mbaume@thestranger.com" class="author-link btn btn-default"><i class="fa fa-envelope" title="Email"></i> Email</a>
          
          
            <a href="https://www.thestranger.com/authors/21647307/matt-baume" class="author-link btn btn-default">More articles</a>
          
          
        </div>
      </div>
    </div>

    
    <div class="row clearfix hidden-xs">
      
        <div class="col-sm-3">
          <div class="author-bio-image">
            <img src="https://media2.fdncms.com/stranger/imager/u/small/46347753/mattblue.png" class="img-responsive" loading="lazy">
          </div>
        </div>
      
      
      <div class="col-sm-9">
        <h2 class="author-bio-name">Matt Baume</h2>
        
          <p>Matt Baume covers geek culture, queer news, and city infrastructure, and will leap at the flimsiest of excuses to write about furries. A writer, podcaster, and videomaker, he resides on Capitol Hill with far too many plants.</p>
        
        <div class="author-social-links">
          
            <a href="https://www.twitter.com/mattbaume" class="author-link btn btn-default"><i class="fa fa-twitter" title="Twitter"></i> Follow</a>
          
          
            <a href="mailto:mbaume@thestranger.com" class="author-link btn btn-default"><i class="fa fa-envelope" title="Email"></i> Email</a>
          
          
            <a href="https://www.thestranger.com/authors/21647307/matt-baume" class="author-link btn btn-default">More articles</a>
          
          
        </div>
      </div>
    </div>
            </div>
          
        
      </div>
    

    
      

      
    

    <div class="component related-content" style="padding:1em 0; border-bottom:1px solid #ddd; margin-bottom:1em;">
        <h2 style="margin:0 0 0.5em; padding-top: 25px; border-top: 1px solid #ddd">You might also be interested in these:</h2>
        
        
        <div class="related-content-row" style="padding:0.5em 0;">
        
          <h3 class="headline">
            <a href="https://www.thestranger.com/slog/2022/05/23/73777006/seattle-sticker-patrol-free-housing-4-all-or-else" rel="nofollow"><strong>Seattle Sticker Patrol:</strong> Free Housing 4 All (Or Else)</a>
          </h3>
          
          
            <div class="byline">
              by <a href="https://www.thestranger.com/authors/32434319/jas-keimig">Jas Keimig</a>
            </div>
          
        
      </div>
        
      
        
        <div class="related-content-row" style="padding:0.5em 0;">
        
          <h3 class="headline">
            <a href="https://www.thestranger.com/slog/2022/05/23/73892786/slog-am-petition-to-fix-sound-transit-escalators-fake-whale-guts-in-the-sound-and-sodo-business-director-to-cyclists-drop-dead" rel="nofollow"><Strong>Slog AM:</strong> Petition to Fix Sound Transit Escalators, Fake Whale Guts in the Sound, and SODO Business Director to Cyclists: Drop Dead</a>
          </h3>
          
          
            <div class="byline">
              by <a href="https://www.thestranger.com/authors/21647307/matt-baume">Matt Baume</a>
            </div>
          
        
      </div>
        
      
        
        <div class="related-content-row" style="padding:0.5em 0;">
        
          <h3 class="headline">
            <a href="https://www.thestranger.com/slog/2022/05/20/73761860/a-glimpse-at-seattle-animal-rescue-in-the-1930s" rel="nofollow">A Glimpse at Seattle Animal Rescue in the 1930s</a>
          </h3>
          
          
            <div class="byline">
              by <a href="https://www.thestranger.com/authors/21647307/matt-baume">Matt Baume</a>
            </div>
          
        
      </div>
        
      
          </div>

    <br>
    <div id="div-gpt-ad-mobile-bottom" class="interstitial-ad"></div>
    
      <div id="div-gpt-ad-bottom" class="interstitial-ad"></div>
    
    

  </div> <!-- end component -->
</div>
<div class="col-sm-12 col-md-4 secondary">
  <!-- stranger content sidebar ads -->
<div class="article-sidebar sidebar-ads text-right">
  
    <div class="sidebar-ad-1">
      <div id="div-gpt-ad-sidebar-1" class="sidebar-ad"></div>
    </div>
  
    <div class="sidebar-ad-2">
      <div id="div-gpt-ad-sidebar-2" class="sidebar-ad"></div>
    </div>
  
    <div class="sidebar-ad-3">
      <div id="div-gpt-ad-sidebar-3" class="sidebar-ad"></div>
    </div>
  
    <div class="sidebar-ad-4">
      <div id="div-gpt-ad-sidebar-4" class="sidebar-ad"></div>
    </div>
  
    <div class="sidebar-ad-5">
      <div id="div-gpt-ad-sidebar-5" class="sidebar-ad"></div>
    </div>
  
    <div class="sidebar-ad-6">
      <div id="div-gpt-ad-sidebar-6" class="sidebar-ad"></div>
    </div>
  
</div>
</div>
        </div>
        <div class="row">
          <div class="col-sm-12">
            <div class="bottom-super text-center">
  <div id="div-gpt-ad-bottom-super" class="gpt-dfp"></div>
</div>
          </div>
        </div>
      </div><!-- /#siteContent -->
      <div id="site-footer">
        <link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
  #mc_embed_signup{
    clear:left;
    font:14px Helvetica,Arial,sans-serif;
    width:100%;
  }

  #mc_embed_signup .button{
    background-color: #16698E;
  }
  /* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
     We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>

<div class="hidden-xs hidden-sm">
  <div id="footer-features">
    <div class="container">
      <div class="footer-row">
        <!-- Begin Mailchimp Signup Form -->

        
          <div id="mc_embed_signup">
            <form action="https://thestranger.us4.list-manage.com/subscribe/post?u=739a0d2f2ff0031156e7b3d55&amp;id=f02129603b" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
              <div id="mc_embed_signup_scroll">
                <label for="mce-EMAIL">
                  <h2 style="text-align: center; color: black; font-family: futura-pt,Helvetica Neue,Helvetica,Arial,sans-serif; margin-top:0px">The Stranger in your inbox</h2>
                </label>
                <input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>
                <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
                <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_739a0d2f2ff0031156e7b3d55_f02129603b" tabindex="-1" value=""></div>
                <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
              </div>
            </form>
          </div>
        

        <!--End mc_embed_signup-->
      </div>
    </div>
  </div>
</div><!-- footer (hidden-xs hidden-sm) -->

      
        









<div class="hidden-xs hidden-sm">
  <div id="footer-features-2">
    <div class="container">
      <div class="footer-row">
        
          <div class="col col-md-4 text-center">
        
            <h4>Publication Info</h4>
              <ul class="list-unstyled">
                <li><a href="https://www.thestranger.com/masthead">Masthead</a></li>
                <li><a href="https://www.thestranger.com/ad-info">Ad Info &amp; Rates</a></li>
                
                <li><a href="https://www.thestranger.com/jobs">Jobs at The Stranger</a></li>
                <li><a href="https://www.thestranger.com/contact-information">Contact</a></li>
                <li><a href="https://everout.com/">EverOut</a></li>
                <li><br></li>
                <li><a href="https://www.thestranger.com/contribute?utm_source=publication&utm_medium=footer_nav&utm_campaign=footer_nav">Contribute</a></li>
              </ul>
          </div>

        
          <div class="col col-md-4 text-center" style="border-right: solid 1px white; border-left: solid 1px white;">
            <h4>Check it out</h4>
            
              <div class="footer-promo" id="" style="margin-left:0">
                <a href="https://www.savagelovecast.com">
                  
                    <img src="https://media1.fdncms.com/stranger/imager/u/original/61758119/savage-188x80.jpg" alt="Savage Lovecast">
                  
                </a>
              </div>
            
              <div class="footer-promo" id="" style="margin-left:0">
                <a href="https://everout.com/seattle/">
                  
                    <img src="https://media2.fdncms.com/stranger/imager/u/original/57533353/eo_sea.png" alt="EverOut Seattle">
                  
                </a>
              </div>
            
              <div class="footer-promo" id="" style="margin-left:0">
                <a href="/sp-list/contests">
                  
                    <img src="https://media1.fdncms.com/stranger/imager/u/original/39759991/checkitout_button-contests.png" alt="The Stranger Contests and Giveaways">
                  
                </a>
              </div>
            
          </div>
        

        <div class="col col-md-4 text-center">
          <h4>Follow Us</h4>
          
              <ul id="footer-social-links" class="list-unstyled text-left">
            
            
            <li><a href="/syndication" target="_blank"><i class="fa fa-rss"></i> RSS</a></li>
            
          
            
            <li><a href="http://www.facebook.com/strangerseattle" target="_blank"><i class="fa fa-facebook"></i> Facebook</a></li>
            
          
            
            <li><a href="/twitter" target="_blank"><i class="fa fa-twitter"></i> Twitter</a></li>
            
          
            
            <li><a href="http://instagram.com/thestrangerseattle" target="_blank"><i class="fa fa-instagram"></i> Instagram</a></li>
            
          
              </ul>
            
        </div>

      </div>
    </div>
  </div>
</div><!-- footer (hidden-xs hidden-sm) -->

      
        

<div class="hidden-xs hidden-sm">
  <div id="footer-copyright">
    <div class="container">
      <div class="footer-row">
        <div class="col-md-6">
          <div class="footer-brand">
            
              <a href="https://www.thestranger.com/"><img src="https://www.thestranger.com/assets/sites/stranger/images/site-logo.png?2018-09-13-121404" alt="The Stranger"></a>
            
          </div>
          
          <p class="footer-copyright">
            
              All contents &copy; Index Newspapers LLC<br>
800 Maynard Ave S, Suite 200, Seattle, WA 98134
            
          </p>
        </div>
        <div class="col-md-6">
          <p class="footer-links text-right">
            <a href="https://www.thestranger.com/contact-information">Contact</a>
            <span class="lighter separater">|</span>
            <a href="https://www.thestranger.com/privacy-policy">Privacy Policy</a>
            <span class="lighter separater">|</span>
            <a href="https://www.thestranger.com/terms-of-use">Terms of Use</a>
            <span class="lighter separater">|</span>
            <a href="https://www.thestranger.com/takedown-policy">Takedown Policy</a>
          </p>
        </div>
      </div>
    </div>
  </div>
</div> <!-- footer (hidden-xs hidden-sm) -->

      
        

<div id="footer-mobile"  class="hidden-md hidden-lg">
  <div class="container">
    <div class="footer-row">
      <div class="col-sm-12 text-center">
        <div id="footer-mobile-social-links">
          
            <a href="/syndication" target="_blank"><i class="fa fa-rss"></i></a>
          
            <a href="http://www.facebook.com/strangerseattle" target="_blank"><i class="fa fa-facebook"></i></a>
          
            <a href="/twitter" target="_blank"><i class="fa fa-twitter"></i></a>
          
            <a href="http://instagram.com/thestrangerseattle" target="_blank"><i class="fa fa-instagram"></i></a>
          
        </div>
        <div class="footer-brand">
          
            <a href="https://www.thestranger.com/"><img src="https://www.thestranger.com/assets/sites/stranger/images/site-logo.png?2018-09-13-121404" alt="The Stranger"></a>
          
        </div>
        
        <p class="footer-copyright">
          
            All contents &copy; Index Newspapers LLC<br>
800 Maynard Ave S, Suite 200, Seattle, WA 98134
          
        </p>
        <p class="footer-links">
          <small>
            <a href="https://www.thestranger.com/contact-information">Contact</a> |
            <a href="https://www.thestranger.com/privacy-policy">Privacy Policy</a> |
            <a href="https://www.thestranger.com/terms-of-use">Terms of Use</a> |
            <a href="https://www.thestranger.com/takedown-policy">Takedown Policy</a>
          </small>
        </p>
      </div>
    </div>
  </div>
</div> <!-- /footer-mobile -->
      </div> <!-- /#site-footer -->
    </div> <!-- /.wrapper -->
    <!-- content background ad -->
<div id="div-gpt-ad-background"></div>

      
        


 





<script>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</script>





  
  




  




  
  



  
























<div id="fb-root"></div>

  <script>
    window.fbAsyncInit = function() {
      FB.init({
        appId      : '43933993878',
        xfbml      : true,
        version    : 'v2.6'
      });
    };
  </script>

<script>(function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
    fjs.parentNode.insertBefore(js, fjs);
  }(document, 'script', 'facebook-jssdk'));</script>


<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-332219-1', 'auto');
  ga('require', 'linkid', 'linkid.js');
  ga('set', 'anonymizeIp', true);

  var user = JSON.parse($.cookie('user'));
  var dimension1Value = "";
  var dimension2Value = "";
  var dimension3Value = "";
  var dimension4Value = "";
  var dimension5Value = "slog";
  var dimension6Value = "";
  var dimension7Value = "Matt Baume";
  var dimension8Value = "stranger-editorial-slog-ampm";
  var dimension9Value = "";
  var dimension10Value = user ? user.type : "Guest";
  var dimension11Value = $.map($('.fish-butter'), function(val, i) {
      return $(val).data('adOid')
  }).join(",");
  ga('set', 'dimension1', dimension1Value); // calendar section
  ga('set', 'dimension2', dimension2Value); // location category
  ga('set', 'dimension3', dimension3Value); // location neighborhood
  ga('set', 'dimension4', dimension4Value); // location cuisine
  ga('set', 'dimension5', dimension5Value); // section
  ga('set', 'dimension6', dimension6Value); // category
  ga('set', 'dimension7', dimension7Value); // author
  ga('set', 'dimension8', dimension8Value); // targeting section
  ga('set', 'dimension9', dimension9Value); // location category
  ga('set', 'dimension10', dimension10Value); // user type
  ga('set', 'dimension11', dimension11Value); // native ads
  ga('send', 'pageview');
</script>




<script>
  // track location categories
  var locationCategories = [];
  function trackLocationCategories(i) {
    ga('send', 'event', 'Custom Dimension Event', 'Location Page Categories', 'Location Page Categories', {nonInteraction: true, 'dimension9': locationCategories[i], 'metric1': 1});
  }
  for (var i = 0; i < locationCategories.length; i++) {
    setTimeout(trackLocationCategories(i), 3000);
  }
</script>

<script>
  $(function() {
    $("audio").bind("play", function(e){
      var source = ($(this).attr('src')) ? $(this).attr('src') : $(this).find('source').attr('src');
      ga('send', {
        hitType: 'event',
        eventCategory: 'Audio',
        eventAction: 'play',
        eventLabel: source
      });
    });
  });
</script>



<script type='text/javascript'>
    var _sf_async_config = _sf_async_config || {};
    /** CONFIGURATION START **/
    _sf_async_config.sections = 'slog';
    _sf_async_config.authors = 'Matt Baume';
    /** CONFIGURATION END **/
    (function(){
      function loadChartbeat() {
        window._sf_endpt=(new Date()).getTime();
        var e = document.createElement('script');
        e.setAttribute('language', 'javascript');
        e.setAttribute('type', 'text/javascript');
        e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
        document.body.appendChild(e);
      }
      var oldonload = window.onload;
      window.onload = (typeof window.onload != 'function') ?
        loadChartbeat : function() { oldonload(); loadChartbeat(); };
    })();
</script>


<!-- Start Quantcast tag -->

<script type="text/javascript">
  _qcJSHost = (("https:" == document.location.protocol) ? "https://secure." : "http://edge.");
  _qoptions={
    qacct:"p-aaXEgDiyQODdU"
  };
  document.write(unescape("%3Cscript src='" + _qcJSHost + "quantserve.com/quant.js' type='text/javascript'%3E%3C/script%3E"));
</script>
<noscript>
  <img src="https://secure.quantserve.com/pixel/p-aaXEgDiyQODdU.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast">
</noscript>
<!-- End Quantcast tag -->

<!-- Start Quantcast tag -->
<script type="text/javascript">
_qcJSHost = (("https:" == document.location.protocol) ? "https://secure." : "http://edge.");
 _qoptions={
   qacct:"p-a4LDpi_DEopn-"
 };
</script>
<noscript>
  <img src="https://secure.quantserve.com/pixel/p-a4LDpi_DEopn-.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast">
</noscript>
<!-- End Quantcast tag -->
  </body>
</html>
   
 

