 <!DOCTYPE html>
<html lang="en">
  <head>
    <!-- Google Tag Manager -->
  <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','dataLayer','GTM-5GMVQ6J');</script>
  <!-- End Google Tag Manager -->






<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=yes">
<meta name="google-site-verification" content="Yn7U5qsaj-oKD3y_qp7IbGawlVoNxW1Pzu87ZOHqabU">
<meta name="view-id" content="article">
<!-- start Omniconvert.com code -->
<link rel="dns-prefetch" href="//app.omniconvert.com" /> <script type="text/javascript">window._mktz=window._mktz||[];</script> <script src="//cdn.omniconvert.com/js/sd0d155.js"></script>
<!-- end Omniconvert.com code -->



<title>Skyway Wins Big in the Proposed County Budget, For Once - Slog - The Stranger</title>


  

  

  

  

  <meta name="twitter:card" content="summary_large_image" />
  <meta name="twitter:site" content="@thestranger" />
  <meta name="twitter:image" content="https://media2.fdncms.com/stranger/imager/u/large/44857643/1600733716-img_0397.jpg" />
  <meta property="og:title" content="Skyway Wins Big in the Proposed County Budget, For Once" />
  <meta property="og:description" content="The state&#39;s only Black county council member went to bat for the state&#39;s Blackest neighborhoods. Right now, it looks like he&#39;s winning." />
  <meta name="description" content="The state&#39;s only Black county council member went to bat for the state&#39;s Blackest neighborhoods. Right now, it looks like he&#39;s winning." />
  <meta property="og:site_name" content="The Stranger" />
  <meta property="og:type" content="article" />
  <meta property="og:image" content="https://media2.fdncms.com/stranger/imager/u/large/44857643/1600733716-img_0397.jpg" />
  <meta property="article:publisher" content="https://www.facebook.com/strangerseattle" />
  
    
  
  <meta name="apple-mobile-web-app-title" content="Skyway Wins Big in the Proposed County Budget, For Once - Slog - The Stranger" />
  
    <link rel="apple-touch-icon-precomposed"  href="/images/mobile/touchicons/default/touch-icon-60.png" />
  
    <link rel="apple-touch-icon-precomposed" sizes="76x76" href="/images/mobile/touchicons/default/touch-icon-76.png" />
  
    <link rel="apple-touch-icon-precomposed" sizes="120x120" href="/images/mobile/touchicons/default/touch-icon-120.png" />
  
    <link rel="apple-touch-icon-precomposed" sizes="152x152" href="/images/mobile/touchicons/default/touch-icon-152.png" />
  

  <link rel="mask-icon" href="https://www.thestranger.com/assets/sites/stranger/images/site-badge.svg" color="#000000">
  <link rel="icon" type="image/x-icon" href="https://www.thestranger.com/assets/sites/stranger/images/favicon.png">

  
    <meta property="fb:app_id" content="43933993878"/>
  
  
    <meta property="fb:admins" content="741428065"/>
  
  
    <meta property="fb:pages" content="56439755991" />
  

  

  
  
  
    <link rel="canonical" href="https://www.thestranger.com/slog/2020/09/22/44479076/skyway-wins-big-in-the-proposed-county-budget-for-once" />
    <meta property="og:url" content="https://www.thestranger.com/slog/2020/09/22/44479076/skyway-wins-big-in-the-proposed-county-budget-for-once" />
  
  
   <link rel="alternate" type="application/rss+xml" title="The Stranger: Whole Site" href="/seattle/Rss.xml"/>

  <link rel="alternate" type="application/rss+xml" title="The Stranger: Slog Section" href="/seattle/Rss.xml?section=529161"/>


  
    <link rel="alternate" type="application/rss+xml" title="The Stranger: Articles by Rich Smith" href="/seattle/Rss.xml?author=19407358"/>
 

<!-- revved -->

<link href="https://www.thestranger.com/assets/build/css/styles.9625aa7d.css" rel="stylesheet">

<link rel="stylesheet" href="https://use.fontawesome.com/baf88c5825.css">


<!-- jQuery (necessary for Bootstrap's JavaScript plugins) -->
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.0/jquery.min.js"></script>
<!-- Include all compiled plugins (below), or include individual files as needed -->
<script src="https://stackpath.bootstrapcdn.com/bootstrap/3.4.1/js/bootstrap.min.js" integrity="sha384-aJ21OjlMXNL5UyIl/XNwTMqvzeRMZH2w8c5cRVpzpU8Y5bApTppSuUkhZXN0VxHd" crossorigin="anonymous"></script>


<script src="/seattle/Library/Environment/JavascriptEnvironmentScript"></script>


  <script src="https://www.thestranger.com/assets/build/js/app.e765bde4.js"></script>


<!-- HTML5 Shim and Respond.js IE8 support of HTML5 elements and media queries -->
<!-- WARNING: Respond.js doesn't work if you view the page via file:// -->
<!--[if lt IE 9]>
  <script src="https://oss.maxcdn.com/libs/html5shiv/3.7.0/html5shiv.js"></script>
  <script src="https://oss.maxcdn.com/libs/respond.js/1.4.2/respond.min.js"></script>
<![endif]-->



  <!-- Hotjar Tracking Code for thestranger.com -->
  
  






<!--   typekit -->
<script type="text/javascript" src="//use.typekit.net/wjg1xbh.js"></script>
<script type="text/javascript">try{Typekit.load();}catch(e){}</script>







<script type='text/javascript'>
function getWidth() {
  if (self.innerHeight) {
    return self.innerWidth;
  }
  if (document.documentElement && document.documentElement.clientHeight) {
    return document.documentElement.clientWidth;
  }
  if (document.body) {
    return document.body.clientWidth;
  }
}
var documentWidth = getWidth();

var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
  var gads = document.createElement('script');
  gads.async = true;
  gads.type = 'text/javascript';
  var useSSL = 'https:' == document.location.protocol;
  gads.src = (useSSL ? 'https:' : 'http:') +
  '//www.googletagservices.com/tag/js/gpt.js';
  var node = document.getElementsByTagName('script')[0];
  node.parentNode.insertBefore(gads, node);
})();
</script>

<script type="text/javascript">
  // in gyrobase
  $(document).ready(function() {
    if($('.fish-butter') && !navigator.userAgent.match(/bot|googlebot|crawler|spider|robot|crawling|PhantomJS|BingPreview/ig)){
      $('.fish-butter').each(function() {
        var xhr = new XMLHttpRequest();
        var data = {
          'oid': $(this).data('adOid'),
          'context': $(this).data('contextOid')
        }
        xhr.open('POST', '/_private/tracking/record-hit');
        xhr.setRequestHeader('Content-Type', 'application/json');
        xhr.setRequestHeader('X-CSRF-Token', getCookie('csrfToken'));
        xhr.onload = function() {
          var response = JSON.parse(xhr.responseText);
          if (xhr.status === 200) {
          } else {
          }
        };
        xhr.send(JSON.stringify(data));
      });
    }
  });

  // in keen
  !function(name,path,ctx){
    var latest,prev=name!=='Keen'&&window.Keen?window.Keen:false;ctx[name]=ctx[name]||{ready:function(fn){var h=document.getElementsByTagName('head')[0],s=document.createElement('script'),w=window,loaded;s.onload=s.onerror=s.onreadystatechange=function(){if((s.readyState&&!(/^c|loade/.test(s.readyState)))||loaded){return}s.onload=s.onreadystatechange=null;loaded=1;latest=w.Keen;if(prev){w.Keen=prev}else{try{delete w.Keen}catch(e){w.Keen=void 0}}ctx[name]=latest;ctx[name].ready(fn)};s.async=1;s.src=path;h.parentNode.insertBefore(s,h)}}
  }('KeenAsync','https://d26b395fwzu5fz.cloudfront.net/keen-tracking-1.0.3.min.js',this);

  KeenAsync.ready(function(){
      // Configure a client instance
      var client = new KeenAsync({
        projectId: '58b718b78db53dfda8a8a0eb',
        writeKey: '326C65A94101E46B8EF1B20D83CA64E04F13DEEF29A28D5D7E39F4F5833AFB8F1E0C98E7836FB62A52269ECF45B4AF7C30417251B5A7EE01E34071751EB398A79E24280EEA32F15CC3D607C32274ABA72CD3C460A3F0EB9361D304A6F5391B91'
      });

      // Record views of sponsored posts
      if($('.fish-butter') && !navigator.userAgent.match(/bot|googlebot|crawler|spider|robot|crawling|PhantomJS|BingPreview/ig)){

        // in keen
        $('.fish-butter').each(function() {
          client.recordEvent('adViews', {
            publication: "stranger",
            ad: {
              oid: $(this).data('adOid')
            },
            placement: {
              oid: $(this).data('contextOid')
            },
            user_agent: navigator.userAgent,
            page_url: location.href,
            keen: {
              addons: [{
                name: "keen:ua_parser",
                input: {
                  ua_string: "user_agent"
                },
                output: "parsed_user_agent"
              },{
                name: "keen:url_parser",
                input: {
                  url: "page_url"
                },
                output: "parsed_page_url"
              },{
                name: "keen:date_time_parser",
                input: {
                  date_time: "keen.timestamp"
                },
                output: "timestamp_info"
              }]
            }
          });
        })

      }
    });
</script>


<script type="text/javascript">
     var _sf_async_config = _sf_async_config || {};
     /** CONFIGURATION START **/
     _sf_async_config.uid = 65679
     _sf_async_config.domain = "thestranger.com";
     _sf_async_config.useCanonical = true;
     /** CONFIGURATION END **/
     var _sf_startpt = (new Date()).getTime();
</script>
<script src="//static.chartbeat.com/js/chartbeat_mab.js"></script>
  </head>
  <body class="article  article-section-slog">
    <div class="wrapper">
      <div class="network-bar navbar hidden-xs navbar-expand-md navbar-dark bg-dark">
    <div class="container">
      <ul class="nav navbar-nav mr-auto">
        
          
            <li class="nav-item"><a class="nav-link" href="https://thestranger.com" target="self">The Stranger</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          
            <li class="nav-item"><a class="nav-link" href="https://portlandmercury.com" target="self">Portland Mercury</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          
            <li class="nav-item"><a class="nav-link" href="https://everout.com/stranger-seattle/" target="self">EverOut</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          
            <li class="nav-item"><a class="nav-link" href="https://www.savagelovecast.com" target="self">Savage Love</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          
            <li class="nav-item"><a class="nav-link" href="https://humpfilmfest.com" target="self">Hump!</a></li>
          
          
        
      </ul>
    </div>
  </div>



  
  
    <div id="aboveNav" style="background:#000;border-bottom:1px solid #999;position:relative;margin-bottom:-1px;color:#fcfcfc">
      <div class="container donate-ask">
        
        <p>
Dear readers,
</p>
<p>
Now more than ever, The Stranger depends on your support to help fund our coverage. Please consider supporting local, independent, progressive media with a one-time or recurring contribution. Our staff is working morning, noon, and night to make your contributions count.
</p>
<p>
Thank you and we are truly grateful for your support.
</p>
        <div class="text-right"><a href="/contribute" class="btn btn-danger btn-large">CONTRIBUTE NOW</a></div>
      </div>
    </div>
  

<div id="site-header" class="navbar navbar-default hidden-xs" role="navigation">
  <div id="top-nav">
    <div class="container">
      <div class="navbar-header">
        
        <a class="navbar-brand " href="https://www.thestranger.com/"><img src="https://www.thestranger.com/assets/sites/stranger/images/site-logo.png?2018-09-13-121404" alt="The Stranger"></a>
      </div> <!-- /.navbar-header -->

      <div class="navbar-collapse collapse">
        <ul id="nav-site" class="nav navbar-nav">
          <li id="nav-read" class="dropdown" style="margin-left:20px;">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">Things to Read <b class="caret"></b></a>
            <ul class="dropdown-menu" style="min-width:250px;">
              
              
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/slog" target="_self">
                    
                    <i class="fa fa-star"></i>
                    Slog: Seattle's Only Blog
                  </a>
                </li>
              
                

                

                

                <li class="highlighted last">
                  <a data-silo="ttr" href="https://www.thestranger.com/best-of-SLLOTD" target="_self">
                    
                    <i class="fa fa-star"></i>
                    The Best Savage Love Letters of the Day
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/" target="_self">
                    
                    
                    Home
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/savage-love" target="_self">
                    
                    
                    Savage Love
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/news" target="_self">
                    
                    
                    News
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/slog-ampm" target="_self">
                    
                    
                    Slog AM/PM
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/arts" target="_self">
                    
                    
                    Arts
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/unstreamable" target="_self">
                    
                    
                    Unstreamable
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="http://thestranger.com/currently-hanging" target="_self">
                    
                    
                    Currently Hanging
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/messagetothecity" target="_self">
                    
                    
                    Message to the City
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/sticker-patrol" target="_self">
                    
                    
                    Sticker Patrol
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/weed" target="_self">
                    
                    
                    Weed
                  </a>
                </li>
              
            </ul>
          </li>

          <li id="nav-do" class="dropdown">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">Things to Do <b class="caret"></b></a>
            <ul class="dropdown-menu" style="min-width:250px;">
              
                <li class="everout-nav-item">
                  <a href="https://everout.com/stranger-seattle">
                    <img src="https://www.thestranger.com/assets/sites/everout/everout-logo.png?20190815172027" width="65%;" alt="EverOut">
                  </a>
                </li>
              
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttd" href="https://www.thestranger.com/things-to-do" target="_self">
                    
                    <i class="fa fa-star"></i> 
                    Things To Do Home
                  </a>
                </li>

              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/?category=in-person" target="_self">
                    
                    <i class="fa fa-star"></i> 
                    In-Person Events
                  </a>
                </li>

              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/?category=livestreamed" target="_self">
                    
                    <i class="fa fa-star"></i> 
                    Livestreamed Events
                  </a>
                </li>

              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/?category=one-day-only" target="_self">
                    
                    <i class="fa fa-star"></i> 
                    One-Day-Only Events
                  </a>
                </li>

              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/?category=resistance" target="_self">
                    
                    <i class="fa fa-star"></i> 
                    Protests & Resistance Events
                  </a>
                </li>

              
                

                

                

                <li class="highlighted last">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/?category=bipoc" target="_self">
                    
                    <i class="fa fa-star"></i> 
                    BIPOC-Focused Events
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/locations/?feature=outdoor-dining&feature=dine-in" target="_self">
                    
                    
                    Dine-In & Outdoor Dining
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/locations/?category=restaurants&feature=takeout-covid-19&feature=delivery-covid-19&feature=curbside-pickup&feature=walk-up-ordering" target="_self">
                    
                    
                    Takeout & Delivery
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/locations/?feature=in-person-visits" target="_self">
                    
                    
                    Now-Open Shops & Attractions
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/locations/?category=weed-locations&feature=takeout-covid-19" target="_self">
                    
                    
                    Weed Locations
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/articles/stranger-everout-presents-eat-this/c146/" target="_self">
                    
                    
                    Eat This!
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/stranger-seattle/articles/retail-roundup-pike-place-market-edition/c132/" target="_self">
                    
                    
                    Retail Roundup: Pike Place Market
                  </a>
                </li>

              
            </ul>
          </li>
        </ul>

        

        <ul class="nav navbar-nav navbar-right">
          
            <style>
              
                .contribute-nav-item a {
                  color: blue!important
                }
              
              
                .contribute-nav-item a:hover {
                  color: black!important
                }
              
            </style>
            <li>
              <li class="non-dropdown contribute-nav-item">
                <a class="" data-context="desktop-nav" href="https://www.thestranger.com/contribute" target="_self">Support The Stranger</a>
              </li>
            </li>
          
          <li id="topNavAccountMenu" class="dropdown nav-account">
            <a href="#" class="link-icon dropdown-toggle" data-toggle="dropdown"><i class="fa fa-user-circle-o"></i></span></a>
            <ul class="dropdown-menu nav-account-menu">
              <li><a href="https://post.thestranger.com/login">Log in</a></li>
              <li><a href="https://post.thestranger.com/login/create">Sign up</a></li>
            </ul>
          </li>
          <li id="navbar-search">
            <a href="#" class="link-icon"><i class="fa fa-search"></i></a>
            <form action="/search" id="navbar-search-form" class="navbar-form" role="search" required>
              <input name="q" id="q" type="text" class="form-control" placeholder="Search" name="srch-term" id="srch-term">
            </form>
          </li>
          
          
          <script>
            $('#filter-search-more').click(function() {
              if(!$(this).hasClass('collapsed')) {
                $('.more-text',this).html('More');
                $('i.fa',this).removeClass('fa-caret-up').addClass('fa-caret-down');
              } else {
                $('.more-text',this).html('Less');
                $('i.fa',this).removeClass('fa-caret-down').addClass('fa-caret-up');
              }
            });
            $("#navbar-search a.link-icon").click(function(){
              $(this).closest('.navbar-right').toggleClass("search-open");
              $(this).siblings("#navbar-search-form").toggle();
              if($(this).closest('.navbar-right').hasClass('search-open')) {
                $(this).siblings("#navbar-search-form").find('.form-control').focus();
              }
              return false;
            });
          </script>
        </ul>
      </div><!--/.navbar-collapse -->
    </div><!-- /.container -->
  </div><!-- /#top-nav -->
</div><!-- /#site-header -->

<div id="mobile-header" class="navbar navbar-default visible-xs hidden-lg hidden-md" role="navigation">
  <div id="mobile-nav">
    









<header class="mobile-nav" role="banner">
  <div class="navbar-header">
    <button type="button" id="mobileNavToggle" class="navbar-toggle collapsed" data-toggle="collapse" data-target=".main-navigation" style="float:right;">
      <div class="navbar-toggle-closed-label">
        
          <span class="navbar-toggle-label-text">Menu</span>
        
        <i class="fa fa-bars"></i>
      </div>
      <div class="navbar-toggle-open-label">
        
          <span class="navbar-toggle-label-text">Close</span>
        
        <i class="fa fa-times"></i>
      </div>
    </button>
    
    <a class="navbar-brand " href="https://www.thestranger.com/"><img src="https://www.thestranger.com/assets/sites/stranger/images/site-logo.png?2018-09-13-121404" alt="The Stranger"></a>
  </div>
  <nav class="navbar-collapse main-navigation collapse" role="navigation" style="height: 1px;max-height:none;">
    <div class="container">
      <div class="row">
        <div class="col-xs-12">
          <form action="https://post.thestranger.com/search" class="navbar-form navbar-right" role="search">
            <div class="form-group input-group">
              <input type="text" class="form-control" name="q" placeholder="Search">
              <span class="input-group-btn">
                <button type="submit" class="btn btn-default"><i class="fa fa-search"></i></button>
              </span>
            </div>
          </form>
        </div>
      </div>
      <div class="row">
        <div class="col-xs-6" style="padding-right:0;">
          <ul class="nav navbar-nav">
            <li class="dropdown-header" style="padding-left:0;">Things To Read</li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/slog" target="_self">
                  <i class="fa fa-star"></i> 
                  
                  Slog: Seattle's Only Blog</a></li>
                </li>
              
                

                

                

                <li class="highlighted last">
                  <a data-silo="ttr" href="https://www.thestranger.com/best-of-SLLOTD" target="_self">
                  <i class="fa fa-star"></i> 
                  
                  The Best Savage Love Letters of the Day</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/" target="_self">
                  
                  
                  Home</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/savage-love" target="_self">
                  
                  
                  Savage Love</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/news" target="_self">
                  
                  
                  News</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/slog-ampm" target="_self">
                  
                  
                  Slog AM/PM</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/arts" target="_self">
                  
                  
                  Arts</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/unstreamable" target="_self">
                  
                  
                  Unstreamable</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="http://thestranger.com/currently-hanging" target="_self">
                  
                  
                  Currently Hanging</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/messagetothecity" target="_self">
                  
                  
                  Message to the City</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/sticker-patrol" target="_self">
                  
                  
                  Sticker Patrol</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/weed" target="_self">
                  
                  
                  Weed</a></li>
                </li>
              
            <li><a href="/issues">Print Archives</a></li>
          </ul>
        </div>
        <div class="col-xs-6">
          <ul class="nav navbar-nav">
            <li class="dropdown-header" style="padding-left:0;">Things To Do</li>

              
                

                

                

              <li class="highlighted">
                <a data-silo="ttd" href="https://www.thestranger.com/things-to-do" target="_self">
                <i class="fa fa-star"></i> 
                
                Things To Do Home</a></li>
              </li>

            
                

                

                

              <li class="highlighted">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/?category=in-person" target="_self">
                <i class="fa fa-star"></i> 
                
                In-Person Events</a></li>
              </li>

            
                

                

                

              <li class="highlighted">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/?category=livestreamed" target="_self">
                <i class="fa fa-star"></i> 
                
                Livestreamed Events</a></li>
              </li>

            
                

                

                

              <li class="highlighted">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/?category=one-day-only" target="_self">
                <i class="fa fa-star"></i> 
                
                One-Day-Only Events</a></li>
              </li>

            
                

                

                

              <li class="highlighted">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/?category=resistance" target="_self">
                <i class="fa fa-star"></i> 
                
                Protests & Resistance Events</a></li>
              </li>

            
                

                

                

              <li class="highlighted last">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/events/?category=bipoc" target="_self">
                <i class="fa fa-star"></i> 
                
                BIPOC-Focused Events</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/locations/?feature=outdoor-dining&feature=dine-in" target="_self">
                
                
                Dine-In & Outdoor Dining</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/locations/?category=restaurants&feature=takeout-covid-19&feature=delivery-covid-19&feature=curbside-pickup&feature=walk-up-ordering" target="_self">
                
                
                Takeout & Delivery</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/locations/?feature=in-person-visits" target="_self">
                
                
                Now-Open Shops & Attractions</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/locations/?category=weed-locations&feature=takeout-covid-19" target="_self">
                
                
                Weed Locations</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/articles/stranger-everout-presents-eat-this/c146/" target="_self">
                
                
                Eat This!</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/stranger-seattle/articles/retail-roundup-pike-place-market-edition/c132/" target="_self">
                
                
                Retail Roundup: Pike Place Market</a></li>
              </li>

            
          </ul>
        </div>
      </div>
      <div class="row">
        
          <div class="col-xs-6">
            <ul class="nav navbar-nav">
              <li class="dropdown-header" style="padding-left:0;">Other Things</li>
              
                <li><a href="https://www.thestranger.com/contribute" target="_self">Support The Stranger</a></li>
              
                <li><a href="https://www.thestranger.com/ad-info" target="_self">Ad Info & Rates</a></li>
              
                <li><a href="http://www.strangertickets.com" target="_blank">Stranger Tickets</a></li>
              
            </ul>
          </div>
        
        <div id="mobileNavAccountMenu" class="col-xs-6 nav-account">
          <ul class="nav navbar-nav nav-account-menu">
            <li class="dropdown-header" style="padding-left:0;">Account</li>
            <li><a href="https://post.thestranger.com/login">Log in</a></li>
            <li><a href="https://post.thestranger.com/login/create">Sign up</a></li>
          </ul>
        </div>
      </div>
    </div> <!-- end container -->
  </nav>
  <script>
    $('#mobileNavToggle').click(function() {
      var menuAction = $(this).hasClass('collapsed') ? 'openMenu' : 'closeMenu';
      ga('send', {
        hitType: 'event',
        eventCategory: 'MobileNav',
        eventAction: ''+menuAction+''
      });
      $(this).toggleClass('collapsed');
    });
    $('.mobile-nav .nav li a').click(function() {
      var navLabel = $(this).data('silo')+'-'+$(this).text();
      ga('send', {
        hitType: 'event',
        eventCategory: 'MobileNav',
        eventAction: 'click',
        eventLabel: ''+navLabel+''
      });
    });
  </script>
</header>

  </div>
</div>
      <div class="top-super text-center component container">
  <div id="div-gpt-ad-top-super"></div>
  <div id="div-gpt-ad-mobile-top"></div>
</div>
      <div id="siteContent" class="container">
        <div class="row" class="main">
          <div class="col-sm-12 col-md-8 primary">
  
  <div id="articleComponent-44479076" class="component">

    

     <div class="blog-header slog">
  <h1><a href="https://www.thestranger.com/slog"><img id="slogLogo" src="" class="img-responsive slog-logo"></a></h1>
</div>
    
    
    <div id="article-44479076" class="article coll_news">
      <div id="article-header-44479076" class="article-header">
        
          <div class="post-tags-and-date">
            
              <div class="label topic">
                
                  <a href="https://www.thestranger.com/archive/news">News</a>
                  
                
              </div>
            
          </div>
        
        <h1 class="headline">
          Skyway Wins Big in the Proposed County Budget, For Once
          
        </h1>
        <h2 class="subheadline">
          
        </h2>
        <div class="byline">
          
            by <a href="https://www.thestranger.com/authors/19407358/rich-smith">Rich Smith</a>
            
              &bull;
            
          
          
            <span class="post-time">
              Sep 22, 2020 at  1:30 pm
            </span>
          
        </div>
        
        
        
          
        
      </div> <!-- end .article-header -->

      <div class="article-text category-slog">
        
        

        <div class="social-tools text-right" style="margin-bottom:10px;position:relative;">
          
          <div class="fb-like"
            data-href="https://www.thestranger.com/slog/2020/09/22/44479076/skyway-wins-big-in-the-proposed-county-budget-for-once"
            data-layout="button_count"
            data-action="like"
            data-show-faces="true"
            data-share="true" style="margin-right:10px;position:relative;top:-5px;"></div>
          
          <a class="twitter-share-button" href="https://twitter.com/share"
            data-url="https://www.thestranger.com/slog/2020/09/22/44479076/skyway-wins-big-in-the-proposed-county-budget-for-once"
            data-text="Skyway Wins Big in the Proposed County Budget, For Once">
          Tweet
          </a>
          <script>
          window.twttr=(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],t=window.twttr||{};if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);t._e=[];t.ready=function(f){t._e.push(f);};return t;}(document,"script","twitter-wjs"));
          </script>
          <a style="position:relative;top:-5px;" href="//www.reddit.com/submit?url=https%3A//www.thestranger.com/slog/2020/09/22/44479076/skyway-wins-big-in-the-proposed-county-budget-for-once" target="_blank"><img src="//www.redditstatic.com/spreddit5.gif" alt="submit to reddit" border="0" /></a>
        </div>

        

        
        

        
        
        
        
        
          
          
          
          
          
          
            
            
            
            
              
              <div class="blogImageCenter img-responsive" style=""><img src="https://media2.fdncms.com/stranger/imager/u/large/44857643/1600733716-img_0397.jpg" alt="The states only Black county council member went to bat for the states Blackest neighborhood. Right now, it looks like hes winning." title="The states only Black county council member went to bat for the states Blackest neighborhood. Right now, it looks like hes winning. "><div class="image-caption-and-credit"><span class="imageCaption">The state's only Black county council member went to bat for the state's Blackest neighborhoods. Right now, it looks like he's winning. </span> <span class="imageCredit">Quinn Russell Brown </span></div></div><br />King County Councilmember Girmay Zahilay has been talking up the need to invest in Skyway since the second he walked into office earlier this year. </p>
              
            
              
               <p>His argument is simple. Skyway, an unincorporated area between Seattle and Renton situated at the southern tip of his district, is home to the highest proportion of African Americans in the state. If Black Lives Matter, then Skyway matters. And if Skyway matters, then King County should reflect that fact in its $12 billion biennial budget. </p>
              <div class="row fish-butter article-inline-native-wrapper" data-context-oid="44387674" data-ad-oid="44387673">

      <div class="fish-tag row article-inline-native-tag">
          Sponsored
      </div>

      <div class="row">
        <div class="col article-inline-native-inner-wrapper">
          

          
            <div class="col-xs-3 article-inline-native-image">
              <a href="https://post.thestranger.com/seattle/clickclick?adoid=44387673&poid=44387674&url=https%3A//post.spl.org/31Cj1Q3" class="image-link" rel="nofollow">
                <img src="https://media1.fdncms.com/stranger/imager/u/original/44387672/original-lcsum_200x150.jpg" class="img-fluid">
              </a>
            </div>
          

          
          <div class="col-xs-9">
            <div class="row article-inline-native-headline">
              <a href="https://post.thestranger.com/seattle/clickclick?adoid=44387673&poid=44387674&url=https%3A//post.spl.org/31Cj1Q3" rel="nofollow">
                Library Curbside Pickup Service is Now Available!
              </a>
              
            </div>

            
              <div class="row article-inline-native-body">
                Place holds online, then schedule a time to pick up at select locations by mobile app or phone.
              </div>
            
          </div>
          
        </div>
      </div>
    </div>
            
              
               <p>Zahilay has argued this point in the op-ed pages of the <em><a href="http://www.seattletimes.com/opinion/we-failed-the-central-district-but-we-can-do-right-by-skyway/">Seattle Times</a></em>, <em><a href="http://crosscut.com/opinion/2020/09/black-lives-matter-wa-skyway-has-matter">Crosscut</a></em>, and <em><a href="http://publicola.com/2020/09/16/girmay-zahilay-in-november-a-chance-to-begin-rebuilding-public-safety-from-the-ground-up/">PubliCola</a></em>. He emphasized the point in remote town halls with Skyway residents and King County budget director Dwight Dively. And when I joined Zahilay for an interview outside the Skyway Grocery Outlet last month, he stayed on-message for a solid two hours as he handed out county-issued cloth masks to shoppers. </p>
              
            
              
               <p>Judging by the substantial funds King County Executive Dow Constantine directed to the area in his proposed budget, Zahilay's advocacy appears to have paid off. For now.</p>
              
            
              
              
          <a name="more"></a>
          <div class="blogImageCenter img-responsive" style=""><img src="https://media1.fdncms.com/stranger/imager/u/large/44859964/1600734909-img_0399.jpg" alt="The county gave Zahilay  24,000 masks to distribute to his district. He handed out a whole box outside the Skyway Grocery Outlet last month." title="The county gave Zahilay  24,000 masks to distribute to his district. He handed out a whole box outside the Skyway Grocery Outlet last month. "><div class="image-caption-and-credit"><span class="imageCaption">You can't tell from this picture, but chances are Zahilay is talking about Skyway.</span> <span class="imageCredit">Courtesy of Girmay Zahilay's office </span></div></div><br /><big><strong>"I Lived in Morrowind" </strong></big></p>
              <div class="interstitial-ad-1 ad pull-right">
                      <div id="div-gpt-ad-mobile-inline-1" class="interstitial-ad  inline-ad"></div>
                    </div>
            
              
               <p>When Zahilay moved to Skyway as a freshman in high school, he spent a lot of his free time in Morrowind, an expansive province that serves as the setting for the third installment of Bethesda's hit fantasy RPG series, <em>The Elder Scrolls.</em></p>
              
            
              
               <p>Zahilay played high-quality immersive video games during his summers and holidays because "there was nothing else to do," he said. Years ago, back when he lived up the road in New Holly, he hung out in community centers, bused around town, and walked to the park. But the moment he landed in Skyway he felt "trapped." His choices for hang-out spots were restricted to a parking lot, a bowling alley, the parking lot of a bowling alley, or Morrowind. A lot of the time, he chose Morrowind. </p>
              
            
              
               <p>Other kids in town made other choices and wound up on the wrong track, "especially if they were like me," Zahilay said. </p>
              
            
              
               <p>"My mom had to work three jobs, so she wasn’t home all the time. We were just kids without much structure around us," he added. "And then we wonder why our youth do stuff we don’t want them to. It’s because we haven’t invested in them the way we should." </p>
              
            
              
               <p><big><strong>What Happened to Skyway? </strong></big></p>
              <div class="interstitial-ad-2 ad pull-right">
                      <div id="div-gpt-ad-mobile-inline-2" class="interstitial-ad  inline-ad"></div>
                    </div>
            
              
               <p>The state's Growth Management Act encourages unincorporated areas to join nearby cities so they don't end up like Skyway, a place reliant solely on the county for resources and representation. For years King County "encouraged" Skyway to join Renton by just not funding big housing and transportation projects in the area. Making such long-term investments would risk accruing debt they'd prefer Renton to take on, Zahilay said. </p>
              
            
              
               <p>As a result, Skyway lacks a lot of the essential services they need to thrive. They have, for instance, basically no east-to-west transportation and very little north-to-south transportation. Zahilay said the King County Department of Community and Human Services couldn't tell him when they last invested in affordable housing in the area. "Not in the past five years, not in the past ten years," he said. </p>
              
            
              
               <p>Zahilay said he has a name for this persistent lack of investment in the area where the state's largest proportion of African Americans live: "systematic racism." </p>
              
            
              
               <p>"This is not secret stuff," Zahilay added. "But that’s why Skyway is the way it is." </p>
              
            
              
               <p><big><strong>Skyway or the Highway </strong></big></p>
              <div class="interstitial-ad-3 ad pull-right">
                      <div id="div-gpt-ad-mobile-inline-3" class="interstitial-ad  inline-ad"></div>
                    </div>
            
              
               <p>So when the people of District 2 elected him to serve, the hometown hero aimed to put the full force of his office behind elevating their needs. </p>
              
            
              
               <p>In the last nine months Zahilay has spearheaded policy to down-zone some areas of Skyway and to add some affordable housing requirements in others to "slow down the gentrification process" that continues to push people of color outside the city. He also helped <a href="http://www.thestranger.com/slog/2020/07/01/43994517/a-massive-wave-of-evictions-will-probably-hit-washington-next-month">pass</a> an ordinance that adds a legal protection for residential and commercial tenants facing eviction in unincorporated King County, as well as another bill that directs law enforcement to connect minors to public defenders before they waive their Miranda rights. </p>
              
            
              
               <p>These legislative wins will help on the margins, but Zahilay dreamed a little bigger when it came to the 2021-22 budget. Last month he said he and the community wanted to see "tens of millions in investment into affordable housing," plus $15 million for a community center to give neighborhood kids some place to go. The budget proposal Constantine handed down today didn't quite deliver all that, but Zahilay said he's pleased with the results so far. </p>
              
            
              
               <p>Constantine's proposal includes $10 million in seed money for a Skyway Community Center and $10 million for "new capital projects" in unincorporated areas, including Skyway, White Center, Fairwood, East Federal Way, and East Renton. Rather than telling residents how to spend that $10 million, the county will invite community leaders to make the decisions for the area through a participatory budgeting process. </p>
              
            
              
               <p>On top of that, Constantine plans to direct $6 million for new bus service in Skyway, "to be co-created with community." </p>
              <div class="interstitial-ad-4 ad pull-right">
                      <div id="div-gpt-ad-mobile-inline-4" class="interstitial-ad  inline-ad"></div>
                    </div>
            
              
               <p>To address community demands for police reform, Constantine proposes moving $4.6 million in marijuana tax revenue from law enforcement to "community-based programs in King County" and directing $750,000 towards Skyway and White Center to design alternative systems of public safety, which could "involve hiring behavioral health professionals to partner with Sheriff’s Office Deputies and divert cases from criminal courts and jails." </p>
              
            
              
               <p>Zahilay credits the work of Choose 180, Community Passageways, Creative Justice, and the recent wave of Black Lives Matter protests for foregrounding the need for major police reform and meaningful financial investments in Black communities. </p>
              
            
              
               <p>As part of his mission to uplift those voices, Zahilay hosted a couple community budget workshops between those nonprofit directors, residents of Skyway, and King County Budget Director Dwight Dively. At these meetings Dively outlined the county's general fund spending and expected revenues, and then opened up the floor for various community members and organizers to state their priorities. If you want to watch Nikkita Oliver advance a pretty solid argument for defunding/reinvesting, do yourself a favor and <a href="http://www.facebook.com/watch/live/?v=3640038002695385&ref=watch_permalink">watch the recording</a> of that meeting. </p>
              
            
              
               <p>Those meetings served primarily to increase transparency in the budgeting process for Skyway residents, but in the future Zahilay wants to launch a participatory budgeting process so the community can decide how to spend the money themselves. Constantine's proposed budget opens the door for that to happen. </p>
              
            
              
               <p><big><strong>The Future </strong></big></p>
              
            
              
               <p>All this good news for Skyway is, of course, provisional. The council will now hold several budget meetings, where they'll very politely try to direct as much money as possible to their own districts. With a smaller pie (thanks again, COVID) tensions could run high and Zahilay will have to play defense. But he's got a pretty good argument for maintaining those allocations, and it's well-rehearsed. </p>
              
            
              
               <p>The budget's big, but it's only the beginning. </p>
              <div class="fish-butter article-inline-native" data-context-oid="41865158" data-ad-oid="41865157">
      <h3 class="article-inline-text">
        <a href="https://post.thestranger.com/seattle/clickclick?adoid=41865157&poid=41865158&url=https%3A//www.thestranger.com/contribute" target="_blank" rel="nofollow">
          Support <em>The Stranger</em>
        </a>
      </h3>
      <div>
        <a href="https://post.thestranger.com/seattle/clickclick?adoid=41865157&poid=41865158&url=https%3A//www.thestranger.com/contribute" target="_blank" rel="nofollow" style="font-size:1rem;font-weight:normal;">
          More than ever, we depend on your support to help fund our coverage. Support local, independent media with a  one-time or recurring donation. Thank you!
        </a>
      </div>
    </div>
            
              
               <p>Zahilay said the county's investments in Skyway would help small businesses and families avoid the negative impacts of gentrification, but until they can stand up adequate defenses against mass displacement, the battle against gentrification will happen on a building by building basis. The owner of the Skyway Park Shopping Center, for instance, recently put the place up for <a href="http://ccmcommercial.com/wp-content/uploads/2017/02/Skyway-Park-Shopping-Center-VFlyer.pdf">sale.</a> Before a developer swoops in, Zahilay said his office hopes to work with the tenants to buy the property and establish collective ownership of the building. "Nothing is concrete yet, but if we can do it, then that’s 8 or 9 small black businesses saved for a generation," he said. </p>
              
            
              
               <p>He's also hoping King County voters pass all seven county charter amendments in November, many of which will set the stage for meaningful reforms to the sheriff's office and the criminal justice system, which accounts for 75% of the county's general fund spending.   </p>
              
            
              
               <p>The King County Charter Review Commission recommended <a href="http://www.kingcounty.gov/~/media/independent/charter-review-commission/2020/Approved_KC_CRC_Report_-_Full.ashx?la=en">all of those measures </a>except for  King County Charter Amendment No. 6, which Zahilay and King County Councilmember Rod Dembowski proposed. That amendment would give the council authority to change the duties of the sheriff's office, as it had before 1996. Instead of sending gun-toting officers, Zahilay would prefer to send bike brigades to manage traffic during protests, and he'd rather send mental health professionals to conduct wellness checks. But unless voters approve Amendment 6 in November, the charter forbids the council from taking such actions. </p>
              
            
              
               <p>He's also working on transferring two parcels of land down the street from the Columbia City light rail station to a community land trust. The plan, which is responsive to one of King Count Equity Now's <a href="http://www.kingcountyequitynow.com/">demands</a>, is to build a Youth Achievement Center with free housing and programming for kids without stable housing in South Seattle. </p>
              
            
              
               <p>Sound Transit owns the property, which has sat empty and fenced-off for over a decade. The agency wanted to transfer the property to the Seattle Office of Housing as part of an initiative to promote homeownership, but Zahilay said communities the office engaged with around that issue said they’d prefer a youth center with housing, instead. </p>
              
            
              
               <p>The hitch: Right now, federal law requires ST to transfer the property to another public agency in order to extinguish the debt the agency required when it bought the land from the government. So that law needs to change. Zahilay said U.S. House Rep. Adam Smith and Senators Patty Murray and Maria Cantwell hope to work that change into the CARES package.</p>
              
            
              
               <p>And of course, Zahilay also plans to push the state legislature to grant the county authority to tax big businesses. Otherwise, the county will just keep leaning into property taxes and sales taxes to pay for needed services, which puts them in the position of creating programs to serve people in need while also taxing those people to death. But with a special session unlikely, he'll have to wait until January to have a shot at even trying to make that become a reality.</p>
              
            
           

        

        
        

        

        

        
          <div class="row fish-butter article-inline-native-wrapper" data-context-oid="44470790" data-ad-oid="44470789">

      <div class="fish-tag row article-inline-native-tag">
          Sponsored
      </div>

      <div class="row">
        <div class="col article-inline-native-inner-wrapper">
          

          
            <div class="col-xs-3 article-inline-native-image">
              <a href="https://post.thestranger.com/seattle/clickclick?adoid=44470789&poid=44470790&url=https%3A//bit.ly/33cI4ZJ" class="image-link" rel="nofollow">
                <img src="https://media2.fdncms.com/stranger/imager/u/original/44470788/original-flu-display-ads-v3_200x150.png" class="img-fluid">
              </a>
            </div>
          

          
          <div class="col-xs-9">
            <div class="row article-inline-native-headline">
              <a href="https://post.thestranger.com/seattle/clickclick?adoid=44470789&poid=44470790&url=https%3A//bit.ly/33cI4ZJ" rel="nofollow">
                Practice safe flu shots.
              </a>
              
            </div>

            
              <div class="row article-inline-native-body">
                ZOOM+Care makes flu shots easy and safe. Schedule ahead, skip the line—get in and out in 5 minutes.
              </div>
            
          </div>
          
        </div>
      </div>
    </div>
        

      </div> <!-- end .article-text -->
      
      
        
          <div id="mc_embed_signup" style="padding: 30px 10px; background:#fff;font:15px Georgia,serif;width:100%; font-weight: normal; text-align: center;">
<form action="https://thestranger.us4.list-manage.com/subscribe?u=739a0d2f2ff0031156e7b3d55&amp;id=f02129603b" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" target="_blank" novalidate="">
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL" style="font-weight: normal; padding: 5px;">To get this delivered to your inbox, subscribe to <i>The Stranger</i>'s Slog AM newsletter.</label>
<div class="input-group" style=" width=100%; max-width:400px; margin: 0 auto;">
<input type="hidden" name="group[19329][4]" value="checked">
<input class="form-control" type="email" value="" name="EMAIL" id="mce-EMAIL" placeholder="email address" required="" style="border-radius: 4px;border-bottom-right-radius: 0;border-top-right-radius: 0;">
<div style="position: absolute; left: -5000px;" aria-hidden="true">
<input type="text" name="b_739a0d2f2ff0031156e7b3d55_67f93c78f9" tabindex="-1" value=""></div>
<span class="input-group-btn"><button class="btn btn-default" style="font-weight: normal;" type="submit" value="Subscribe" name="subscribe">Subscribe</span></div></div></form></div>
        
      
    </div> <!-- end .article -->

    <!-- article-contribution-footer -->
    
    
      <div class="article-contribution-footer">
        <em>The Stranger</em> depends on your continuing support to provide articles like this one. In return, we pledge our ongoing commitment to truthful, progressive journalism and serving our community. So if you’re able, please consider a small recurring contribution. Thank you—you are appreciated!
        <div style="margin-top:1rem;"><a href="/contribute" class="btn btn-danger btn-large">CONTRIBUTE NOW</a></div>
      </div>
    
    <!-- article-contribution-footer -->

    

    <div class="row social-tools" style="margin-top:1.5em; clear:both;">
      <div class="col-xs-12 col-sm-5 text-center lg-social-btn">
        <a href="http://www.facebook.com/sharer.php?u=https%3A//www.thestranger.com/slog/2020/09/22/44479076/skyway-wins-big-in-the-proposed-county-budget-for-once&amp;t=Skyway+Wins+Big+in+the+Proposed+County+Budget%2C+For+Once" target="_blank" onclick="window.open(this.href, '_blank', 'toolbar=no, scrollbars=auto, resizable=yes, top=250, left=250, width=500, height=500'); return false;"><img class="img-responsive" src="/images/social/share-on-facebook.png" alt="Share on Facebook" style=""></a>
      </div>
      <div class="col-xs-12 col-sm-5 text-center lg-social-btn">
        <a href="http://twitter.com/intent/tweet?&amp;url=https%3A//www.thestranger.com/slog/2020/09/22/44479076/skyway-wins-big-in-the-proposed-county-budget-for-once&amp;text=Skyway+Wins+Big+in+the+Proposed+County+Budget%2C+For+Once&amp;related=strangerslog" target="_blank" onclick="window.open(this.href, '_blank', 'toolbar=no, scrollbars=auto, resizable=yes, top=250, left=250, width=500, height=500'); return false;"><img class="img-responsive" src="/images/social/share-on-twitter.png" alt="Share on Twitter" style=""></a>
      </div>
      
        <div class="col-xs-12 col-sm-2 text-center" style="padding-bottom:0.2em;">
          <h3 style="margin-top:5px;">
            
              <a href="/slog/2020/09/22/44479076/skyway-wins-big-in-the-proposed-county-budget-for-once/comments" rel="nofollow"><i class="fa fa-comment"></i> <span class="comment-count">1</span></a>
            
          </h3>
        </div>
      
    </div>

    
    
      <div class="article-bio-wrapper">
        
          
          
            <div class="article-author-bio">

              <div class="row clearfix visible-xs">
      <div class="col-xs-12">
        
          <div class="author-bio-image pull-right">
            <img src="https://media2.fdncms.com/stranger/imager/u/large/37802013/rich_final.jpeg" class="img-responsive">
          </div>
        
        <h4 class="author-bio-name"><b>Rich Smith</b></h4>
        
          <p>Rich Smith writes about politics, books, and performance for The Stranger. You can hear his impersonations of Bernie Sanders and Jeff Sessions on Blabbermouth, and you can read his poems at <a href="https://richsmithpoetry.com/">www.richsmithpoetry.com</a></p>
        
        <div class="author-social-links pull-left">
          
            <a href="https://www.twitter.com/richsssmith" class="author-link btn btn-default"><i class="fa fa-twitter" title="Twitter"></i> Follow</a>
          
          
            <a href="mailto:rsmith@thestranger.com" class="author-link btn btn-default"><i class="fa fa-envelope" title="Email"></i> Email</a>
          
          
            <a href="https://www.thestranger.com/authors/19407358/rich-smith" class="author-link btn btn-default">More articles</a>
          
          
        </div>
      </div>
    </div>

    
    <div class="row clearfix hidden-xs">
      
        <div class="col-sm-3">
          <div class="author-bio-image">
            <img src="https://media2.fdncms.com/stranger/imager/u/large/37802013/rich_final.jpeg" class="img-responsive">
          </div>
        </div>
      
      
      <div class="col-sm-9">
        <h2 class="author-bio-name">Rich Smith</h2>
        
          <p>Rich Smith writes about politics, books, and performance for The Stranger. You can hear his impersonations of Bernie Sanders and Jeff Sessions on Blabbermouth, and you can read his poems at <a href="https://richsmithpoetry.com/">www.richsmithpoetry.com</a></p>
        
        <div class="author-social-links">
          
            <a href="https://www.twitter.com/richsssmith" class="author-link btn btn-default"><i class="fa fa-twitter" title="Twitter"></i> Follow</a>
          
          
            <a href="mailto:rsmith@thestranger.com" class="author-link btn btn-default"><i class="fa fa-envelope" title="Email"></i> Email</a>
          
          
            <a href="https://www.thestranger.com/authors/19407358/rich-smith" class="author-link btn btn-default">More articles</a>
          
          
        </div>
      </div>
    </div>
            </div>
          
        
      </div>
    

    
      

      
    

    <div class="component related-content" style="padding:1em 0; border-bottom:1px solid #ddd; margin-bottom:1em;">
        <h2 style="margin:0 0 0.5em; padding-top: 25px; border-top: 1px solid #ddd">You might also be interested in these:</h2>
        
        
        <div class="related-content-row" style="padding:0.5em 0;">
        
          <h3 class="headline">
            <a href="https://www.thestranger.com/slog/2020/09/22/44849628/will-council-members-vote-against-their-own-budget-to-save-face" rel="nofollow">Will Council Members Vote Against Their Own Budget to Save Face?</a>
          </h3>
          
          
            <div class="byline">
              by <a href="https://www.thestranger.com/authors/25618826/nathalie-graham">Nathalie Graham</a>
            </div>
          
        
      </div>
        
      
        
        <div class="related-content-row" style="padding:0.5em 0;">
        
          <h3 class="headline">
            <a href="https://www.thestranger.com/slog/2019/10/17/41720527/every-unstreamable-film-weve-blurbed-so-far" rel="nofollow">A Big List of Unstreamable Movies</a>
          </h3>
          
            <h4 class="subheadline">
              Turn off the internet and touch some tapes.
            </h4>
          
          
            <div class="byline">
              by <a href="https://www.thestranger.com/authors/24744263/chase-burns">Chase Burns</a> and <a href="https://www.thestranger.com/authors/32434319/jasmyne-keimig">Jasmyne Keimig</a>
            </div>
          
        
      </div>
        
      
        
        <div class="related-content-row" style="padding:0.5em 0;">
        
          <h3 class="headline">
            <a href="https://www.thestranger.com/slog/2020/09/22/44925521/new-savage-lovecast-with-247-submissive-goddess-lina-dune" rel="nofollow"><strong>New Savage Lovecast:</strong> With 24/7 Submissive Goddess Lina Dune</a>
          </h3>
          
          
            <div class="byline">
              by <a href="https://www.thestranger.com/authors/707628/the-stranger">The Stranger</a>
            </div>
          
        
      </div>
        
      
          </div>

    <br>
    <div id="div-gpt-ad-mobile-bottom" class="interstitial-ad"></div>
    <div id="div-gpt-ad-bottom" class="interstitial-ad"></div>
    

  </div> <!-- end component -->
</div>
<div class="col-sm-12 col-md-4 secondary">
  <!-- stranger content sidebar ads -->
<div class="article-sidebar sidebar-ads text-right">
  
    <div class="sidebar-ad-1">
      <div id="div-gpt-ad-sidebar-1" class="sidebar-ad"></div>
    </div>
  
    <div class="sidebar-ad-2">
      <div id="div-gpt-ad-sidebar-2" class="sidebar-ad"></div>
    </div>
  
    <div class="sidebar-ad-3">
      <div id="div-gpt-ad-sidebar-3" class="sidebar-ad"></div>
    </div>
  
    <div class="sidebar-ad-4">
      <div id="div-gpt-ad-sidebar-4" class="sidebar-ad"></div>
    </div>
  
</div>
</div>
        </div>
        <div class="row">
          <div class="col-sm-12">
            <div class="bottom-super text-center">
  <div id="div-gpt-ad-bottom-super" class="gpt-dfp"></div>
</div>
          </div>
        </div>
      </div><!-- /#siteContent -->
      <div id="site-footer">
        <div class="hidden-xs hidden-sm">
  <div id="footer-features">
    <div class="container">
      <div class="footer-row">
        
            
          
          
          <div class="col-md-2 text-center" style="width:25%;">
            <i class="fa fa-envelope"></i>
            <h4><a href="/newsletters">Newsletters</a></h4>
            <p>Sign up for the latest news and to win free tickets to events</p>
          </div>
        
          
          <div class="col-md-2 text-center" style="width:25%;">
            <i class="fa fa-ticket"></i>
            <h4><a href="http://www.strangertickets.com">Stranger Tickets</a></h4>
            <p>Buy tickets to events around Seattle</p>
          </div>
        
          
          <div class="col-md-2 text-center" style="width:25%;">
            <i class="fa fa-calendar"></i>
            <h4><a href="/things-to-do">EverOut<br>Things To Do</a></h4>
            <p>Comprehensive calendar of Seattle events</p>
          </div>
        
          
          <div class="col-md-2 text-center" style="width:25%;">
            <i class="fa fa-mobile"></i>
            <h4><a href="/thingstodoapp">EverOut App</a></h4>
            <p>The easiest way to find Seattle's best events</p>
          </div>
        
      </div>
    </div>
  </div>
</div><!-- footer (hidden-xs hidden-sm) -->

      
        







<div class="hidden-xs hidden-sm">
  <div id="footer-features-2">
    <div class="container">
      <div class="footer-row">
        <div class="col col-md-4 text-center">
          <h4>Publication Info</h4>
            <ul class="list-unstyled">
              <li><a href="https://www.thestranger.com/masthead">Masthead</a></li>
              <li><a href="https://www.thestranger.com/ad-info">Ad Info &amp; Rates</a></li>
              
                <li><a href="https://www.thestranger.com/distribution">Distribution</a></li>
              
              <li><a href="https://www.thestranger.com/jobs">Jobs at The Stranger</a></li>
              <li><a href="https://www.thestranger.com/contact-information">Contact</a></li>
              <li><a href="https://everout.com/">EverOut</a></li>
              <li><br></li>
              <li><a href="https://www.thestranger.com/contribute">Contribute</a></li>
            </ul>
        </div>
        <div class="col col-md-4 text-center" style="border-right: solid 1px white; border-left: solid 1px white;">
          <h4>Check it out</h4>
          
            <div class="footer-promo" id="" style="margin-left:0">
              <a href="https://www.savagelovecast.com">
                
                  <img src="https://media1.fdncms.com/stranger/imager/u/original/39759989/savagelovecast.jpg" alt="Savage Lovecast">
                
              </a>
            </div>
          
            <div class="footer-promo" id="" style="margin-left:0">
              <a href="http://www.cocktailcompass.com">
                
                  <img src="https://media2.fdncms.com/stranger/imager/u/original/39759990/cocktailcompass-188x80.png" alt="Cocktail Compass">
                
              </a>
            </div>
          
            <div class="footer-promo" id="" style="margin-left:0">
              <a href="/promotions">
                
                  <img src="https://media1.fdncms.com/stranger/imager/u/original/39759991/checkitout_button-contests.png" alt="The Stranger Promotions">
                
              </a>
            </div>
          
        </div>
        <div class="col col-md-4 text-center">
          <h4>Follow Us</h4>
          
              <ul id="footer-social-links" class="list-unstyled text-left">
            
            
            <li><a href="/syndication" target="_blank"><i class="fa fa-rss"></i> RSS</a></li>
            
          
            
            <li><a href="http://www.facebook.com/strangerseattle" target="_blank"><i class="fa fa-facebook"></i> Facebook</a></li>
            
          
            
            <li><a href="/twitter" target="_blank"><i class="fa fa-twitter"></i> Twitter</a></li>
            
          
            
            <li><a href="http://instagram.com/thestrangerseattle" target="_blank"><i class="fa fa-instagram"></i> Instagram</a></li>
            
          
              </ul>
            
        </div>
      </div>
    </div>
  </div>
</div><!-- footer (hidden-xs hidden-sm) -->

      
        

<div class="hidden-xs hidden-sm">
  <div id="footer-copyright">
    <div class="container">
      <div class="footer-row">
        <div class="col-md-6">
          <div class="footer-brand">
            
              <a href="https://www.thestranger.com/"><img src="https://www.thestranger.com/assets/sites/stranger/images/site-logo.png?2018-09-13-121404" alt="The Stranger"></a>
            
          </div>
          
          <p class="footer-copyright">
            
              All contents &copy; Index Newspapers LLC<br>
800 Maynard Ave S, Suite 200, Seattle, WA 98134
            
          </p>
        </div>
        <div class="col-md-6">
          <p class="footer-links text-right">
            <a href="https://www.thestranger.com/contact-information">Contact</a>
            <span class="lighter separater">|</span>
            <a href="https://www.thestranger.com/privacy-policy">Privacy Policy</a>
            <span class="lighter separater">|</span>
            <a href="https://www.thestranger.com/terms-of-use">Terms of Use</a>
            <span class="lighter separater">|</span>
            <a href="https://www.thestranger.com/takedown-policy">Takedown Policy</a>
          </p>
        </div>
      </div>
    </div>
  </div>
</div> <!-- footer (hidden-xs hidden-sm) -->

      
        

<div id="footer-mobile"  class="hidden-md hidden-lg">
  <div class="container">
    <div class="footer-row">
      <div class="col-sm-12 text-center">
        <div id="footer-mobile-social-links">
          
            <a href="/syndication" target="_blank"><i class="fa fa-rss"></i></a>
          
            <a href="http://www.facebook.com/strangerseattle" target="_blank"><i class="fa fa-facebook"></i></a>
          
            <a href="/twitter" target="_blank"><i class="fa fa-twitter"></i></a>
          
            <a href="http://instagram.com/thestrangerseattle" target="_blank"><i class="fa fa-instagram"></i></a>
          
        </div>
        <div class="footer-brand">
          
            <a href="https://www.thestranger.com/"><img src="https://www.thestranger.com/assets/sites/stranger/images/site-logo.png?2018-09-13-121404" alt="The Stranger"></a>
          
        </div>
        
        <p class="footer-copyright">
          
            All contents &copy; Index Newspapers LLC<br>
800 Maynard Ave S, Suite 200, Seattle, WA 98134
          
        </p>
        <p class="footer-links">
          <small>
            <a href="https://www.thestranger.com/contact-information">Contact</a> |
            <a href="https://www.thestranger.com/privacy-policy">Privacy Policy</a> |
            <a href="https://www.thestranger.com/terms-of-use">Terms of Use</a> |
            <a href="https://www.thestranger.com/takedown-policy">Takedown Policy</a>
          </small>
        </p>
      </div>
    </div>
  </div>
</div> <!-- /footer-mobile -->
      </div> <!-- /#site-footer -->
    </div> <!-- /.wrapper -->
    <!-- content background ad -->
<div id="div-gpt-ad-background"></div>

      
        


 


















<script>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</script>








<div id="fb-root"></div>

  <script>
    window.fbAsyncInit = function() {
      FB.init({
        appId      : '43933993878',
        xfbml      : true,
        version    : 'v2.6'
      });
    };
  </script>

<script>(function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
    fjs.parentNode.insertBefore(js, fjs);
  }(document, 'script', 'facebook-jssdk'));</script>


<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-332219-1', 'auto');
  ga('require', 'linkid', 'linkid.js');
  ga('set', 'anonymizeIp', true);

  var user = JSON.parse($.cookie('user'));
  var dimension1Value = "";
  var dimension2Value = "";
  var dimension3Value = "";
  var dimension4Value = "";
  var dimension5Value = "slog";
  var dimension6Value = "";
  var dimension7Value = "Rich Smith";
  var dimension8Value = "stranger-editorial-news";
  var dimension9Value = "";
  var dimension10Value = user ? user.type : "Guest";
  var dimension11Value = $.map($('.fish-butter'), function(val, i) {
      return $(val).data('adOid')
  }).join(",");
  ga('set', 'dimension1', dimension1Value); // calendar section
  ga('set', 'dimension2', dimension2Value); // location category
  ga('set', 'dimension3', dimension3Value); // location neighborhood
  ga('set', 'dimension4', dimension4Value); // location cuisine
  ga('set', 'dimension5', dimension5Value); // section
  ga('set', 'dimension6', dimension6Value); // category
  ga('set', 'dimension7', dimension7Value); // author
  ga('set', 'dimension8', dimension8Value); // targeting section
  ga('set', 'dimension9', dimension9Value); // location category
  ga('set', 'dimension10', dimension10Value); // user type
  ga('set', 'dimension11', dimension11Value); // native ads
  ga('send', 'pageview');
</script>


<style>
  a#sitewrap {
    position: absolute !important;
    max-height: 800px;
    max-width: 1380px;
    margin: 0 auto;
    bottom: 0;
    right: 0;
  }
</style>
<script>
  $(document).ready(function() {
    setTimeout(function() {
      if (!fix_background_ad_top()) {
        setTimeout(fix_background_ad_top, 3000);
      }
    }, 1000);
  });
  function fix_background_ad_top() {
    if ($("a#sitewrap").length) {
      var body_position = $("#site-header").position();
      var body_top = body_position.top;
      $("a#sitewrap").css("top",(body_top ? body_top : 0) + 114);
      return true;
    }
  }
</script>




<script>
  // track location categories
  var locationCategories = [];
  function trackLocationCategories(i) {
    ga('send', 'event', 'Custom Dimension Event', 'Location Page Categories', 'Location Page Categories', {nonInteraction: true, 'dimension9': locationCategories[i], 'metric1': 1});
  }
  for (var i = 0; i < locationCategories.length; i++) {
    setTimeout(trackLocationCategories(i), 3000);
  }
</script>

<script>
  $(function() {
    $("audio").bind("play", function(e){
      var source = ($(this).attr('src')) ? $(this).attr('src') : $(this).find('source').attr('src');
      ga('send', {
        hitType: 'event',
        eventCategory: 'Audio',
        eventAction: 'play',
        eventLabel: source
      });
    });
  });
</script>



<script type='text/javascript'>
    var _sf_async_config = _sf_async_config || {};
    /** CONFIGURATION START **/
    _sf_async_config.sections = 'slog';
    _sf_async_config.authors = 'Rich Smith';
    /** CONFIGURATION END **/
    (function(){
      function loadChartbeat() {
        window._sf_endpt=(new Date()).getTime();
        var e = document.createElement('script');
        e.setAttribute('language', 'javascript');
        e.setAttribute('type', 'text/javascript');
        e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
        document.body.appendChild(e);
      }
      var oldonload = window.onload;
      window.onload = (typeof window.onload != 'function') ?
        loadChartbeat : function() { oldonload(); loadChartbeat(); };
    })();
</script>


<!-- Start Quantcast tag -->

<script type="text/javascript">
  _qcJSHost = (("https:" == document.location.protocol) ? "https://secure." : "http://edge.");
  _qoptions={
    qacct:"p-aaXEgDiyQODdU"
  };
  document.write(unescape("%3Cscript src='" + _qcJSHost + "quantserve.com/quant.js' type='text/javascript'%3E%3C/script%3E"));
</script>
<noscript>
  <img src="https://secure.quantserve.com/pixel/p-aaXEgDiyQODdU.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast">
</noscript>
<!-- End Quantcast tag -->

<!-- Start Quantcast tag -->
<script type="text/javascript">
_qcJSHost = (("https:" == document.location.protocol) ? "https://secure." : "http://edge.");
 _qoptions={
   qacct:"p-a4LDpi_DEopn-"
 };
</script>
<noscript>
  <img src="https://secure.quantserve.com/pixel/p-a4LDpi_DEopn-.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast">
</noscript>
<!-- End Quantcast tag -->
  </body>
</html>
   
 

