 <!DOCTYPE html>
<html lang="en">
  <head>
    <!-- Google Tag Manager -->
  <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','dataLayer','GTM-5GMVQ6J');</script>
  <!-- End Google Tag Manager -->






<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=yes">
<meta name="google-site-verification" content="Yn7U5qsaj-oKD3y_qp7IbGawlVoNxW1Pzu87ZOHqabU">
<meta name="view-id" content="article">
<!-- start Omniconvert.com code -->
<link rel="dns-prefetch" href="//app.omniconvert.com" /> <script type="text/javascript">window._mktz=window._mktz||[];</script> <script src="//cdn.omniconvert.com/js/sd0d155.js"></script>
<!-- end Omniconvert.com code -->



<title>Slog PM: Kids Get the COVID Vaccine, Eighth Oregon County Votes to Join "Greater Idaho," Asian Giant Hornet Found in British Columbia - Slog - The Stranger</title>


  

  

  

  

  <meta name="twitter:card" content="summary_large_image" />
  <meta name="twitter:site" content="@thestranger" />
  <meta name="twitter:image" content="https://media2.fdncms.com/stranger/imager/u/original/62539940/1635985969-1601564989-gettyimages-1227833157.jpeg" />
  <meta property="og:title" content="Slog PM: Kids Get the COVID Vaccine, Eighth Oregon County Votes to Join &quot;Greater Idaho,&quot; Asian Giant Hornet Found in British Columbia" />
  <meta property="og:description" content="All local media can talk about today is the election: Which is understandable. My colleague Rich Smith has a ballot drop update for your ass right here. Read that then get back over to Slog Post Meridiem for some more news. West Seattle residents briefly marooned this morning: The Spokane Street swing bridge&mdash;which has been limited to buses, cyclists, truckers, and permitted drivers as the West Seattle Bridge is still closed for construction&mdash;got stuck before..." />
  <meta name="description" content="All local media can talk about today is the election: Which is understandable. My colleague Rich Smith has a ballot drop update for your ass right here. Read that then get back over to Slog Post Meridiem for some more news. West Seattle residents briefly marooned this morning: The Spokane Street swing bridge&mdash;which has been limited to buses, cyclists, truckers, and permitted drivers as the West Seattle Bridge is still closed for construction&mdash;got stuck before..." />
  <meta property="og:site_name" content="The Stranger" />
  <meta property="og:type" content="article" />
  <meta property="og:image" content="https://media2.fdncms.com/stranger/imager/u/original/62539940/1635985969-1601564989-gettyimages-1227833157.jpeg" />
  <meta property="article:publisher" content="https://www.facebook.com/strangerseattle" />
  
    
  
  <meta name="apple-mobile-web-app-title" content="Slog PM: Kids Get the COVID Vaccine, Eighth Oregon County Votes to Join "Greater Idaho," Asian Giant Hornet Found in British Columbia - Slog - The Stranger" />
  
    <link rel="apple-touch-icon-precomposed"  href="/images/mobile/touchicons/default/touch-icon-60.png" />
  
    <link rel="apple-touch-icon-precomposed" sizes="76x76" href="/images/mobile/touchicons/default/touch-icon-76.png" />
  
    <link rel="apple-touch-icon-precomposed" sizes="120x120" href="/images/mobile/touchicons/default/touch-icon-120.png" />
  
    <link rel="apple-touch-icon-precomposed" sizes="152x152" href="/images/mobile/touchicons/default/touch-icon-152.png" />
  

  <link rel="mask-icon" href="https://www.thestranger.com/assets/sites/stranger/images/site-badge.svg" color="#000000">
  <link rel="icon" type="image/x-icon" href="https://www.thestranger.com/assets/sites/stranger/images/favicon.png">

  
    <meta property="fb:app_id" content="43933993878"/>
  
  
    <meta property="fb:admins" content="741428065"/>
  
  
    <meta property="fb:pages" content="56439755991" />
  

  

  
  
  
    <link rel="canonical" href="https://www.thestranger.com/slog/2021/11/03/62535706/slog-pm-kids-get-the-covid-vaccine-eighth-oregon-county-votes-to-join-greater-idaho-asian-giant-hornet-found-in-british-columbia" />
    <meta property="og:url" content="https://www.thestranger.com/slog/2021/11/03/62535706/slog-pm-kids-get-the-covid-vaccine-eighth-oregon-county-votes-to-join-greater-idaho-asian-giant-hornet-found-in-british-columbia" />
  
  
   <link rel="alternate" type="application/rss+xml" title="The Stranger: Whole Site" href="/seattle/Rss.xml"/>

  <link rel="alternate" type="application/rss+xml" title="The Stranger: Slog Section" href="/seattle/Rss.xml?section=529161"/>


  
    <link rel="alternate" type="application/rss+xml" title="The Stranger: Articles by Jas Keimig" href="/seattle/Rss.xml?author=32434319"/>
 

<!-- revved -->

<link href="https://www.thestranger.com/assets/build/css/styles.a4d2e2e5.css" rel="stylesheet">

<link rel="stylesheet" href="https://use.fontawesome.com/baf88c5825.css">


<!-- jQuery (necessary for Bootstrap's JavaScript plugins) -->
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.11.0/jquery.min.js"></script>
<!-- Include all compiled plugins (below), or include individual files as needed -->
<script src="https://stackpath.bootstrapcdn.com/bootstrap/3.4.1/js/bootstrap.min.js" integrity="sha384-aJ21OjlMXNL5UyIl/XNwTMqvzeRMZH2w8c5cRVpzpU8Y5bApTppSuUkhZXN0VxHd" crossorigin="anonymous"></script>


<script src="/seattle/Library/Environment/JavascriptEnvironmentScript"></script>


  <script src="https://www.thestranger.com/assets/build/js/app.e765bde4.js"></script>


<!-- HTML5 Shim and Respond.js IE8 support of HTML5 elements and media queries -->
<!-- WARNING: Respond.js doesn't work if you view the page via file:// -->
<!--[if lt IE 9]>
  <script src="https://oss.maxcdn.com/libs/html5shiv/3.7.0/html5shiv.js"></script>
  <script src="https://oss.maxcdn.com/libs/respond.js/1.4.2/respond.min.js"></script>
<![endif]-->



  <!-- Hotjar Tracking Code for thestranger.com -->
  
  






<!--   typekit -->
<script type="text/javascript" src="//use.typekit.net/wjg1xbh.js"></script>
<script type="text/javascript">try{Typekit.load();}catch(e){}</script>







<script type='text/javascript'>
function getWidth() {
  if (self.innerHeight) {
    return self.innerWidth;
  }
  if (document.documentElement && document.documentElement.clientHeight) {
    return document.documentElement.clientWidth;
  }
  if (document.body) {
    return document.body.clientWidth;
  }
}
var documentWidth = getWidth();

var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
  var gads = document.createElement('script');
  gads.async = true;
  gads.type = 'text/javascript';
  var useSSL = 'https:' == document.location.protocol;
  gads.src = (useSSL ? 'https:' : 'http:') +
  '//www.googletagservices.com/tag/js/gpt.js';
  var node = document.getElementsByTagName('script')[0];
  node.parentNode.insertBefore(gads, node);
})();
</script>

<script type="text/javascript">
  // in gyrobase
  // $(document).ready(function() {
  //   if($('.fish-butter') && !navigator.userAgent.match(/bot|googlebot|crawler|spider|robot|crawling|PhantomJS|BingPreview/ig)){
  //     $('.fish-butter').each(function() {
  //       var xhr = new XMLHttpRequest();
  //       var data = {
  //         'oid': $(this).data('adOid'),
  //         'context': $(this).data('contextOid')
  //       }
  //       xhr.open('POST', '/_private/tracking/record-hit');
  //       xhr.setRequestHeader('Content-Type', 'application/json');
  //       xhr.setRequestHeader('X-CSRF-Token', getCookie('csrfToken'));
  //       xhr.onload = function() {
  //         var response = JSON.parse(xhr.responseText);
  //         if (xhr.status === 200) {
  //         } else {
  //         }
  //       };
  //       xhr.send(JSON.stringify(data));
  //     });
  //   }
  // });

  // in keen
  !function(name,path,ctx){
    var latest,prev=name!=='Keen'&&window.Keen?window.Keen:false;ctx[name]=ctx[name]||{ready:function(fn){var h=document.getElementsByTagName('head')[0],s=document.createElement('script'),w=window,loaded;s.onload=s.onerror=s.onreadystatechange=function(){if((s.readyState&&!(/^c|loade/.test(s.readyState)))||loaded){return}s.onload=s.onreadystatechange=null;loaded=1;latest=w.Keen;if(prev){w.Keen=prev}else{try{delete w.Keen}catch(e){w.Keen=void 0}}ctx[name]=latest;ctx[name].ready(fn)};s.async=1;s.src=path;h.parentNode.insertBefore(s,h)}}
  }('KeenAsync','https://d26b395fwzu5fz.cloudfront.net/keen-tracking-1.0.3.min.js',this);

  KeenAsync.ready(function(){
      // Configure a client instance
      var client = new KeenAsync({
        projectId: '58b718b78db53dfda8a8a0eb',
        writeKey: '326C65A94101E46B8EF1B20D83CA64E04F13DEEF29A28D5D7E39F4F5833AFB8F1E0C98E7836FB62A52269ECF45B4AF7C30417251B5A7EE01E34071751EB398A79E24280EEA32F15CC3D607C32274ABA72CD3C460A3F0EB9361D304A6F5391B91'
      });

      // Record views of sponsored posts
      if($('.fish-butter') && !navigator.userAgent.match(/bot|googlebot|crawler|spider|robot|crawling|PhantomJS|BingPreview/ig)){

        // in keen
        $('.fish-butter').each(function() {
          client.recordEvent('adViews', {
            publication: "stranger",
            ad: {
              oid: $(this).data('adOid')
            },
            placement: {
              oid: $(this).data('contextOid')
            },
            user_agent: navigator.userAgent,
            page_url: location.href,
            keen: {
              addons: [{
                name: "keen:ua_parser",
                input: {
                  ua_string: "user_agent"
                },
                output: "parsed_user_agent"
              },{
                name: "keen:url_parser",
                input: {
                  url: "page_url"
                },
                output: "parsed_page_url"
              },{
                name: "keen:date_time_parser",
                input: {
                  date_time: "keen.timestamp"
                },
                output: "timestamp_info"
              }]
            }
          });
        })

      }
    });
</script>


<script type="text/javascript">
     var _sf_async_config = _sf_async_config || {};
     /** CONFIGURATION START **/
     _sf_async_config.uid = 65679
     _sf_async_config.domain = "thestranger.com";
     _sf_async_config.useCanonical = true;
     /** CONFIGURATION END **/
     var _sf_startpt = (new Date()).getTime();
</script>
<script src="//static.chartbeat.com/js/chartbeat_mab.js"></script>
  </head>
  <body class="article  article-section-slog">
    <div class="wrapper">
      <div class="network-bar navbar hidden-xs navbar-expand-md navbar-dark bg-dark">
    <div class="container">
      <ul class="nav navbar-nav mr-auto">
        
          
            <li class="nav-item"><a class="nav-link" href="https://thestranger.com" target="self">The Stranger</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          
            <li class="nav-item"><a class="nav-link" href="https://portlandmercury.com" target="self">Portland Mercury</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          
            <li class="nav-item"><a class="nav-link" href="https://everout.com/stranger-seattle/" target="self">EverOut</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          
            <li class="nav-item"><a class="nav-link" href="https://savage.love/" target="self">Savage Love</a></li>
          
          
            <li class="nav-item nav-item-separator">|</li>
          
        
          
            <li class="nav-item"><a class="nav-link" href="https://humpfilmfest.com" target="self">Hump</a></li>
          
          
        
      </ul>
    </div>
  </div>


<div id="site-header" class="navbar navbar-default hidden-xs" role="navigation">
  <div id="top-nav">
    <div class="container">
      <div class="navbar-header">
        <a class="navbar-brand" href="https://www.thestranger.com/"><img src="https://www.thestranger.com/assets/sites/stranger/images/site-logo.png?2018-09-13-121404" alt="The Stranger"></a>
      </div> <!-- /.navbar-header -->

      <div class="navbar-collapse collapse">
        <ul id="nav-site" class="nav navbar-nav">
          <li id="nav-read" class="dropdown" style="margin-left:20px;">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">Things to Read <b class="caret"></b></a>
            <ul class="dropdown-menu" style="min-width:250px;">
              
              
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/sponsored/nowhiring" target="_self">
                    <span class="fish-nav"></span>
                    <i class="fa fa-star"></i>
                    Now Hiring
                  </a>
                </li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/sp-list/classifieds" target="_self">
                    <span class="fish-nav"></span>
                    <i class="fa fa-star"></i>
                    Classifieds
                  </a>
                </li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/sponsored/outdoor-dining" target="_self">
                    <span class="fish-nav"></span>
                    <i class="fa fa-star"></i>
                    Outdoor Dining
                  </a>
                </li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/slog" target="_self">
                    
                    <i class="fa fa-star"></i>
                    Slog: Seattle's Only Blog
                  </a>
                </li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/slog-ampm" target="_self">
                    
                    <i class="fa fa-star"></i>
                    Slog AM/PM
                  </a>
                </li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/sticker-patrol" target="_self">
                    
                    <i class="fa fa-star"></i>
                    Sticker Patrol
                  </a>
                </li>
              
                

                

                

                <li class="highlighted last">
                  <a data-silo="ttr" href="https://www.thestranger.com/electionheadquarters" target="_self">
                    
                    <i class="fa fa-star"></i>
                    Election Headquarters
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/" target="_self">
                    
                    
                    Home
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/savage-love" target="_self">
                    
                    
                    Savage Love
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/news" target="_self">
                    
                    
                    News
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/arts" target="_self">
                    
                    
                    Arts
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/geek" target="_self">
                    
                    
                    Comics<span class="lighter">&</span>Games
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/pride2021" target="_self">
                    
                    
                    Queer
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/unstreamable" target="_self">
                    
                    
                    Unstreamable
                  </a>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/food-and-drink" target="_self">
                    
                    
                    Food<span class="lighter">&</span>Drink
                  </a>
                </li>
              
            </ul>
          </li>

          <li id="nav-do" class="dropdown">
            <a href="#" class="dropdown-toggle" data-toggle="dropdown">Things to Do <b class="caret"></b></a>
            <ul class="dropdown-menu" style="min-width:250px;">
              
                <li class="everout-nav-item">
                  <a href="https://everout.com/seattle">
                    <img src="https://www.thestranger.com/assets/sites/everout/everout-logo.png?20190815172027" width="65%;" alt="EverOut">
                  </a>
                </li>
              
              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/seattle" target="_self">
                    
                    
                    Home
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/seattle/neighborhoods/" target="_self">
                    
                    
                    Neighborhoods at a Glance
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/seattle/articles/" target="_self">
                    
                    
                    Picks & Guides
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/seattle/events/?category=in-person" target="_self">
                    
                    
                    In-Person Events
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/seattle/events/" target="_self">
                    
                    
                    All Events
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/seattle/music/" target="_self">
                    
                    
                    Live Music
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/seattle/events/?category=food-drink" target="_self">
                    
                    
                    Food & Drink
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/seattle/events/?category=readings-talks" target="_self">
                    
                    
                    Readings & Talks
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/seattle/visual-art/" target="_self">
                    
                    
                    Visual Art
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/seattle/events/?category=performance" target="_self">
                    
                    
                    Performance
                  </a>
                </li>

              
                

                

                

                <li class="">
                  <a data-silo="ttd" href="https://everout.com/seattle/film/" target="_self">
                    
                    
                    Film
                  </a>
                </li>

              
            </ul>
          </li>
        </ul>

        

        <ul class="nav navbar-nav navbar-right">
          
            <style>
              
                .contribute-nav-item a {
                  color: blue!important
                }
              
              
                .contribute-nav-item a:hover {
                  color: black!important
                }
              
            </style>
            <li>
              <li class="non-dropdown contribute-nav-item">
                <a class="" data-context="desktop-nav" href="https://www.thestranger.com/contribute?utm_source=publication&utm_medium=top_nav&utm_campaign=top_nav" target="_self">Support The Stranger</a>
              </li>
            </li>
          
          <li id="topNavAccountMenu" class="dropdown nav-account">
            <a href="#" class="link-icon dropdown-toggle" data-toggle="dropdown"><i class="fa fa-user-circle-o"></i></span></a>
            <ul class="dropdown-menu nav-account-menu">
              <li><a href="https://post.thestranger.com/login">Log in</a></li>
              <li><a href="https://post.thestranger.com/login/create">Sign up</a></li>
            </ul>
          </li>
          <li id="navbar-search">
            <a href="#" class="link-icon"><i class="fa fa-search"></i></a>
            <form action="/search" id="navbar-search-form" class="navbar-form" role="search" required>
              <input name="q" id="q" type="text" class="form-control" placeholder="Search" name="srch-term" id="srch-term">
            </form>
          </li>
          
          
          <script>
            $('#filter-search-more').click(function() {
              if(!$(this).hasClass('collapsed')) {
                $('.more-text',this).html('More');
                $('i.fa',this).removeClass('fa-caret-up').addClass('fa-caret-down');
              } else {
                $('.more-text',this).html('Less');
                $('i.fa',this).removeClass('fa-caret-down').addClass('fa-caret-up');
              }
            });
            $("#navbar-search a.link-icon").click(function(){
              $(this).closest('.navbar-right').toggleClass("search-open");
              $(this).siblings("#navbar-search-form").toggle();
              if($(this).closest('.navbar-right').hasClass('search-open')) {
                $(this).siblings("#navbar-search-form").find('.form-control').focus();
              }
              return false;
            });
          </script>
        </ul>
      </div><!--/.navbar-collapse -->
    </div><!-- /.container -->
  </div><!-- /#top-nav -->
</div><!-- /#site-header -->

<div id="mobile-header" class="navbar navbar-default visible-xs hidden-lg hidden-md" role="navigation">
  <div id="mobile-nav">
    









<header class="mobile-nav" role="banner">
  <div class="navbar-header">
    <button type="button" id="mobileNavToggle" class="navbar-toggle collapsed" data-toggle="collapse" data-target=".main-navigation" style="float:right;">
      <div class="navbar-toggle-closed-label">
        
          <span class="navbar-toggle-label-text">Menu</span>
        
        <i class="fa fa-bars"></i>
      </div>
      <div class="navbar-toggle-open-label">
        
          <span class="navbar-toggle-label-text">Close</span>
        
        <i class="fa fa-times"></i>
      </div>
    </button>
    
    <a class="navbar-brand " href="https://www.thestranger.com/"><img src="https://www.thestranger.com/assets/sites/stranger/images/site-logo.png?2018-09-13-121404" alt="The Stranger"></a>
  </div>
  <nav class="navbar-collapse main-navigation collapse" role="navigation" style="height: 1px;max-height:none;">
    <div class="container">
      <div class="row">
        <div class="col-xs-12">
          <form action="https://post.thestranger.com/search" class="navbar-form navbar-right" role="search">
            <div class="form-group input-group">
              <input type="text" class="form-control" name="q" placeholder="Search">
              <span class="input-group-btn">
                <button type="submit" class="btn btn-default"><i class="fa fa-search"></i></button>
              </span>
            </div>
          </form>
        </div>
      </div>
      <div class="row">
        <div class="col-xs-6" style="padding-right:0;">
          <ul class="nav navbar-nav">
            <li class="dropdown-header" style="padding-left:0;">Things To Read</li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/sponsored/nowhiring" target="_self">
                  <i class="fa fa-star"></i> 
                  <span class="fish-nav"></span>
                  Now Hiring</a></li>
                </li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/sp-list/classifieds" target="_self">
                  <i class="fa fa-star"></i> 
                  <span class="fish-nav"></span>
                  Classifieds</a></li>
                </li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/sponsored/outdoor-dining" target="_self">
                  <i class="fa fa-star"></i> 
                  <span class="fish-nav"></span>
                  Outdoor Dining</a></li>
                </li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/slog" target="_self">
                  <i class="fa fa-star"></i> 
                  
                  Slog: Seattle's Only Blog</a></li>
                </li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/slog-ampm" target="_self">
                  <i class="fa fa-star"></i> 
                  
                  Slog AM/PM</a></li>
                </li>
              
                

                

                

                <li class="highlighted">
                  <a data-silo="ttr" href="https://www.thestranger.com/sticker-patrol" target="_self">
                  <i class="fa fa-star"></i> 
                  
                  Sticker Patrol</a></li>
                </li>
              
                

                

                

                <li class="highlighted last">
                  <a data-silo="ttr" href="https://www.thestranger.com/electionheadquarters" target="_self">
                  <i class="fa fa-star"></i> 
                  
                  Election Headquarters</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/" target="_self">
                  
                  
                  Home</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/savage-love" target="_self">
                  
                  
                  Savage Love</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/news" target="_self">
                  
                  
                  News</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/arts" target="_self">
                  
                  
                  Arts</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/geek" target="_self">
                  
                  
                  Comics<span class="lighter">&</span>Games</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/pride2021" target="_self">
                  
                  
                  Queer</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/unstreamable" target="_self">
                  
                  
                  Unstreamable</a></li>
                </li>
              
                

                

                

                <li class="">
                  <a data-silo="ttr" href="https://www.thestranger.com/food-and-drink" target="_self">
                  
                  
                  Food<span class="lighter">&</span>Drink</a></li>
                </li>
              
            <li><a href="/issues">Print Archives</a></li>
          </ul>
        </div>
        <div class="col-xs-6">
          <ul class="nav navbar-nav">
            <li class="dropdown-header" style="padding-left:0;">Things To Do</li>

              
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/seattle" target="_self">
                
                
                Home</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/seattle/neighborhoods/" target="_self">
                
                
                Neighborhoods at a Glance</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/seattle/articles/" target="_self">
                
                
                Picks & Guides</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/seattle/events/?category=in-person" target="_self">
                
                
                In-Person Events</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/seattle/events/" target="_self">
                
                
                All Events</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/seattle/music/" target="_self">
                
                
                Live Music</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/seattle/events/?category=food-drink" target="_self">
                
                
                Food & Drink</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/seattle/events/?category=readings-talks" target="_self">
                
                
                Readings & Talks</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/seattle/visual-art/" target="_self">
                
                
                Visual Art</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/seattle/events/?category=performance" target="_self">
                
                
                Performance</a></li>
              </li>

            
                

                

                

              <li class="">
                <a data-silo="ttd" href="https://everout.com/seattle/film/" target="_self">
                
                
                Film</a></li>
              </li>

            
          </ul>
        </div>
      </div>
      <div class="row">
        
          <div class="col-xs-6">
            <ul class="nav navbar-nav">
              <li class="dropdown-header" style="padding-left:0;">Other Things</li>
              
                <li><a href="https://www.thestranger.com/contribute" target="_self">Support The Stranger</a></li>
              
                <li><a href="https://www.thestranger.com/ad-info" target="_self">Ad Info & Rates</a></li>
              
                <li><a href="http://www.strangertickets.com" target="_blank">Stranger Tickets</a></li>
              
            </ul>
          </div>
        
        <div id="mobileNavAccountMenu" class="col-xs-6 nav-account">
          <ul class="nav navbar-nav nav-account-menu">
            <li class="dropdown-header" style="padding-left:0;">Account</li>
            <li><a href="https://post.thestranger.com/login">Log in</a></li>
            <li><a href="https://post.thestranger.com/login/create">Sign up</a></li>
          </ul>
        </div>
      </div>
    </div> <!-- end container -->
  </nav>
  <script>
    $('#mobileNavToggle').click(function() {
      var menuAction = $(this).hasClass('collapsed') ? 'openMenu' : 'closeMenu';
      ga('send', {
        hitType: 'event',
        eventCategory: 'MobileNav',
        eventAction: ''+menuAction+''
      });
      $(this).toggleClass('collapsed');
    });
    $('.mobile-nav .nav li a').click(function() {
      var navLabel = $(this).data('silo')+'-'+$(this).text();
      ga('send', {
        hitType: 'event',
        eventCategory: 'MobileNav',
        eventAction: 'click',
        eventLabel: ''+navLabel+''
      });
    });
  </script>
</header>

  </div>
</div>
      <div class="top-super text-center component container">
  <div id="div-gpt-ad-top-super"></div>
  <div id="div-gpt-ad-mobile-top"></div>
</div>
      <div id="siteContent" class="container">
        <div class="row" class="main">
          <div class="col-sm-12 col-md-8 primary">
  
  <div id="articleComponent-62535706" class="component">

    

     <div class="blog-header slog">
  <h1><a href="https://www.thestranger.com/slog"><img id="slogLogo" src="" class="img-responsive slog-logo"></a></h1>
</div>
    
    
    <div id="article-62535706" class="article coll_slog-am-pm">
      <div id="article-header-62535706" class="article-header">
        
          <div class="post-tags-and-date">
            
              <div class="label topic">
                
                  <a href="https://www.thestranger.com/archive/slog-am-pm">Slog AM/PM</a>
                  
                
              </div>
            
          </div>
        
        <h1 class="headline">
          <strong>Slog PM:</strong> Kids Get the COVID Vaccine, Eighth Oregon County Votes to Join "Greater Idaho," Asian Giant Hornet Found in British Columbia
          
        </h1>
        <h2 class="subheadline">
          
        </h2>
        <div class="byline">
          
            by <a href="https://www.thestranger.com/authors/32434319/jasmyne-keimig">Jas Keimig</a>
            
              &bull;
            
          
          
            <span class="post-time">
              Nov  3, 2021 at  6:00 pm
            </span>
          
        </div>
        
        
        
          
        
      </div> <!-- end .article-header -->

      <div class="article-text category-slog">
        
        

        <div class="social-tools text-right" style="margin-bottom:10px;position:relative;">
          
          <div class="fb-like"
            data-href="https://www.thestranger.com/slog/2021/11/03/62535706/slog-pm-kids-get-the-covid-vaccine-eighth-oregon-county-votes-to-join-greater-idaho-asian-giant-hornet-found-in-british-columbia"
            data-layout="button_count"
            data-action="like"
            data-show-faces="true"
            data-share="true" style="margin-right:10px;position:relative;top:-5px;"></div>
          
          <a class="twitter-share-button" href="https://twitter.com/share"
            data-url="https://www.thestranger.com/slog/2021/11/03/62535706/slog-pm-kids-get-the-covid-vaccine-eighth-oregon-county-votes-to-join-greater-idaho-asian-giant-hornet-found-in-british-columbia"
            data-text="Slog PM: Kids Get the COVID Vaccine, Eighth Oregon County Votes to Join &quot;Greater Idaho,&quot; Asian Giant Hornet Found in British Columbia">
          Tweet
          </a>
          <script>
          window.twttr=(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],t=window.twttr||{};if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);t._e=[];t.ready=function(f){t._e.push(f);};return t;}(document,"script","twitter-wjs"));
          </script>
          <a style="position:relative;top:-5px;" href="//www.reddit.com/submit?url=https%3A//www.thestranger.com/slog/2021/11/03/62535706/slog-pm-kids-get-the-covid-vaccine-eighth-oregon-county-votes-to-join-greater-idaho-asian-giant-hornet-found-in-british-columbia" target="_blank"><img src="//www.redditstatic.com/spreddit5.gif" alt="submit to reddit" border="0" /></a>
        </div>

        

        
        

        
        
        
        
        
          
          
          
          
          
          
            
            
            
            
              
              <div class="blogImageCenter img-responsive" style="width:700px"><img src="https://media2.fdncms.com/stranger/imager/u/original/62539940/1635985969-1601564989-gettyimages-1227833157.jpeg" alt="Ive said this before, and Ill say it again: I think Asian giant hornets are kinda cute." title="Ive said this before, and Ill say it again: I think Asian giant hornets are kinda cute. "><div class="image-caption-and-credit"><span class="imageCaption">I've said this before, and I'll say it again: I think Asian giant hornets are kinda cute. </span> <span class="imageCredit">KAREN DUCEY/GETTY</span></div></div><strong>All local media can talk about today is the election:</strong> Which is understandable. My colleague Rich Smith has a ballot drop update for your ass <a href="https://www.thestranger.com/slog/2021/11/03/62536826/ballot-drop-update-hasegawa-scoots-ahead-of-steinbrueck-in-port-race-seattle-progressives-still-way-down">right here</a>. Read that then get back over to Slog Post Meridiem for some more news.</p>
              <div class="row fish-butter article-inline-native-wrapper" data-context-oid="62510124" data-ad-oid="62510110">

      <div class="fish-tag row article-inline-native-tag">
          Sponsored
      </div>

      <div class="row">
        <div class="col article-inline-native-inner-wrapper">
          

          
            <div class="col-xs-3 article-inline-native-image">
              <a href="https://post.thestranger.com/seattle/clickclick?adoid=62510110&poid=62510124&url=https%3A//srweek.org/charliesproduce/" class="image-link" rel="nofollow">
                <img src="https://media2.fdncms.com/stranger/imager/u/original/62510109/original-copy_of_everout_newsletter_10_28_field_to_fork_.jpg" class="img-fluid">
              </a>
            </div>
          

          
          <div class="col-xs-9">
            <div class="row article-inline-native-headline">
              <a href="https://post.thestranger.com/seattle/clickclick?adoid=62510110&poid=62510124&url=https%3A//srweek.org/charliesproduce/" rel="nofollow">
                Get to know the people and processes that play an essential role in building a vibrant, sustainable, and inclusive local food economy.
              </a>
              
            </div>

            
              <div class="row article-inline-native-body">
                The Field to Fork podcast takes you on a deep dive into the local food systems of the Puget Sound region
              </div>
            
          </div>
          
        </div>
      </div>
    </div>
            
              
               <p><strong>West Seattle residents briefly marooned this morning:</strong> The Spokane Street swing bridge—which has been limited to buses, cyclists, truckers, and permitted drivers as the West Seattle Bridge is still closed for construction—got stuck before reopening around 10 am, <a href="https://www.seattletimes.com/seattle-news/transportation/west-seattles-lower-swing-bridge-back-open-after-getting-stuck/">reports</a> the <em>Seattle Times</em>. The lower bridge is set to receive "major rehab work" later this year. West Seattle Blog has some <a href="https://westseattleblog.com/2021/11/traffic-road-work-transit-weather-post-election-wednesday/">pics</a> of the whole kerfuffle. </p>
              <div class="interstitial-ad-1 ad pull-right">
                      <div id="div-gpt-ad-mobile-inline-1" class="interstitial-ad  inline-ad"></div>
                    </div>
            
              
               <p><strong>More of Oregon wants to join Idaho:</strong> 63% of Harney County, OR voters approved a non-binding measure to join them to the "<a href="https://www.greateridaho.org/">Greater Idaho</a>" movement, <a href="https://www.opb.org/article/2021/11/03/another-oregon-county-signals-support-to-join-greater-idaho/">reports</a> OPB. For those of you blissfully unaware of "Greater Idaho," the plan would have Idaho "absorb about three-quarters of Oregon’s land as well as a portion of Northern California." The reason being that the Gem State's ~*~**~conservative values~~*~* are more desirable than the antifa anarchy going down in Portland. Its chances of actually happening are <a href="https://www.usatoday.com/story/news/nation/2021/06/20/rural-oregon-would-join-idaho-under-long-shot-greater-idaho-movement/7626820002/">slim to none</a>.</p>
              
            
              
              
          <a name="more"></a>
          <p><strong>Another day, another cat saved from the <a href="https://www.capitolhillseattle.com/2021/11/thanks-to-canopy-cat-rescue-ella-the-capitol-hill-cat-is-safely-back-home-after-an-adventure-high-above-volunteer-park/">tree canopy</a> above Volunteer Park:</strong> I thought this was something that only happened in movies? Why do cats climb that high? (I'm allergic and have absolutely no knowledge of these creatures' habits.)</p>
              <div class="interstitial-ad-2 ad pull-right">
                      <div id="div-gpt-ad-mobile-inline-2" class="interstitial-ad  inline-ad"></div>
                    </div>
            
              
               <p><strong>A group of children aged 5 to 11 are the first young kids in Washington to get their COVID-19 vaccines:</strong> Ten kids rolled up their sleeves to receive their Pfizer vaccine at Shoreline Community College today, reports <a href="https://www.seattletimes.com/seattle-news/health/first-covid-vaccines-for-kids-5-to-11-administered-in-washington-state-though-doses-might-be-limited-at-first/"><em>Seattle Times</em></a>. The state is expecting to receive 230,000 kid-sized doses from the feds, "with an additional 86,000 doses scheduled to arrive at pharmacies." These doses are limited for now, but if you have a kiddo in your life who needs one, you can get on a waiting list or snag an appointment <a href="https://www.uwmedicine.org/coronavirus/vaccine">here</a>. <blockquote class="twitter-tweet"><p lang="en" dir="ltr">Nervous smiles spread throughout the room as children lined up to be among some of Washington state’s first 5- to 11-year-olds to receive Pfizer’s pediatric vaccine.<br><br>UW received 5,700 doses of the pediatric dose and will start administering to the community tomorrow. <a href="https://t.co/shO2a8CHEO">pic.twitter.com/shO2a8CHEO</a><br />— amandamsnyder (@amandamsnyder) <a href="https://twitter.com/amandamsnyder/status/1456039548945776640?ref_src=twsrc%5Etfw">November 3, 2021</a></blockquote> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
              
            
              
               <p><strong>Diablo Dam Powerhouse is back up and running: </strong>After Seattle City Light had to shut it down four days ago thanks to a rockslide last Thursday, which "tore away the slide-protection fencing and supporting poles and cables," <a href="https://www.king5.com/article/news/local/seattle/seattle-city-light-restarts-turbines-after-rockslides-at-diablo-dam/281-0a778c9b-0eb8-493f-b240-689456aba65f">reports</a> KING 5. </p>
              <div class="interstitial-ad-3 ad pull-right">
                      <div id="div-gpt-ad-mobile-inline-3" class="interstitial-ad  inline-ad"></div>
                    </div>
            
              
               <p><strong>Before asking William Shatner, Jeff Bezos apparently offered Tom Hank a seat on his Blue Origin rocket:</strong> Hanks turned him down. The reason? The richest man in the world wanted him to <a href="https://www.cnn.com/2021/11/03/entertainment/tom-hanks-jeff-bezos-space/index.html">cough up $28 million</a> for the ride, Hanks told Jimmy Kimmel yesterday. Whatever Jeff!</p>
              
            
              
               <p><strong>Horny break:</strong> Get caught up looking at Carroll Dunham's (yes, Lena Dunham's dad) latest suite of work, <em><a href="https://www.presenhuber.com/viewing-room/carroll-dunham#tab-1:thumbnails;tab-2:thumbnails;tab-3:thumbnails">Qualiascope</a></em>, now showing at Galerie Eva Presenhuber in Zurich. They are erotic paintings and drawings of people fucking, rendered in a very green green. The essay accompanying the work by Mary Simpson describes the figures as "either thousands of years old, or dropped from outer space, or perhaps teleported from an ancient future." I can't stop looking at their nipples!</p>
              <div class="interstitial-ad-4 ad pull-right">
                      <div id="div-gpt-ad-mobile-inline-4" class="interstitial-ad  inline-ad"></div>
                    </div>
            
              
               <p><strong>Lol, America:</strong> According to <a href="https://apnews.com/article/donald-trump-elections-presidential-elections-legislature-virginia-523be44d4f3e6a672f0d232caeb6deb6?utm_medium=AP_Politics&utm_campaign=SocialFlow&utm_source=Twitter">AP News</a>, there are "at least six state or local political candidates" who attended the infamous Stop the Steal rally on January 6 that now are elected to office. While none are accused of committing any crimes or breaching the Capitol building on that fateful day, at least one does not regret attending Trump's incendiary rally. </p>
              
            
              
               <p><strong>But some good news:</strong> Progressive Michelle Wu is the <a href="https://www.cnbc.com/2021/11/03/michelle-wu-makes-history-as-first-woman-elected-mayor-of-boston.html">first woman as well as the first person of color</a> to become mayor of Boston. For 200 years, only white dudes have been elected to run Beantown, and now the daughter of Taiwanese immigrants (and Elizabeth Warren's <a href="https://wbznewsradio.iheart.com/content/sen-warren-on-wus-win-i-knew-she-was-terrific-from-the-very-beginning/">protégé</a>, I might add) has been elected to do the job. </p>
              <div class="interstitial-ad-5 ad pull-right">
                      <div id="div-gpt-ad-mobile-inline-5" class="interstitial-ad  inline-ad"></div>
                    </div>
            
              
               <p><strong>More good news: </strong>Democrat Phil Murphy has narrowly won <a href="https://www.reuters.com/world/us/democratic-new-jersey-governor-phil-murphy-wins-re-election-ap-2021-11-03/">reelection</a> for New Jersey governor against GOP challenger Jack Ciattarelli. </p>
              
            
              
               <p><strong>Weather break:</strong> Bundle up kids! <blockquote class="twitter-tweet"><p lang="en" dir="ltr">A frontal system will move through the area tonight and Thursday morning—blustery winds will develop on Thursday as the low pressure area moves ashore. Here's a nice image midday Wednesday, Nov. 3rd—it certainly looks like November in the northeast Pacific. <a href="https://t.co/i1bCirS63J">pic.twitter.com/i1bCirS63J</a><br />— NWS Seattle (@NWSSeattle) <a href="https://twitter.com/NWSSeattle/status/1455987258633310209?ref_src=twsrc%5Etfw">November 3, 2021</a></blockquote> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
              <div class="interstitial-ad-6 ad pull-right">
                      <div id="div-gpt-ad-mobile-inline-6" class="interstitial-ad  inline-ad"></div>
                    </div>
            
              
               <p><strong>I'm getting whiplash from Biden's social spending bill:</strong> Now, four weeks of paid leave is back ON the table, after the Dems got rid of it to appease the moderate and noted narcissists Sens. Kyrsten Sinema and Joe Manchin last week. Senate Majority Leader Nancy Pelosi pushed for paid leave's re-inclusion, with supporters like Sen. Kirsten Gillibrand right behind her, <a href="https://www.businessinsider.com/paid-family-medical-leave-back-in-democrats-social-soending-bill-2021-11">reports</a> Business Insider. Can't wait to see what they whittle it down to next week!</p>
              <div class="fish-butter article-inline-native" data-context-oid="41865832" data-ad-oid="41865831">
      <h3 class="article-inline-text">
        <a href="https://post.thestranger.com/seattle/clickclick?adoid=41865831&poid=41865832&url=https%3A//www.thestranger.com/contribute%3Futm_source%3Dpublication%26utm_medium%3Darticle_inline%26utm_campaign%3Dinline_ampm" target="_blank" rel="nofollow">
          Love Slog AM/PM?
        </a>
      </h3>
      <div>
        <a href="https://post.thestranger.com/seattle/clickclick?adoid=41865831&poid=41865832&url=https%3A//www.thestranger.com/contribute%3Futm_source%3Dpublication%26utm_medium%3Darticle_inline%26utm_campaign%3Dinline_ampm" target="_blank" rel="nofollow" style="font-size:1rem;font-weight:normal;">
          More than ever, <em>The Stranger</em> is relying on your contributions to help fund our coverage. With a one-time or recurring contribution, you can support local, independent media and help keep columns like Slog AM/PM around.
        </a>
      </div>
    </div>
            
              
               <p><strong>Another Asian giant hornet found across the border in British Columbia: </strong>Washington state entomologists say they found the hornet in a trap "well within flight distance from where Asian Giant hornet nests were found and destroyed in Washington," <a href="https://komonews.com/news/local/asian-giant-hornet-found-in-british-columbia-well-within-flight-distance-from-us-nests">reports</a> KOMO. But B.C. province's "resident bee expert" says that residents shouldn't worry as it likely came from one of the nests that U.S. officials have already eradicated. They should be more concerned if DNA analysis determine the hornet did not come from those nests which would "increase the likelihood the invasive insects are breeding and spreading in B.C.," <a href="https://www.cbc.ca/news/canada/british-columbia/asian-giant-hornet-caught-in-bc-1.6235581">reports</a> CBC. Party!</p>
              
            
              
               <p><strong>The six finalists in Washington Transportation Commission's contest to name our new ferry are:</strong> Wishkah, Stillaguamish, Snoqualmie, Stehekin, Muckleshoot and Enie Marie. The <em>Seattle Times</em> has some <a href="https://www.seattletimes.com/seattle-news/whew-finalists-chosen-for-naming-that-new-washington-state-ferry-but-some-quibbles-remain/">background</a> on all the names chosen to advance to the final round after the commission extended the search because too many <a href="https://www.seattletimes.com/seattle-news/the-pete-carroll-sir-floats-a-lot-with-zero-submissions-meeting-criteria-washington-state-extends-naming-new-ferry/">jokey names</a> had been submitted.  You've got until November 12 to <a href="https://pacificmarketresearch.opinioninsight.com/portal/community_1_1_1.php">choose your preference</a> (after registering with the Ferry Riders' Opinion Group), with the commission set to vote on a name on December 14. </p>
              
            
              
               <p><strong>For your listening pleasure:</strong> I know I posted one of their songs recently, but I'm going to see Yves Tumor perform live tonight and I really hope they play "Super Stars." <iframe width="560" height="315" src="https://www.youtube.com/embed/VMM5In5YT68" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
              
            
           

        

        
        

        

        

        
          <div class="row fish-butter article-inline-native-wrapper" data-context-oid="62158115" data-ad-oid="62158114">

      <div class="fish-tag row article-inline-native-tag">
          Sponsored
      </div>

      <div class="row">
        <div class="col article-inline-native-inner-wrapper">
          

          
            <div class="col-xs-3 article-inline-native-image">
              <a href="https://post.thestranger.com/seattle/clickclick?adoid=62158114&poid=62158115&url=https%3A//www.seattlerelief.com/" class="image-link" rel="nofollow">
                <img src="https://media2.fdncms.com/stranger/imager/u/original/62158113/original-stranger_125x90px.png" class="img-fluid">
              </a>
            </div>
          

          
          <div class="col-xs-9">
            <div class="row article-inline-native-headline">
              <a href="https://post.thestranger.com/seattle/clickclick?adoid=62158114&poid=62158115&url=https%3A//www.seattlerelief.com/" rel="nofollow">
                The City of Seattle is offering one-time financial assistance to low-income Seattle residents impacted by COVID-19.
              </a>
              
            </div>

            
          </div>
          
        </div>
      </div>
    </div>
        

      </div> <!-- end .article-text -->

      
      
      
        
          <div id="mc_embed_signup" style="padding: 30px 10px; background:#fff;font:15px Georgia,serif;width:100%; font-weight: normal; text-align: center;">
<form action="https://thestranger.us4.list-manage.com/subscribe?u=739a0d2f2ff0031156e7b3d55&amp;id=f02129603b" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" target="_blank" novalidate="">
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL" style="font-weight: normal; padding: 5px;">To get this delivered to your inbox, subscribe to <i>The Stranger</i>'s Slog AM newsletter.</label>
<div class="input-group" style=" width=100%; max-width:400px; margin: 0 auto;">
<input type="hidden" name="group[19329][4]" value="checked">
<input class="form-control" type="email" value="" name="EMAIL" id="mce-EMAIL" placeholder="email address" required="" style="border-radius: 4px;border-bottom-right-radius: 0;border-top-right-radius: 0;">
<div style="position: absolute; left: -5000px;" aria-hidden="true">
<input type="text" name="b_739a0d2f2ff0031156e7b3d55_67f93c78f9" tabindex="-1" value=""></div>
<span class="input-group-btn"><button class="btn btn-default" style="font-weight: normal;" type="submit" value="Subscribe" name="subscribe">Subscribe</span></div></div></form></div>
        
      

      
      
        <script id="fdncms-carousel-top-stories-video" src="https://www.hub.fdncms.com/gyrobase/Responsive/Components/Content/TopStoriesVideo?cb=72fc8652&key=bc2394029788a572f638c2af9ed8678a&req=js" async></script>
      

    </div> <!-- end .article -->

    <!-- article-contribution-footer -->
    
    
      <div class="article-contribution-footer">
        <em>The Stranger</em> depends on your continuing support to provide articles like this one. In return, we pledge our ongoing commitment to truthful, progressive journalism and serving our community. So if you’re able, please consider a small recurring contribution. Thank you—you are appreciated!
        <div style="margin-top:1rem;"><a href="/contribute?utm_source=publication&utm_medium=article_footer&utm_campaign=footer_ask" class="btn btn-danger btn-large">CONTRIBUTE NOW</a></div>
      </div>
    
    <!-- article-contribution-footer -->

    

    <div class="row social-tools" style="margin-top:1.5em; clear:both;">
      <div class="col-xs-12 col-sm-5 text-center lg-social-btn">
        <a href="http://www.facebook.com/sharer.php?u=https%3A//www.thestranger.com/slog/2021/11/03/62535706/slog-pm-kids-get-the-covid-vaccine-eighth-oregon-county-votes-to-join-greater-idaho-asian-giant-hornet-found-in-british-columbia&amp;t=Slog+PM%3A+Kids+Get+the+COVID+Vaccine%2C+Eighth+Oregon+County+Votes+to+Join+%22Greater+Idaho%2C%22+Asian+Giant+Hornet+Found+in+British+Columbia" target="_blank" onclick="window.open(this.href, '_blank', 'toolbar=no, scrollbars=auto, resizable=yes, top=250, left=250, width=500, height=500'); return false;"><img class="img-responsive" src="/images/social/share-on-facebook.png" alt="Share on Facebook" style=""></a>
      </div>
      <div class="col-xs-12 col-sm-5 text-center lg-social-btn">
        <a href="http://twitter.com/intent/tweet?&amp;url=https%3A//www.thestranger.com/slog/2021/11/03/62535706/slog-pm-kids-get-the-covid-vaccine-eighth-oregon-county-votes-to-join-greater-idaho-asian-giant-hornet-found-in-british-columbia&amp;text=Slog+PM%3A+Kids+Get+the+COVID+Vaccine%2C+Eighth+Oregon+County+Votes+to+Join+%22Greater+Idaho%2C%22+Asian+Giant+Hornet+Found+in+British+Columbia&amp;related=strangerslog" target="_blank" onclick="window.open(this.href, '_blank', 'toolbar=no, scrollbars=auto, resizable=yes, top=250, left=250, width=500, height=500'); return false;"><img class="img-responsive" src="/images/social/share-on-twitter.png" alt="Share on Twitter" style=""></a>
      </div>
      
        <div class="col-xs-12 col-sm-2 text-center" style="padding-bottom:0.2em;">
          <h3 style="margin-top:5px;">
            
              <a href="/slog/2021/11/03/62535706/slog-pm-kids-get-the-covid-vaccine-eighth-oregon-county-votes-to-join-greater-idaho-asian-giant-hornet-found-in-british-columbia/comments" rel="nofollow"><i class="fa fa-comment"></i> <span class="comment-count">4</span></a>
            
          </h3>
        </div>
      
    </div>

    

    
    
      <div class="article-bio-wrapper">
        
          
          
            <div class="article-author-bio">

              <div class="row clearfix visible-xs">
      <div class="col-xs-12">
        
          <div class="author-bio-image pull-right">
            <img src="https://media1.fdncms.com/stranger/imager/u/small/57365918/keimig_photo.png" class="img-responsive" loading="lazy">
          </div>
        
        <h4 class="author-bio-name"><b>Jas Keimig</b></h4>
        
          <p>Jas Keimig is a staff writer at <em>The Stranger</em>, where they cover visual art, film, stickers, and culture.</p>
        
        <div class="author-social-links pull-left">
          
            <a href="https://www.twitter.com/jasmynekeimig" class="author-link btn btn-default"><i class="fa fa-twitter" title="Twitter"></i> Follow</a>
          
          
            <a href="mailto:jkeimig@thestranger.com" class="author-link btn btn-default"><i class="fa fa-envelope" title="Email"></i> Email</a>
          
          
            <a href="https://www.thestranger.com/authors/32434319/jasmyne-keimig" class="author-link btn btn-default">More articles</a>
          
          
        </div>
      </div>
    </div>

    
    <div class="row clearfix hidden-xs">
      
        <div class="col-sm-3">
          <div class="author-bio-image">
            <img src="https://media1.fdncms.com/stranger/imager/u/small/57365918/keimig_photo.png" class="img-responsive" loading="lazy">
          </div>
        </div>
      
      
      <div class="col-sm-9">
        <h2 class="author-bio-name">Jas Keimig</h2>
        
          <p>Jas Keimig is a staff writer at <em>The Stranger</em>, where they cover visual art, film, stickers, and culture.</p>
        
        <div class="author-social-links">
          
            <a href="https://www.twitter.com/jasmynekeimig" class="author-link btn btn-default"><i class="fa fa-twitter" title="Twitter"></i> Follow</a>
          
          
            <a href="mailto:jkeimig@thestranger.com" class="author-link btn btn-default"><i class="fa fa-envelope" title="Email"></i> Email</a>
          
          
            <a href="https://www.thestranger.com/authors/32434319/jasmyne-keimig" class="author-link btn btn-default">More articles</a>
          
          
        </div>
      </div>
    </div>
            </div>
          
        
      </div>
    

    
      

      
    

    <div class="component related-content" style="padding:1em 0; border-bottom:1px solid #ddd; margin-bottom:1em;">
        <h2 style="margin:0 0 0.5em; padding-top: 25px; border-top: 1px solid #ddd">You might also be interested in these:</h2>
        
        
        <div class="related-content-row" style="padding:0.5em 0;">
        
          <h3 class="headline">
            <a href="https://www.thestranger.com/slog/2021/11/03/62536826/ballot-drop-update-hasegawa-scoots-ahead-of-steinbrueck-in-port-race-seattle-progressives-still-way-down" rel="nofollow"><strong>Ballot Drop Update:</strong> Hasegawa Scoots Ahead of Steinbrueck in Port Race, Seattle Progressives Still Way Down</a>
          </h3>
          
          
            <div class="byline">
              by <a href="https://www.thestranger.com/authors/19407358/rich-smith">Rich Smith</a>
            </div>
          
        
      </div>
        
      
        
        <div class="related-content-row" style="padding:0.5em 0;">
        
          <h3 class="headline">
            <a href="https://www.thestranger.com/slog/2021/11/03/62530972/a-hallucinogenic-alternate-universe-rave-in-fremont" rel="nofollow">A Hallucinogenic, Alternate-Universe Rave in Ballard</a>
          </h3>
          
            <h4 class="subheadline">
              Black Dice turned the party out at Substation on Monday night.
            </h4>
          
          
            <div class="byline">
              by <a href="https://www.thestranger.com/authors/12963/dave-segal">Dave Segal</a>
            </div>
          
        
      </div>
        
      
        
        <div class="related-content-row" style="padding:0.5em 0;">
        
          <h3 class="headline">
            <a href="https://www.thestranger.com/slog/2021/11/03/62506890/eternals-review-not-gay-enough" rel="nofollow"><Strong><em>Eternals</em> Review:</strong> Not Gay Enough</a>
          </h3>
          
          
            <div class="byline">
              by <a href="https://www.thestranger.com/authors/21647307/matt-baume">Matt Baume</a>
            </div>
          
        
      </div>
        
      
          </div>

    <br>
    <div id="div-gpt-ad-mobile-bottom" class="interstitial-ad"></div>
    <div id="div-gpt-ad-bottom" class="interstitial-ad"></div>
    

  </div> <!-- end component -->
</div>
<div class="col-sm-12 col-md-4 secondary">
  <!-- stranger content sidebar ads -->
<div class="article-sidebar sidebar-ads text-right">
  
    <div class="sidebar-ad-1">
      <div id="div-gpt-ad-sidebar-1" class="sidebar-ad"></div>
    </div>
  
    <div class="sidebar-ad-2">
      <div id="div-gpt-ad-sidebar-2" class="sidebar-ad"></div>
    </div>
  
    <div class="sidebar-ad-3">
      <div id="div-gpt-ad-sidebar-3" class="sidebar-ad"></div>
    </div>
  
    <div class="sidebar-ad-4">
      <div id="div-gpt-ad-sidebar-4" class="sidebar-ad"></div>
    </div>
  
    <div class="sidebar-ad-5">
      <div id="div-gpt-ad-sidebar-5" class="sidebar-ad"></div>
    </div>
  
    <div class="sidebar-ad-6">
      <div id="div-gpt-ad-sidebar-6" class="sidebar-ad"></div>
    </div>
  
</div>
</div>
        </div>
        <div class="row">
          <div class="col-sm-12">
            <div class="bottom-super text-center">
  <div id="div-gpt-ad-bottom-super" class="gpt-dfp"></div>
</div>
          </div>
        </div>
      </div><!-- /#siteContent -->
      <div id="site-footer">
        <link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
  #mc_embed_signup{
    clear:left;
    font:14px Helvetica,Arial,sans-serif;
    width:100%;
  }

  #mc_embed_signup .button{
    background-color: #16698E;
  }
  /* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
     We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>

<div class="hidden-xs hidden-sm">
  <div id="footer-features">
    <div class="container">
      <div class="footer-row">
        <!-- Begin Mailchimp Signup Form -->

        
          <div id="mc_embed_signup">
            <form action="https://thestranger.us4.list-manage.com/subscribe/post?u=739a0d2f2ff0031156e7b3d55&amp;id=f02129603b" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
              <div id="mc_embed_signup_scroll">
                <label for="mce-EMAIL">
                  <h2 style="text-align: center; color: black; font-family: futura-pt,Helvetica Neue,Helvetica,Arial,sans-serif; margin-top:0px">The Stranger in your inbox</h2>
                </label>
                <input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>
                <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
                <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_739a0d2f2ff0031156e7b3d55_f02129603b" tabindex="-1" value=""></div>
                <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
              </div>
            </form>
          </div>
        

        <!--End mc_embed_signup-->
      </div>
    </div>
  </div>
</div><!-- footer (hidden-xs hidden-sm) -->

      
        









<div class="hidden-xs hidden-sm">
  <div id="footer-features-2">
    <div class="container">
      <div class="footer-row">
        
          <div class="col col-md-4 text-center">
        
            <h4>Publication Info</h4>
              <ul class="list-unstyled">
                <li><a href="https://www.thestranger.com/masthead">Masthead</a></li>
                <li><a href="https://www.thestranger.com/ad-info">Ad Info &amp; Rates</a></li>
                
                <li><a href="https://www.thestranger.com/jobs">Jobs at The Stranger</a></li>
                <li><a href="https://www.thestranger.com/contact-information">Contact</a></li>
                <li><a href="https://everout.com/">EverOut</a></li>
                <li><br></li>
                <li><a href="https://www.thestranger.com/contribute?utm_source=publication&utm_medium=footer_nav&utm_campaign=footer_nav">Contribute</a></li>
              </ul>
          </div>

        
          <div class="col col-md-4 text-center" style="border-right: solid 1px white; border-left: solid 1px white;">
            <h4>Check it out</h4>
            
              <div class="footer-promo" id="" style="margin-left:0">
                <a href="https://www.savagelovecast.com">
                  
                    <img src="https://media1.fdncms.com/stranger/imager/u/original/61758119/savage-188x80.jpg" alt="Savage Lovecast">
                  
                </a>
              </div>
            
              <div class="footer-promo" id="" style="margin-left:0">
                <a href="https://everout.com/seattle/">
                  
                    <img src="https://media2.fdncms.com/stranger/imager/u/original/57533353/eo_sea.png" alt="EverOut Seattle">
                  
                </a>
              </div>
            
              <div class="footer-promo" id="" style="margin-left:0">
                <a href="/sp-list/contests">
                  
                    <img src="https://media1.fdncms.com/stranger/imager/u/original/39759991/checkitout_button-contests.png" alt="The Stranger Contests and Giveaways">
                  
                </a>
              </div>
            
          </div>
        

        <div class="col col-md-4 text-center">
          <h4>Follow Us</h4>
          
              <ul id="footer-social-links" class="list-unstyled text-left">
            
            
            <li><a href="/syndication" target="_blank"><i class="fa fa-rss"></i> RSS</a></li>
            
          
            
            <li><a href="http://www.facebook.com/strangerseattle" target="_blank"><i class="fa fa-facebook"></i> Facebook</a></li>
            
          
            
            <li><a href="/twitter" target="_blank"><i class="fa fa-twitter"></i> Twitter</a></li>
            
          
            
            <li><a href="http://instagram.com/thestrangerseattle" target="_blank"><i class="fa fa-instagram"></i> Instagram</a></li>
            
          
              </ul>
            
        </div>

      </div>
    </div>
  </div>
</div><!-- footer (hidden-xs hidden-sm) -->

      
        

<div class="hidden-xs hidden-sm">
  <div id="footer-copyright">
    <div class="container">
      <div class="footer-row">
        <div class="col-md-6">
          <div class="footer-brand">
            
              <a href="https://www.thestranger.com/"><img src="https://www.thestranger.com/assets/sites/stranger/images/site-logo.png?2018-09-13-121404" alt="The Stranger"></a>
            
          </div>
          
          <p class="footer-copyright">
            
              All contents &copy; Index Newspapers LLC<br>
800 Maynard Ave S, Suite 200, Seattle, WA 98134
            
          </p>
        </div>
        <div class="col-md-6">
          <p class="footer-links text-right">
            <a href="https://www.thestranger.com/contact-information">Contact</a>
            <span class="lighter separater">|</span>
            <a href="https://www.thestranger.com/privacy-policy">Privacy Policy</a>
            <span class="lighter separater">|</span>
            <a href="https://www.thestranger.com/terms-of-use">Terms of Use</a>
            <span class="lighter separater">|</span>
            <a href="https://www.thestranger.com/takedown-policy">Takedown Policy</a>
          </p>
        </div>
      </div>
    </div>
  </div>
</div> <!-- footer (hidden-xs hidden-sm) -->

      
        

<div id="footer-mobile"  class="hidden-md hidden-lg">
  <div class="container">
    <div class="footer-row">
      <div class="col-sm-12 text-center">
        <div id="footer-mobile-social-links">
          
            <a href="/syndication" target="_blank"><i class="fa fa-rss"></i></a>
          
            <a href="http://www.facebook.com/strangerseattle" target="_blank"><i class="fa fa-facebook"></i></a>
          
            <a href="/twitter" target="_blank"><i class="fa fa-twitter"></i></a>
          
            <a href="http://instagram.com/thestrangerseattle" target="_blank"><i class="fa fa-instagram"></i></a>
          
        </div>
        <div class="footer-brand">
          
            <a href="https://www.thestranger.com/"><img src="https://www.thestranger.com/assets/sites/stranger/images/site-logo.png?2018-09-13-121404" alt="The Stranger"></a>
          
        </div>
        
        <p class="footer-copyright">
          
            All contents &copy; Index Newspapers LLC<br>
800 Maynard Ave S, Suite 200, Seattle, WA 98134
          
        </p>
        <p class="footer-links">
          <small>
            <a href="https://www.thestranger.com/contact-information">Contact</a> |
            <a href="https://www.thestranger.com/privacy-policy">Privacy Policy</a> |
            <a href="https://www.thestranger.com/terms-of-use">Terms of Use</a> |
            <a href="https://www.thestranger.com/takedown-policy">Takedown Policy</a>
          </small>
        </p>
      </div>
    </div>
  </div>
</div> <!-- /footer-mobile -->
      </div> <!-- /#site-footer -->
    </div> <!-- /.wrapper -->
    <!-- content background ad -->
<div id="div-gpt-ad-background"></div>

      
        


 






















<script>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</script>








<div id="fb-root"></div>

  <script>
    window.fbAsyncInit = function() {
      FB.init({
        appId      : '43933993878',
        xfbml      : true,
        version    : 'v2.6'
      });
    };
  </script>

<script>(function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
    fjs.parentNode.insertBefore(js, fjs);
  }(document, 'script', 'facebook-jssdk'));</script>


<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-332219-1', 'auto');
  ga('require', 'linkid', 'linkid.js');
  ga('set', 'anonymizeIp', true);

  var user = JSON.parse($.cookie('user'));
  var dimension1Value = "";
  var dimension2Value = "";
  var dimension3Value = "";
  var dimension4Value = "";
  var dimension5Value = "slog";
  var dimension6Value = "";
  var dimension7Value = "Jas Keimig";
  var dimension8Value = "stranger-editorial-slog-ampm";
  var dimension9Value = "";
  var dimension10Value = user ? user.type : "Guest";
  var dimension11Value = $.map($('.fish-butter'), function(val, i) {
      return $(val).data('adOid')
  }).join(",");
  ga('set', 'dimension1', dimension1Value); // calendar section
  ga('set', 'dimension2', dimension2Value); // location category
  ga('set', 'dimension3', dimension3Value); // location neighborhood
  ga('set', 'dimension4', dimension4Value); // location cuisine
  ga('set', 'dimension5', dimension5Value); // section
  ga('set', 'dimension6', dimension6Value); // category
  ga('set', 'dimension7', dimension7Value); // author
  ga('set', 'dimension8', dimension8Value); // targeting section
  ga('set', 'dimension9', dimension9Value); // location category
  ga('set', 'dimension10', dimension10Value); // user type
  ga('set', 'dimension11', dimension11Value); // native ads
  ga('send', 'pageview');
</script>




<script>
  // track location categories
  var locationCategories = [];
  function trackLocationCategories(i) {
    ga('send', 'event', 'Custom Dimension Event', 'Location Page Categories', 'Location Page Categories', {nonInteraction: true, 'dimension9': locationCategories[i], 'metric1': 1});
  }
  for (var i = 0; i < locationCategories.length; i++) {
    setTimeout(trackLocationCategories(i), 3000);
  }
</script>

<script>
  $(function() {
    $("audio").bind("play", function(e){
      var source = ($(this).attr('src')) ? $(this).attr('src') : $(this).find('source').attr('src');
      ga('send', {
        hitType: 'event',
        eventCategory: 'Audio',
        eventAction: 'play',
        eventLabel: source
      });
    });
  });
</script>



<script type='text/javascript'>
    var _sf_async_config = _sf_async_config || {};
    /** CONFIGURATION START **/
    _sf_async_config.sections = 'slog';
    _sf_async_config.authors = 'Jas Keimig';
    /** CONFIGURATION END **/
    (function(){
      function loadChartbeat() {
        window._sf_endpt=(new Date()).getTime();
        var e = document.createElement('script');
        e.setAttribute('language', 'javascript');
        e.setAttribute('type', 'text/javascript');
        e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
        document.body.appendChild(e);
      }
      var oldonload = window.onload;
      window.onload = (typeof window.onload != 'function') ?
        loadChartbeat : function() { oldonload(); loadChartbeat(); };
    })();
</script>


<!-- Start Quantcast tag -->

<script type="text/javascript">
  _qcJSHost = (("https:" == document.location.protocol) ? "https://secure." : "http://edge.");
  _qoptions={
    qacct:"p-aaXEgDiyQODdU"
  };
  document.write(unescape("%3Cscript src='" + _qcJSHost + "quantserve.com/quant.js' type='text/javascript'%3E%3C/script%3E"));
</script>
<noscript>
  <img src="https://secure.quantserve.com/pixel/p-aaXEgDiyQODdU.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast">
</noscript>
<!-- End Quantcast tag -->

<!-- Start Quantcast tag -->
<script type="text/javascript">
_qcJSHost = (("https:" == document.location.protocol) ? "https://secure." : "http://edge.");
 _qoptions={
   qacct:"p-a4LDpi_DEopn-"
 };
</script>
<noscript>
  <img src="https://secure.quantserve.com/pixel/p-a4LDpi_DEopn-.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast">
</noscript>
<!-- End Quantcast tag -->
  </body>
</html>
   
 

